summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-10-03 09:57:09 +0000
committerTim Harder <radhermit@gentoo.org>2012-10-03 09:57:09 +0000
commit44f497471f87569b21db02819da06bd7bdf3b758 (patch)
tree992a08a99baadb835900a2e5620089f16a000899
parentVersion bump. (diff)
downloadhistorical-44f497471f87569b21db02819da06bd7bdf3b758.tar.gz
historical-44f497471f87569b21db02819da06bd7bdf3b758.tar.bz2
historical-44f497471f87569b21db02819da06bd7bdf3b758.zip
Version bump.
Package-Manager: portage-2.2.0_alpha134/cvs/Linux x86_64
-rw-r--r--media-gfx/apngasm/ChangeLog7
-rw-r--r--media-gfx/apngasm/apngasm-2.7.ebuild33
-rw-r--r--media-gfx/apngdis/ChangeLog7
-rw-r--r--media-gfx/apngdis/apngdis-2.5.ebuild31
-rw-r--r--media-gfx/apngopt/ChangeLog7
-rw-r--r--media-gfx/apngopt/apngopt-1.2.ebuild32
-rw-r--r--media-gfx/pngcrush/ChangeLog7
-rw-r--r--media-gfx/pngcrush/pngcrush-1.7.38.ebuild38
8 files changed, 158 insertions, 4 deletions
diff --git a/media-gfx/apngasm/ChangeLog b/media-gfx/apngasm/ChangeLog
index b8d39f8d980e..d09d06c692e2 100644
--- a/media-gfx/apngasm/ChangeLog
+++ b/media-gfx/apngasm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/apngasm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/apngasm/ChangeLog,v 1.7 2012/05/05 07:00:20 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/apngasm/ChangeLog,v 1.8 2012/10/03 09:52:37 radhermit Exp $
+
+*apngasm-2.7 (03 Oct 2012)
+
+ 03 Oct 2012; Tim Harder <radhermit@gentoo.org> +apngasm-2.7.ebuild:
+ Version bump.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> apngasm-2.5.ebuild,
apngasm-2.6.ebuild:
diff --git a/media-gfx/apngasm/apngasm-2.7.ebuild b/media-gfx/apngasm/apngasm-2.7.ebuild
new file mode 100644
index 000000000000..d0b11ee0abb4
--- /dev/null
+++ b/media-gfx/apngasm/apngasm-2.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/apngasm/apngasm-2.7.ebuild,v 1.1 2012/10/03 09:52:37 radhermit Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="create an APNG from multiple PNG files"
+HOMEPAGE="http://sourceforge.net/projects/apngasm/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libpng[apng]
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDLIBS="$($(tc-getPKG_CONFIG) --libs libpng --libs zlib)" ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc readme.txt
+}
diff --git a/media-gfx/apngdis/ChangeLog b/media-gfx/apngdis/ChangeLog
index 103af3dfa065..06ba55dbaefd 100644
--- a/media-gfx/apngdis/ChangeLog
+++ b/media-gfx/apngdis/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/apngdis
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/apngdis/ChangeLog,v 1.4 2012/05/05 07:00:24 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/apngdis/ChangeLog,v 1.5 2012/10/03 09:54:13 radhermit Exp $
+
+*apngdis-2.5 (03 Oct 2012)
+
+ 03 Oct 2012; Tim Harder <radhermit@gentoo.org> +apngdis-2.5.ebuild:
+ Version bump.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> apngdis-2.3.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/media-gfx/apngdis/apngdis-2.5.ebuild b/media-gfx/apngdis/apngdis-2.5.ebuild
new file mode 100644
index 000000000000..d01bf06fe30d
--- /dev/null
+++ b/media-gfx/apngdis/apngdis-2.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/apngdis/apngdis-2.5.ebuild,v 1.1 2012/10/03 09:54:13 radhermit Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="extract PNG frames from an APNG"
+HOMEPAGE="http://sourceforge.net/projects/apngdis/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDLIBS="-lz" ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc readme.txt
+}
diff --git a/media-gfx/apngopt/ChangeLog b/media-gfx/apngopt/ChangeLog
index a73693b90cff..e8ae9f66c85a 100644
--- a/media-gfx/apngopt/ChangeLog
+++ b/media-gfx/apngopt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/apngopt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/apngopt/ChangeLog,v 1.5 2012/05/05 07:00:23 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/apngopt/ChangeLog,v 1.6 2012/10/03 09:55:32 radhermit Exp $
+
+*apngopt-1.2 (03 Oct 2012)
+
+ 03 Oct 2012; Tim Harder <radhermit@gentoo.org> +apngopt-1.2.ebuild:
+ Version bump.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> apngopt-1.0.ebuild,
apngopt-1.1.ebuild:
diff --git a/media-gfx/apngopt/apngopt-1.2.ebuild b/media-gfx/apngopt/apngopt-1.2.ebuild
new file mode 100644
index 000000000000..04e57adbbaa3
--- /dev/null
+++ b/media-gfx/apngopt/apngopt-1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/apngopt/apngopt-1.2.ebuild,v 1.1 2012/10/03 09:55:32 radhermit Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="optimize APNG images"
+HOMEPAGE="http://sourceforge.net/projects/apng/"
+SRC_URI="mirror://sourceforge/apng/APNG_Optimizer/${PV}/${P}-src.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDLIBS="$($(tc-getPKG_CONFIG) --libs zlib)" ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc readme.txt
+}
diff --git a/media-gfx/pngcrush/ChangeLog b/media-gfx/pngcrush/ChangeLog
index 3feda2e9c5c2..df5c3207db64 100644
--- a/media-gfx/pngcrush/ChangeLog
+++ b/media-gfx/pngcrush/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/pngcrush
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngcrush/ChangeLog,v 1.96 2012/09/02 04:05:39 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngcrush/ChangeLog,v 1.97 2012/10/03 09:57:09 radhermit Exp $
+
+*pngcrush-1.7.38 (03 Oct 2012)
+
+ 03 Oct 2012; Tim Harder <radhermit@gentoo.org> +pngcrush-1.7.38.ebuild:
+ Version bump.
*pngcrush-1.7.37 (02 Sep 2012)
diff --git a/media-gfx/pngcrush/pngcrush-1.7.38.ebuild b/media-gfx/pngcrush/pngcrush-1.7.38.ebuild
new file mode 100644
index 000000000000..f6aac4f5876b
--- /dev/null
+++ b/media-gfx/pngcrush/pngcrush-1.7.38.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/pngcrush/pngcrush-1.7.38.ebuild,v 1.1 2012/10/03 09:57:09 radhermit Exp $
+
+EAPI=4
+
+MY_P=${P}-nolib
+
+inherit toolchain-funcs
+
+DESCRIPTION="Portable Network Graphics (PNG) optimizing utility"
+HOMEPAGE="http://pmt.sourceforge.net/pngcrush/"
+SRC_URI="mirror://sourceforge/pmt/${MY_P}.tar.xz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=">=media-libs/libpng-1.4:0
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC)" \
+ CFLAGS="${CFLAGS} -Wall" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ dohtml ChangeLog.html
+}