summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Laue <brad@gentoo.org>2003-07-20 03:37:58 +0000
committerBrad Laue <brad@gentoo.org>2003-07-20 03:37:58 +0000
commit4eef635ad2a343e892747bcea10161071bd233b1 (patch)
treee0743f7e08bcae422fd64bdd3923369c52e8f967
parentperm fixes (diff)
downloadhistorical-4eef635ad2a343e892747bcea10161071bd233b1.tar.gz
historical-4eef635ad2a343e892747bcea10161071bd233b1.tar.bz2
historical-4eef635ad2a343e892747bcea10161071bd233b1.zip
mark stable on x86
-rw-r--r--net-www/mozilla-firebird/ChangeLog9
-rw-r--r--net-www/mozilla-firebird/Manifest4
-rw-r--r--net-www/mozilla-firebird/mozilla-firebird-0.6-r6.ebuild14
3 files changed, 16 insertions, 11 deletions
diff --git a/net-www/mozilla-firebird/ChangeLog b/net-www/mozilla-firebird/ChangeLog
index 7b092af0bc58..ebb1239d585b 100644
--- a/net-www/mozilla-firebird/ChangeLog
+++ b/net-www/mozilla-firebird/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-www/mozilla-firebird
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird/ChangeLog,v 1.11 2003/07/18 04:47:12 brad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird/ChangeLog,v 1.12 2003/07/20 03:37:51 brad Exp $
+
+ 19 Jul 2003; Brad Laue <brad@gentoo.org> mozilla-firebird-0.6-r6.ebuild:
+ Mark stable on x86. Bugs fixed:
+
+ - -ffast-math is now filtered out, clears preferences bug
+ - Builds properly without chatzilla and other such bloat
+ - Builds on 2.6 kernels (see previous entry)
18 Jul 2003; Brad Laue <brad@gentoo.org> mozilla-firebird-0.6-r6.ebuild:
Build fix on 2.6 series kernels.
diff --git a/net-www/mozilla-firebird/Manifest b/net-www/mozilla-firebird/Manifest
index 4180ca49616f..86aa7dcbef7a 100644
--- a/net-www/mozilla-firebird/Manifest
+++ b/net-www/mozilla-firebird/Manifest
@@ -1,7 +1,7 @@
MD5 8ca497e8450db916c56c95ea96fcbfc9 mozilla-firebird-0.6-r4.ebuild 4713
MD5 febebab06fcb3cc7cf269e565795436d mozilla-firebird-0.6-r5.ebuild 4948
-MD5 6e32c6938be81b5380229b8b49cb00c9 ChangeLog 2169
-MD5 29ec2925b0611adebb3b2bd6661fafc9 mozilla-firebird-0.6-r6.ebuild 5081
+MD5 354413bd8534fc50004005594a084be0 ChangeLog 2451
+MD5 c44058fad41573d4ce34592bc3f00bc9 mozilla-firebird-0.6-r6.ebuild 5139
MD5 6e4352482ed149b3b9aca78d83de1124 files/MozillaFirebird 753
MD5 78b9eef353e1aff29cef379e4de6b9fa files/digest-mozilla-firebird-0.6-r4 81
MD5 78b9eef353e1aff29cef379e4de6b9fa files/digest-mozilla-firebird-0.6-r5 81
diff --git a/net-www/mozilla-firebird/mozilla-firebird-0.6-r6.ebuild b/net-www/mozilla-firebird/mozilla-firebird-0.6-r6.ebuild
index 552562cdf7a3..33ffbb7e0e44 100644
--- a/net-www/mozilla-firebird/mozilla-firebird-0.6-r6.ebuild
+++ b/net-www/mozilla-firebird/mozilla-firebird-0.6-r6.ebuild
@@ -1,22 +1,19 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird/mozilla-firebird-0.6-r6.ebuild,v 1.2 2003/07/18 04:47:12 brad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla-firebird/mozilla-firebird-0.6-r6.ebuild,v 1.3 2003/07/20 03:37:51 brad Exp $
-inherit makeedit flag-o-matic gcc nsplugins
+inherit makeedit flag-o-matic gcc nsplugins eutils
# Added to get MozillaFirebird to compile on sparc.
replace-sparc64-flags
-EMVER="0.65.2"
-IPCVER="1.0.0.1"
-
S=${WORKDIR}/mozilla
DESCRIPTION="The Mozilla Firebird Web Browser"
HOMEPAGE="http://www.mozilla.org/projects/firebird/"
SRC_URI="http://komodo.mozilla.org/pub/firebird/releases/${PV}/MozillaFirebird-${PV}-source.tar.bz2"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+KEYWORDS="x86 ~ppc ~sparc ~alpha"
SLOT="0"
LICENSE="MPL-1.1 | NPL-1.1"
IUSE="java gtk2 ipv6"
@@ -93,10 +90,11 @@ src_compile() {
--enable-strip-libs \
--enable-cpp-rtti \
--enable-xterm-updates \
- --enable-optimize=-O2 \
+ --enable-optimize=-O2 \
--disable-ldap \
--disable-toolkit-qt \
- --disable-toolkit-xlib"
+ --disable-toolkit-xlib \
+ --enable-extensions=default,-inspector,-irc,-venkman,-content-packs,-help"
if [ -n "`use gtk2`" ] ; then
myconf="${myconf} --enable-toolkit-gtk2 \