summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2012-09-05 19:08:19 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2012-09-05 19:08:19 +0000
commit747d9f40de05323884756408b5866a5d06a9ae2c (patch)
treefe7c4b386fd2bb0790dc9906783cd49373fba5fd
parentRedundant copy of BSD license (diff)
downloadhistorical-747d9f40de05323884756408b5866a5d06a9ae2c.tar.gz
historical-747d9f40de05323884756408b5866a5d06a9ae2c.tar.bz2
historical-747d9f40de05323884756408b5866a5d06a9ae2c.zip
initial import for net-mail/dbmail-3.x fixes bug #251063
Package-Manager: portage-2.1.11.12/cvs/Linux x86_64
-rw-r--r--dev-db/libzdb/ChangeLog8
-rw-r--r--dev-db/libzdb/Manifest4
-rw-r--r--dev-db/libzdb/libzdb-2.10.3.ebuild92
-rw-r--r--dev-db/libzdb/metadata.xml11
4 files changed, 115 insertions, 0 deletions
diff --git a/dev-db/libzdb/ChangeLog b/dev-db/libzdb/ChangeLog
new file mode 100644
index 000000000000..c6375342a1d8
--- /dev/null
+++ b/dev-db/libzdb/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-db/libzdb
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libzdb/ChangeLog,v 1.1 2012/09/05 19:08:19 lordvan Exp $
+
+ 05 Sep 2012; <lordvan@gentoo.org> libzdb-2.10.3.ebuild, metadata.xml:
+ using parts from ebuild from bug #251063 by Johan Bergström
+ <bugs@bergstroem.nu>
+
diff --git a/dev-db/libzdb/Manifest b/dev-db/libzdb/Manifest
new file mode 100644
index 000000000000..c6e5a67690cb
--- /dev/null
+++ b/dev-db/libzdb/Manifest
@@ -0,0 +1,4 @@
+DIST libzdb-2.10.3.tar.gz 600834 SHA256 8716d2cb3563478228f33de43e89857b3d190576be36a1f490dc245ffe60f959 SHA512 b2d358a4dbeddced3237aea02d94e6a60a089db10fb137c781389c735e27820f81697ea8e514ca13934b5dba3c3446db7140facaa7d03459f9a117b339fc343f WHIRLPOOL 8c10068502ab2d044f22a7c0de655b5779d9c8a82be7f7f2893fcd925abeb6dece7f0fd8c3dc8e20134310af8b51811cfeb6808065515b349aa461ba51adc812
+EBUILD libzdb-2.10.3.ebuild 2185 SHA256 f90eaa94965fe17815e9961fd322f2de305cb5193fcaa8e65655bece0dc89aff SHA512 ba41d3a22d69715d9baa1e34eaa3505ce2d78ef57e02f1d68b1b3838b8eecf0d78c577fba1d52f1c29abd51ba4447aebc8012507cff88781fcab8d06906f6889 WHIRLPOOL 580ac6024481579a64af4803de6e5b95c70e483cb3912966c9cebd84a2cad8adbe5f3b366e90c20950c5cccaee03ac1898108c7adb5f13adaac95bf808ed73b0
+MISC ChangeLog 359 SHA256 46368f368ed87da27fc3ac674a8d9922a113ec505209b7c2a1792f3570b484c5 SHA512 4647f152a61d4311dae2dce1031674ad2436b21edfd285cb43b82df7749312789b8871f550145e860ba6958fb017b2897f6d63a7349154f57d711bfb2cb0a0c0 WHIRLPOOL 05723e9c62b379aa3fb6bc998de212017ac49d5209491ce7f52c735c815ee6cf2f09d2bd3bcfcd4397e401581cd6c98a93ae05b226f860cdc1b856047a12146b
+MISC metadata.xml 309 SHA256 8f5a132d6406dce327ecff2f073400f62926b26e4a54287bf4780253b3fe07f2 SHA512 0d0106d6bd75b64c2f1e17be86dede1540400c45183c5038b327e226f6cce078ae893b8db17ca9283edc8b7eee625ea95e0d2e6874ce64b27354fed13c50bea2 WHIRLPOOL ac6c208c94ddc570fcb371b9d87851b9b1e0e50ae081547ee762ba986fe0e491c390b5081214caa93a817a3504bafe04a4cf582950f61d54fd9c9783e2b6071d
diff --git a/dev-db/libzdb/libzdb-2.10.3.ebuild b/dev-db/libzdb/libzdb-2.10.3.ebuild
new file mode 100644
index 000000000000..6e2e80b3eae4
--- /dev/null
+++ b/dev-db/libzdb/libzdb-2.10.3.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libzdb/libzdb-2.10.3.ebuild,v 1.1 2012/09/05 19:08:19 lordvan Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A thread safe high level multi-database connection pool library"
+HOMEPAGE="http://www.tildeslash.com/libzdb/"
+SRC_URI="http://www.tildeslash.com/${PN}/dist/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="debug doc mysql postgres +sqlite +sqliteunlock ssl static-libs"
+REQUIRED_USE=" || ( postgres mysql sqlite )"
+
+RDEPEND="mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql-base )
+ sqlite? ( >=dev-db/sqlite-3 )
+ sqliteunlock? ( >=dev-db/sqlite-3.6.12[unlock-notify] )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ sed -i -e "s|&& ./pool||g" test/Makefile.in || die
+}
+
+src_configure() {
+ ## TODO: check what --enable-optimized actually does
+ ## TODO: find someone with oracle db to add oci8 support
+ myconf=""
+ if [[ $(gcc-version) < 4.1 ]];then
+ myconf="${myconf} --disable-protected"
+ else
+ myconf="${myconf} --enable-protected"
+ fi
+
+ if ( use sqlite ); then
+ myconf="${myconf} --with-sqlite=${EPREFIX}/usr/"
+ if has_version 'dev-db/sqlite[unlock-notify]'; then
+ myconf="${myconf} --enable-sqliteunlock"
+ fi
+ else
+ myconf="${myconf} --without-sqlite"
+ fi
+
+ if use mysql; then
+ myconf="${myconf} --with-mysql=${EPREFIX}/usr/bin/mysql_config"
+ else
+ myconf="${myconf} --without-mysql"
+ fi
+
+ if use postgres; then
+ myconf="${myconf} --with-postgresql=${EPREFIX}/usr/bin/pg_config"
+ else
+ myconf="${myconf} --without-postgresql"
+ fi
+
+ econf \
+ $(use_enable debug profiling) \
+ $(use_enable static-libs static) \
+ $(use_enable ssl openssl) \
+ --without-oci \
+ ${myconf}
+}
+
+src_compile() {
+ default_src_compile
+ if use doc; then
+ emake doc
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # the --disable-static flag only skips .a
+ use static-libs || rm -f "${D}"/usr/lib*/libzdb.la
+
+ dodoc AUTHORS CHANGES README
+ if use doc;then
+ dohtml -r "${S}/doc/api-docs"/*
+ fi
+}
+
+src_test() {
+ emake verify
+}
diff --git a/dev-db/libzdb/metadata.xml b/dev-db/libzdb/metadata.xml
new file mode 100644
index 000000000000..9588cabe3a5e
--- /dev/null
+++ b/dev-db/libzdb/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+<maintainer>
+ <email>lordvan@gentoo.org</email>
+</maintainer>
+<use>
+ <flag name="sqliteunlock">Enable SQLite unlock notification api</flag>
+</use>
+</pkgmetadata>