summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2004-05-06 09:10:12 +0000
committerTavis Ormandy <taviso@gentoo.org>2004-05-06 09:10:12 +0000
commit74ba4ca09d75f279b83486be3a876d9c3dbae264 (patch)
treec487a303bb70750c6f4012c70419f4670ac167fc
parentgcj apparently works somewhere. go figure. (diff)
downloadhistorical-74ba4ca09d75f279b83486be3a876d9c3dbae264.tar.gz
historical-74ba4ca09d75f279b83486be3a876d9c3dbae264.tar.bz2
historical-74ba4ca09d75f279b83486be3a876d9c3dbae264.zip
adding .desktop file for gnome menus.
-rw-r--r--net-misc/putty/ChangeLog9
-rw-r--r--net-misc/putty/Manifest5
-rw-r--r--net-misc/putty/files/digest-putty-20040313-r11
-rw-r--r--net-misc/putty/files/putty.desktop10
-rw-r--r--net-misc/putty/putty-20040313-r1.ebuild72
5 files changed, 95 insertions, 2 deletions
diff --git a/net-misc/putty/ChangeLog b/net-misc/putty/ChangeLog
index 9055069e3247..7aee7e3ca84b 100644
--- a/net-misc/putty/ChangeLog
+++ b/net-misc/putty/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/putty
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.12 2004/04/17 15:14:10 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.13 2004/05/06 09:10:12 taviso Exp $
+
+*putty-20040313-r1 (06 May 2004)
+
+ 06 May 2004; Tavis Ormandy <taviso@gentoo.org> putty-20040313-r1.ebuild,
+ files/putty.desktop:
+ Thanks to Gustav Schaffter in #49577, putty will now appear in the
+ gnome applications menu.
17 Apr 2004; Tavis Ormandy <taviso@gentoo.org> putty-20040313.ebuild:
stable on x86
diff --git a/net-misc/putty/Manifest b/net-misc/putty/Manifest
index 18650fa994d1..1c0fa78498e1 100644
--- a/net-misc/putty/Manifest
+++ b/net-misc/putty/Manifest
@@ -1,6 +1,9 @@
MD5 27c2740c5ab57b401017d35b04b422db putty-20030902-r1.ebuild 1386
MD5 00299f5bd645fcf6682dd7633b61dbc8 putty-20040313.ebuild 1420
-MD5 c11ca20785e25b86b154522476ee9c24 ChangeLog 1727
+MD5 7789014df54172ce2ef6a100b1c0f939 putty-20040313-r1.ebuild 1571
+MD5 d1f3a64378af37065e86ca8001f8e62a ChangeLog 1956
MD5 a95f430323d2b9413a9ae45efb4d616c metadata.xml 549
MD5 d3c6f158244af5bb6cdd7bbda46e8dc6 files/digest-putty-20040313 71
+MD5 d3c6f158244af5bb6cdd7bbda46e8dc6 files/digest-putty-20040313-r1 71
+MD5 85355228c88a7a925e751df0f058f0ea files/putty.desktop 207
MD5 68c88474593f165e89a7cf28fe98f555 files/digest-putty-20030902-r1 70
diff --git a/net-misc/putty/files/digest-putty-20040313-r1 b/net-misc/putty/files/digest-putty-20040313-r1
new file mode 100644
index 000000000000..aaf7b059b130
--- /dev/null
+++ b/net-misc/putty/files/digest-putty-20040313-r1
@@ -0,0 +1 @@
+MD5 4c658a8e61933c3fea48ee684ef31dfe putty-cvs-20040313.tar.bz2 699018
diff --git a/net-misc/putty/files/putty.desktop b/net-misc/putty/files/putty.desktop
new file mode 100644
index 000000000000..0ce40261457c
--- /dev/null
+++ b/net-misc/putty/files/putty.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=PuTTY
+Comment[sv]=ssh, ftp och telnet klient
+Comment=ssh, ftp and telnet client
+Exec=/usr/bin/putty
+;Icon=
+Terminal=false
+Type=Application
+Categories=Application;Network;
diff --git a/net-misc/putty/putty-20040313-r1.ebuild b/net-misc/putty/putty-20040313-r1.ebuild
new file mode 100644
index 000000000000..5095c531d363
--- /dev/null
+++ b/net-misc/putty/putty-20040313-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/putty-20040313-r1.ebuild,v 1.1 2004/05/06 09:10:12 taviso Exp $
+
+inherit eutils
+
+DESCRIPTION="UNIX port of the famous Telnet and SSH client"
+
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/putty/"
+SRC_URI="mirror://gentoo/putty-cvs-${PV}.tar.bz2"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~ppc ~sparc"
+IUSE="doc"
+
+RDEPEND="=x11-libs/gtk+-1.2* virtual/x11"
+
+DEPEND="${RDEPEND} dev-lang/perl sys-apps/sed"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ # unpack the tarball...
+ unpack ${A}
+
+ # generate the makefiles
+ ebegin "Generating Makefiles"
+ cd ${S}; ${S}/mkfiles.pl
+ eend $?
+
+ # change the CFLAGS to those requested by user.
+ ebegin "Setting CFLAGS"
+ sed -i "s!-O2!${CFLAGS}!g" ${S}/unix/Makefile.gtk
+ eend $?
+}
+
+src_compile() {
+ # build putty.
+ einfo "Building putty..."
+ cd ${S}/unix; emake -f Makefile.gtk || die
+}
+
+src_install() {
+
+ cd ${S}/unix
+
+ # man pages...
+ doman plink.1 pterm.1 putty.1 puttytel.1
+
+ # binaries...
+ dobin plink pterm putty puttytel psftp pscp
+
+ cd ${S}
+
+ # docs...
+ dodoc README README.txt LICENCE CHECKLST.txt LATEST.VER website.url MODULE
+ use doc && dodoc doc/*
+
+ prepallman
+
+ # install desktop file provided by Gustav Schaffter in #49577
+ dodir /usr/share/applications
+ insinto /usr/share/applications
+ doins ${FILESDIR}/putty.desktop
+
+ if test ! -c /dev/ptmx; then
+ ewarn
+ ewarn "The pterm application requires kernel UNIX98 PTY support to operate."
+ ewarn
+ fi
+}