summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-20 05:20:37 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-20 05:20:37 +0000
commitcadc7cd088772bfbe2f25439d3b386f22fae0253 (patch)
treefe72a605402da0a7b33bc524a59594b9b8122bea
parentupdate snapshot (diff)
downloadhistorical-cadc7cd088772bfbe2f25439d3b386f22fae0253.tar.gz
historical-cadc7cd088772bfbe2f25439d3b386f22fae0253.tar.bz2
historical-cadc7cd088772bfbe2f25439d3b386f22fae0253.zip
update snapshot
Package-Manager: portage-2.0.51.22-r2
-rw-r--r--x11-misc/entrance/Manifest16
-rw-r--r--x11-misc/entrance/entrance-0.9.0.004.ebuild71
-rw-r--r--x11-misc/entrance/files/digest-entrance-0.9.0.0042
3 files changed, 87 insertions, 2 deletions
diff --git a/x11-misc/entrance/Manifest b/x11-misc/entrance/Manifest
index d2d0152fbe7d..3989fe722190 100644
--- a/x11-misc/entrance/Manifest
+++ b/x11-misc/entrance/Manifest
@@ -1,7 +1,19 @@
-MD5 68ff58a2c9237ecc80a013841dfd1b5e ChangeLog 1015
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 902528fcff68ba07fe2205f9b7dddb74 entrance-0.9.0.003.ebuild 2505
+MD5 58921dceb4b576e2140774ddcb2fc6bf entrance-0.9.0.004.ebuild 2082
MD5 088d07394fa8372e79b7757075ea4a7d metadata.xml 515
MD5 fb2c3677ba086d85367b1e18bceb4db7 entrance-9999.ebuild 2500
-MD5 902528fcff68ba07fe2205f9b7dddb74 entrance-0.9.0.003.ebuild 2505
+MD5 68ff58a2c9237ecc80a013841dfd1b5e ChangeLog 1015
MD5 8c2c9320269ef791ea0b6a00729a9104 files/digest-entrance-9999 64
+MD5 3a3eecf8051b90daf3798cea11a190a2 files/digest-entrance-0.9.0.004 136
MD5 e96746829116e24c379e88663da20667 files/no-listen-tcp.patch 711
MD5 a51d29aa09a1946b741bc92f713d5ce0 files/digest-entrance-0.9.0.003 136
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDBr3JgIKl8Uu19MoRAox1AJsEo67kz9CDS4j40hxc5L9utzXU7ACcDcPE
+VI+PwwBiUsBZMTDJSiwKOJw=
+=vvHO
+-----END PGP SIGNATURE-----
diff --git a/x11-misc/entrance/entrance-0.9.0.004.ebuild b/x11-misc/entrance/entrance-0.9.0.004.ebuild
new file mode 100644
index 000000000000..b9befc696863
--- /dev/null
+++ b/x11-misc/entrance/entrance-0.9.0.004.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/entrance/entrance-0.9.0.004.ebuild,v 1.1 2005/08/20 05:20:37 vapier Exp $
+
+inherit enlightenment eutils
+
+DESCRIPTION="next generation of Elogin, a login/display manager for X"
+HOMEPAGE="http://xcomputerman.com/pages/entrance.html"
+SRC_URI="${SRC_URI}
+ mirror://gentoo/extraicons-1.tar.bz2
+ http://wh0rd.de/gentoo/distfiles/extraicons-1.tar.bz2"
+
+IUSE="pam"
+
+DEPEND="virtual/x11
+ pam? ( sys-libs/pam )
+ >=dev-db/edb-1.0.5
+ >=x11-libs/evas-0.9.9
+ >=x11-libs/ecore-0.9.9
+ >=media-libs/edje-0.5.0
+ >=x11-libs/esmart-0.9.0"
+
+src_unpack() {
+ enlightenment_src_unpack
+ cd "${S}"
+ epatch ${FILESDIR}/no-listen-tcp.patch
+}
+
+src_compile() {
+ if use pam ; then
+ export MY_ECONF="--with-auth-mode=pam"
+ else
+ export MY_ECONF="--with-auth-mode=shadow"
+ fi
+ enlightenment_src_compile
+}
+
+src_install() {
+ enlightenment_src_install
+ rm -rf ${D}/etc/init.d
+ insinto /usr/share/entrance/images/sessions
+ doins ${WORKDIR}/extraicons/*
+ exeinto /usr/share/entrance
+ doexe data/config/build_config.sh
+
+ cd /etc/X11/Sessions
+ local edb="${D}/etc/entrance_config.db"
+ local count="`edb_ed ${edb} get /entrance/session/count int`"
+ local datadir="${D}/usr/share/entrance/images/sessions"
+ local icon=""
+ while [ ${count} -ge 0 ] ; do
+ edb_ed ${edb} del /entrance/session/${count}/icon
+ edb_ed ${edb} del /entrance/session/${count}/session
+ edb_ed ${edb} del /entrance/session/${count}/title
+ count=$((${count} - 1))
+ done
+ count=0
+ for s in default * failsafe ; do
+ [ "${s}" == "Xsession" ] && continue
+ icon="`find ${datadir} -iname ${s}.png -printf %f`"
+ if [ -z "${icon}" ] ; then
+ edb_ed ${edb} add /entrance/session/${count}/icon str default.png
+ else
+ edb_ed ${edb} add /entrance/session/${count}/icon str ${icon}
+ fi
+ edb_ed ${edb} add /entrance/session/${count}/session str ${s}
+ edb_ed ${edb} add /entrance/session/${count}/title str ${s}
+ count=$((${count} + 1))
+ done
+ edb_ed ${edb} add /entrance/session/count int ${count}
+}
diff --git a/x11-misc/entrance/files/digest-entrance-0.9.0.004 b/x11-misc/entrance/files/digest-entrance-0.9.0.004
new file mode 100644
index 000000000000..6d1943e6ae9b
--- /dev/null
+++ b/x11-misc/entrance/files/digest-entrance-0.9.0.004
@@ -0,0 +1,2 @@
+MD5 48d8999a5be31e4b089e0faf40bf9fd9 entrance-0.9.0.004.tar.gz 16901820
+MD5 b1d2a452028c3a09443d84968e24144c extraicons-1.tar.bz2 16770