summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2010-05-12 17:59:02 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2010-05-12 17:59:02 +0000
commitd331869d1e957496f2dc1d4c471cfa26b040984e (patch)
treedb792d715fcb08f5a26c46a8d6dff08c865f54f8
parentx86 stable wrt bug #316643 (diff)
downloadhistorical-d331869d1e957496f2dc1d4c471cfa26b040984e.tar.gz
historical-d331869d1e957496f2dc1d4c471cfa26b040984e.tar.bz2
historical-d331869d1e957496f2dc1d4c471cfa26b040984e.zip
Replace grep -P with more portable sed -ne equivalent
-rw-r--r--eclass/virtuoso.eclass4
1 files changed, 2 insertions, 2 deletions
diff --git a/eclass/virtuoso.eclass b/eclass/virtuoso.eclass
index 4c6fe16d6851..6622bf0ce7af 100644
--- a/eclass/virtuoso.eclass
+++ b/eclass/virtuoso.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/virtuoso.eclass,v 1.3 2010/04/06 17:28:31 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/virtuoso.eclass,v 1.4 2010/05/12 17:59:02 reavertm Exp $
# @ECLASS: virtuoso.eclass
# @MAINTAINER:
@@ -89,7 +89,7 @@ virtuoso_src_prepare() {
sed -e '/^# DISABLED \s*SUBDIRS\s*=/s/.*/SUBDIRS =/g' \
-i "${path}"/Makefile.am
# Append subdirs if not there already
- if [[ -z `grep --color=never -P "SUBDIRS\s*=.*${subdir}\b" "${path}"/Makefile.am` ]]; then
+ if [[ -z `sed -ne "/SUBDIRS\s*=.*${subdir}\b/p" "${path}"/Makefile.am` ]]; then
sed -e "/^SUBDIRS\s*=/s|$| ${subdir}|" \
-i "${path}"/Makefile.am || die "failed to append ${subdir}"
fi