summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-07-04 01:46:39 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-07-04 01:46:39 +0000
commit17e0e0caaf120fe75bdb42f174bd35aa58385e5b (patch)
tree7e2ef3df45d9f011326190439c87e8b8da6647aa /app-admin/diradm/diradm-2.4.ebuild
parentAdd in automount flag for new diradm. (diff)
downloadhistorical-17e0e0caaf120fe75bdb42f174bd35aa58385e5b.tar.gz
historical-17e0e0caaf120fe75bdb42f174bd35aa58385e5b.tar.bz2
historical-17e0e0caaf120fe75bdb42f174bd35aa58385e5b.zip
Version bump.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'app-admin/diradm/diradm-2.4.ebuild')
-rw-r--r--app-admin/diradm/diradm-2.4.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-admin/diradm/diradm-2.4.ebuild b/app-admin/diradm/diradm-2.4.ebuild
new file mode 100644
index 000000000000..4d8217441c3c
--- /dev/null
+++ b/app-admin/diradm/diradm-2.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/diradm/diradm-2.4.ebuild,v 1.1 2005/07/04 01:46:39 robbat2 Exp $
+
+DESCRIPTION="diradm is a nearly complete nss/shadow suite for managing POSIX users/groups/data in LDAP."
+HOMEPAGE="http://research.iat.sfu.ca/custom-software/diradm/"
+SRC_URI="${HOMEPAGE}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="samba irixpasswd automount"
+DEPEND="net-nds/openldap
+ sys-apps/gawk
+ sys-apps/coreutils
+ sys-apps/grep
+ dev-lang/perl
+ app-shells/bash
+ sys-apps/sed
+ perl-core/MIME-Base64
+ samba? (
+ dev-perl/Crypt-SmbHash
+ >=net-fs/samba-3.0.6
+ )"
+
+src_compile() {
+ local myconf
+ myconf="`use_enable samba` `use_enable automount` `use_enable irixpasswd`"
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc CHANGES* README AUTHORS COPYING ChangeLog NEWS README.prefork THANKS TODO
+ if use irixpasswd; then
+ insinto /etc/openldap/schema
+ doins irixpassword.schema
+ fi
+}
+
+pkg_postinst() {
+ einfo "The new diradm pulls many settings from your LDAP configuration."
+ einfo "But don't forget to customize /etc/diradm.conf for other settings."
+ einfo "Please see the README to instructions if you problems."
+}