summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZack Welch <zwelch@gentoo.org>2002-10-23 10:17:54 +0000
committerZack Welch <zwelch@gentoo.org>2002-10-23 10:17:54 +0000
commit1a8566150978f226a14183277424adc07a090020 (patch)
tree937449cb9bd101fe356fcbf96c6f685ec669f3c3 /app-admin/integrit
parentfixes bug #9424 (diff)
downloadhistorical-1a8566150978f226a14183277424adc07a090020.tar.gz
historical-1a8566150978f226a14183277424adc07a090020.tar.bz2
historical-1a8566150978f226a14183277424adc07a090020.zip
add new package app-admin/integrit-3.02.00, see bug 7831
Diffstat (limited to 'app-admin/integrit')
-rw-r--r--app-admin/integrit/ChangeLog9
-rw-r--r--app-admin/integrit/files/digest-integrit-3.02.001
-rw-r--r--app-admin/integrit/integrit-3.02.00.ebuild62
3 files changed, 72 insertions, 0 deletions
diff --git a/app-admin/integrit/ChangeLog b/app-admin/integrit/ChangeLog
new file mode 100644
index 000000000000..29a545495a3a
--- /dev/null
+++ b/app-admin/integrit/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/integrit/ChangeLog,v 1.1 2002/10/23 10:17:54 zwelch Exp $
+
+*integrit-3.02.00 (23 Oct 2002)
+
+ 23 Oct 2002; Zach Welch <zwelch@gentoo.org> :
+ Import from bug 9454, contributed by Danny Pansters <danny@ricin.com>
+
diff --git a/app-admin/integrit/files/digest-integrit-3.02.00 b/app-admin/integrit/files/digest-integrit-3.02.00
new file mode 100644
index 000000000000..7eb5b18724bb
--- /dev/null
+++ b/app-admin/integrit/files/digest-integrit-3.02.00
@@ -0,0 +1 @@
+MD5 062db01161187184f7c85f754ab6f7a5 integrit-3.02.00.tar.gz 251649
diff --git a/app-admin/integrit/integrit-3.02.00.ebuild b/app-admin/integrit/integrit-3.02.00.ebuild
new file mode 100644
index 000000000000..eb9b85449dfe
--- /dev/null
+++ b/app-admin/integrit/integrit-3.02.00.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+DESCRIPTION="Integrit is a file integrity verification program"
+SRC_URI="http://www.noserose.net/e/integrit/download/${P}.tar.gz"
+HOMEPAGE="http://integrit.sourceforge.net"
+
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc"
+
+UNPACKDIR=integrit-3.02
+
+S=${WORKDIR}/${UNPACKDIR}
+
+src_compile() {
+ econf --prefix=/usr
+ emake || die
+ emake utils || die
+ cd ${S}/doc
+ emake || die
+ cd ${S}/hashtbl
+ emake hashtest || die
+ mv README README.hashtbl
+}
+
+src_install() {
+ into /usr
+
+ dosbin integrit
+ dolib libintegrit.a
+ dodoc Changes HACKING INSTALL LICENSE README todo.txt
+
+ cd ${S}/utils
+ dosbin i-viewdb
+ dobin i-ls
+
+ cd ${S}/hashtbl
+ dolib libhashtbl.a
+ insinto /usr/include
+ doins hashtbl.h
+ dobin hashtest
+ dodoc README.hashtbl
+
+ cd ${S}/doc
+ doman i-ls.1 i-viewdb.1 integrit.1
+ doinfo integrit.info
+
+ cd ${S}/examples
+ docinto examples
+ dodoc *
+}
+
+pkg_postinst() {
+ einfo "It is recommended that the integrit binary is copied to a secure"
+ einfo "location and re-copied at runtime or run from a secure medium."
+ einfo "You should also create a configuration file (see examples)."
+ echo
+}