summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-05-14 03:31:22 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-05-14 03:31:22 +0000
commit39c6fea96199b332bd62d648f2b56494306b73c0 (patch)
tree872f126502eb4cece4b7907907af61a1e32b8a33 /app-admin/logrotate/logrotate-3.6.5-r1.ebuild
parentadd missing antivirus and inetd virtuals. ran sort on the file to make it (diff)
downloadhistorical-39c6fea96199b332bd62d648f2b56494306b73c0.tar.gz
historical-39c6fea96199b332bd62d648f2b56494306b73c0.tar.bz2
historical-39c6fea96199b332bd62d648f2b56494306b73c0.zip
new revision of logrotate ebuild:
Diffstat (limited to 'app-admin/logrotate/logrotate-3.6.5-r1.ebuild')
-rw-r--r--app-admin/logrotate/logrotate-3.6.5-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-admin/logrotate/logrotate-3.6.5-r1.ebuild b/app-admin/logrotate/logrotate-3.6.5-r1.ebuild
new file mode 100644
index 000000000000..253a350207a2
--- /dev/null
+++ b/app-admin/logrotate/logrotate-3.6.5-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/logrotate-3.6.5-r1.ebuild,v 1.1 2003/05/14 03:31:18 msterret Exp $
+
+IUSE="selinux"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Rotates, compresses, and mails system logs"
+HOMEPAGE="http://packages.debian.org/unstable/admin/logrotate.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/l/${PN}/${PN}_${PV}.orig.tar.gz
+ selinux? http://www.nsa.gov/selinux/patches/${P}-2003011510.patch.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND=">=sys-apps/portage-2.0.47-r10
+ >=dev-libs/popt-1.5
+ >=sys-apps/sed-4
+ selinux? ( >=sys-apps/selinux-small-2003011510-r2 )"
+
+src_compile() {
+ use selinux && epatch ${DISTDIR}/${P}-2003011510.patch.gz
+
+ sed -i \
+ -e "s:CFLAGS += -g:CFLAGS += -g ${CFLAGS}:" \
+ -e "/CVSROOT =/d" \
+ Makefile || die "sed failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ insinto /usr
+ dosbin logrotate
+ doman logrotate.8
+ dodoc examples/logrotate*
+
+ exeinto /etc
+ doexe ${FILESDIR}/logrotate.cron
+
+ insinto /etc
+ doins ${FILESDIR}/logrotate.conf
+
+ keepdir /etc/logrotate.d
+}
+
+pkg_postinst() {
+ einfo "If you wish to have logrotate e-mail you updates, please"
+ einfo "emerge net-mail/mailx and configure logrotate in"
+ einfo "/etc/logrotate.conf appropriately"
+ einfo ""
+ einfo "Additionally, /etc/logrotate.conf may need to be modified"
+ einfo "for your particular needs. See man logrotate for details."
+}