summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDane Smith <c1pher@gentoo.org>2011-07-21 18:12:26 +0000
committerDane Smith <c1pher@gentoo.org>2011-07-21 18:12:26 +0000
commita6a878b181f8c5190564d2d4105da71b5df6565d (patch)
tree947de0312c39795e765c39edc58addf06a70a359 /app-admin/testdisk/testdisk-6.12.ebuild
parent[bump] dev-perl/Package-Stash-0.300.0 (diff)
downloadhistorical-a6a878b181f8c5190564d2d4105da71b5df6565d.tar.gz
historical-a6a878b181f8c5190564d2d4105da71b5df6565d.tar.bz2
historical-a6a878b181f8c5190564d2d4105da71b5df6565d.zip
app-admin/testdisk: QA: Fix configure sanity checks to make sure it will detect either ntfs or ntfs3g wrt bug 374009. Thanks Ian Abbot for the patch.
Package-Manager: portage-2.2.0_alpha46/cvs/Linux x86_64
Diffstat (limited to 'app-admin/testdisk/testdisk-6.12.ebuild')
-rw-r--r--app-admin/testdisk/testdisk-6.12.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/app-admin/testdisk/testdisk-6.12.ebuild b/app-admin/testdisk/testdisk-6.12.ebuild
index 0be3387b72ee..6f5f74ae9783 100644
--- a/app-admin/testdisk/testdisk-6.12.ebuild
+++ b/app-admin/testdisk/testdisk-6.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/testdisk-6.12.ebuild,v 1.2 2011/07/08 10:16:50 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/testdisk-6.12.ebuild,v 1.3 2011/07/21 18:12:26 c1pher Exp $
EAPI=2
inherit eutils flag-o-matic
@@ -46,8 +46,8 @@ src_configure() {
econf ${myconf} || die
# perform safety checks for NTFS and REISERFS
- if use ntfs && egrep -q 'undef HAVE_LIBNTFS\>' "${S}"/config.h ; then
- die "Failed to find NTFS library."
+ if use ntfs && ! egrep -q '^#define HAVE_LIBNTFS(3G)? 1$' "${S}"/config.h ; then
+ die "Failed to find either NTFS or NTFS-3G library."
fi
if use reiserfs && egrep -q 'undef HAVE_LIBREISERFS\>' "${S}"/config.h ; then
die "Failed to find reiserfs library."