summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-31 12:53:39 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-31 12:53:39 +0000
commit6e376bffd42e998d63ff42365b95d2ce40ec80a2 (patch)
tree8ca4f885d7012c7cf51bf887fb45ae6dbaa2ab48 /app-arch/unzip
parentinitial import (diff)
downloadhistorical-6e376bffd42e998d63ff42365b95d2ce40ec80a2.tar.gz
historical-6e376bffd42e998d63ff42365b95d2ce40ec80a2.tar.bz2
historical-6e376bffd42e998d63ff42365b95d2ce40ec80a2.zip
use CHOST instead of ARCH/USERLAND
Package-Manager: portage-2.1_pre3
Diffstat (limited to 'app-arch/unzip')
-rw-r--r--app-arch/unzip/Manifest18
-rw-r--r--app-arch/unzip/unzip-5.52-r1.ebuild13
-rw-r--r--app-arch/unzip/unzip-5.52.ebuild14
3 files changed, 26 insertions, 19 deletions
diff --git a/app-arch/unzip/Manifest b/app-arch/unzip/Manifest
index a82fc31b82d9..8766e602d37b 100644
--- a/app-arch/unzip/Manifest
+++ b/app-arch/unzip/Manifest
@@ -1,20 +1,20 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 889185ece3718e537769c23672bd5ef1 unzip-5.52-r1.ebuild 1271
-MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 1e8a4d870c17ebc47a8e57a438823739 unzip-5.52.ebuild 1193
-MD5 4c9cca80bd3bde938e8921913622b498 unzip-5.50-r2.ebuild 1129
MD5 8a3d6aa629908a6bd7c2374fc23cec9a ChangeLog 4033
MD5 583a5d8bbc70fb1d858c5e40d686e8ce files/digest-unzip-5.50-r2 61
-MD5 96a480a7d42cba427e44955d142d670c files/digest-unzip-5.52-r1 61
-MD5 b17d0181200f3e1f47a55b54eb93527d files/unzip-5.52-no-exec-stack.patch 334
MD5 96a480a7d42cba427e44955d142d670c files/digest-unzip-5.52 61
+MD5 96a480a7d42cba427e44955d142d670c files/digest-unzip-5.52-r1 61
MD5 3b01796cbe10d9492bd8c0825bc83544 files/unzip-5.50-dotdot.patch 3236
+MD5 b17d0181200f3e1f47a55b54eb93527d files/unzip-5.52-no-exec-stack.patch 334
+MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
+MD5 4c9cca80bd3bde938e8921913622b498 unzip-5.50-r2.ebuild 1129
+MD5 7788e8d3d98f2a6f514542ab343a6fe3 unzip-5.52-r1.ebuild 1389
+MD5 4c3106ff7fd92dd5965a51baa9195a3e unzip-5.52.ebuild 1327
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
-iD8DBQFDQwoLgIKl8Uu19MoRAnQYAJ99p7O4/eLtcSn9K2G0+mrkt6aePQCffru+
-hsbXINrgenQxI3ClPQ/k09E=
-=p6Vs
+iD8DBQFDtn982+ySkm8kpY0RAhjeAKCwJEWFdzvgYfq3dbc/wJsimzyuegCfZ6sg
+g+y8GKy93SA7P9Zkv3iDQ5A=
+=ouzq
-----END PGP SIGNATURE-----
diff --git a/app-arch/unzip/unzip-5.52-r1.ebuild b/app-arch/unzip/unzip-5.52-r1.ebuild
index 4a2795fd98be..38aa53ee72ff 100644
--- a/app-arch/unzip/unzip-5.52-r1.ebuild
+++ b/app-arch/unzip/unzip-5.52-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.52-r1.ebuild,v 1.1 2005/10/04 23:01:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.52-r1.ebuild,v 1.2 2005/12/31 12:53:39 vapier Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -32,10 +32,13 @@ src_unpack() {
src_compile() {
local TARGET
- use x86 \
- && TARGET=linux_asm \
- || TARGET=linux_noasm
- use userland_Darwin && TARGET=macosx
+ case ${CHOST} in
+ i?86*-linux*) TARGET=linux_asm ;;
+ *-linux*) TARGET=linux_noasm ;;
+ *-freebsd*) TARGET=freebsd ;;
+ *-darwin*) TARGET=macosx ;;
+ *) die "Unknown target, you suck" ;;
+ esac
emake -f unix/Makefile ${TARGET} || die "emake failed"
}
diff --git a/app-arch/unzip/unzip-5.52.ebuild b/app-arch/unzip/unzip-5.52.ebuild
index e09029eee37a..d91c1581a65a 100644
--- a/app-arch/unzip/unzip-5.52.ebuild
+++ b/app-arch/unzip/unzip-5.52.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.52.ebuild,v 1.10 2005/09/09 15:11:23 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.52.ebuild,v 1.11 2005/12/31 12:53:39 vapier Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -30,10 +30,14 @@ src_unpack() {
}
src_compile() {
- use x86 \
- && TARGET=linux \
- || TARGET=linux_noasm
- use userland_Darwin && TARGET=macosx
+ local TARGET
+ case ${CHOST} in
+ i?86*-linux*) TARGET=linux_asm ;;
+ *-linux*) TARGET=linux_noasm ;;
+ *-freebsd*) TARGET=freebsd ;;
+ *-darwin*) TARGET=macosx ;;
+ *) die "Unknown target, you suck" ;;
+ esac
emake -f unix/Makefile ${TARGET} || die "emake failed"
}