summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-10-18 09:04:22 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-10-18 09:04:22 +0000
commit18afd9753374c0b21b019933947ff135ec4163de (patch)
treee7418e8faf1e17f8c532102aa94b64fc325a51ac /app-crypt/kth-krb
parentVersion bump. (diff)
downloadhistorical-18afd9753374c0b21b019933947ff135ec4163de.tar.gz
historical-18afd9753374c0b21b019933947ff135ec4163de.tar.bz2
historical-18afd9753374c0b21b019933947ff135ec4163de.zip
Version bump.
Diffstat (limited to 'app-crypt/kth-krb')
-rw-r--r--app-crypt/kth-krb/ChangeLog7
-rw-r--r--app-crypt/kth-krb/files/digest-kth-krb-1.21
-rw-r--r--app-crypt/kth-krb/kth-krb-1.2.ebuild54
3 files changed, 61 insertions, 1 deletions
diff --git a/app-crypt/kth-krb/ChangeLog b/app-crypt/kth-krb/ChangeLog
index 883c08bf819d..0f7a60febc58 100644
--- a/app-crypt/kth-krb/ChangeLog
+++ b/app-crypt/kth-krb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/kth-krb
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/ChangeLog,v 1.3 2002/08/19 01:59:13 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/ChangeLog,v 1.4 2002/10/18 09:04:22 aliz Exp $
+
+*kth-krb 1.2 (18 Oct 2002)
+
+ 18 Oct 2002; Daniel Ahlberg <aliz@gentoo.org> kth-krb-1.2.ebuild
+ Version bump, found by Ian <ian@stacken.kth.se> in #7823.
*kth-krb-1.1.1-r1 (1 Feb 2002)
diff --git a/app-crypt/kth-krb/files/digest-kth-krb-1.2 b/app-crypt/kth-krb/files/digest-kth-krb-1.2
new file mode 100644
index 000000000000..9e04a46664d4
--- /dev/null
+++ b/app-crypt/kth-krb/files/digest-kth-krb-1.2
@@ -0,0 +1 @@
+MD5 7e882968dfac180d9448105c3573dd73 krb4-1.2.tar.gz 2021895
diff --git a/app-crypt/kth-krb/kth-krb-1.2.ebuild b/app-crypt/kth-krb/kth-krb-1.2.ebuild
new file mode 100644
index 000000000000..a2b7481723f9
--- /dev/null
+++ b/app-crypt/kth-krb/kth-krb-1.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/kth-krb-1.2.ebuild,v 1.1 2002/10/18 09:04:22 aliz Exp $
+
+IUSE="ssl afs"
+
+S=${WORKDIR}/krb4-${PV}
+DESCRIPTION="Kerberos 4 implementation from KTH"
+SRC_URI="ftp://ftp.pdc.kth.se/pub/krb/src/krb4-${PV}.tar.gz"
+HOMEPAGE="http://www.pdc.kth.se/kth-krb/"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~sparc ~sparc64"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
+ afs? ( >=net-fs/openafs-1.2.2-r7 )"
+
+src_compile() {
+ local myconf=""
+
+ use ssl && myconf="${myconf} --with-openssl=/usr"
+
+ use afs || myconf="${myconf} --without-afs-support"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr/athena \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install () {
+ make prefix=${D}/usr/athena \
+ sysconfdir=${D}/etc \
+ install || die
+
+ # Doesn't get install otherwise (for some reason, look into this).
+ if [ "`use ssl`" ] ; then
+ cd ${S}/lib/des
+
+ make prefix=${D}/usr/athena \
+ install || die
+
+ cd ${S}
+ fi
+
+ dodir /etc/env.d
+ cp ${FILESDIR}/02kth-krb ${D}/etc/env.d
+
+ dodoc COPYRIGHT ChangeLog README NEWS PROBLEMS TODO
+}