summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-12-26 06:31:36 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-12-26 06:31:36 +0000
commitb42e3c46aafef6c390378332ad24f3cac9a5f075 (patch)
tree942fc22919c8aa0968e63948fd74a99914014e9e /app-crypt/mhash/mhash-0.9.3.ebuild
parentMarked ~ppc for bug #116721. (diff)
downloadhistorical-b42e3c46aafef6c390378332ad24f3cac9a5f075.tar.gz
historical-b42e3c46aafef6c390378332ad24f3cac9a5f075.tar.bz2
historical-b42e3c46aafef6c390378332ad24f3cac9a5f075.zip
Version bump.
Package-Manager: portage-2.1_pre2
Diffstat (limited to 'app-crypt/mhash/mhash-0.9.3.ebuild')
-rw-r--r--app-crypt/mhash/mhash-0.9.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-crypt/mhash/mhash-0.9.3.ebuild b/app-crypt/mhash/mhash-0.9.3.ebuild
new file mode 100644
index 000000000000..4c0e29b1e755
--- /dev/null
+++ b/app-crypt/mhash/mhash-0.9.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mhash/mhash-0.9.3.ebuild,v 1.1 2005/12/26 06:31:36 robbat2 Exp $
+
+DESCRIPTION="library providing a uniform interface to a large number of hash algorithms"
+HOMEPAGE="http://mhash.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mhash/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ econf \
+ --enable-static \
+ --enable-shared || die
+ emake || die "make failure"
+}
+
+src_install() {
+ dodir /usr/{bin,include,lib}
+ make install DESTDIR="${D}" || die "install failure"
+
+ dodoc AUTHORS INSTALL NEWS README TODO THANKS ChangeLog
+ dodoc doc/*.txt doc/skid*
+ prepalldocs
+ cd doc && dohtml mhash.html || die "dohtml failed"
+}