summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-12-27 03:05:00 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-12-27 03:05:00 +0000
commitaa0ae97154f5cb8866b373da05a822b06bed7785 (patch)
treedfc35d914caac0dda793842b898e6297f3aa8a31 /app-crypt/mhash
parentPackage failure on Pentium-M systems in HMAC code. (diff)
downloadhistorical-aa0ae97154f5cb8866b373da05a822b06bed7785.tar.gz
historical-aa0ae97154f5cb8866b373da05a822b06bed7785.tar.bz2
historical-aa0ae97154f5cb8866b373da05a822b06bed7785.zip
Bug #116769 - upstream accidently dropped a symbol. Note that 0.9.3* is package.masked for the moment due to another bug as well.
Package-Manager: portage-2.1_pre2
Diffstat (limited to 'app-crypt/mhash')
-rw-r--r--app-crypt/mhash/ChangeLog9
-rw-r--r--app-crypt/mhash/Manifest5
-rw-r--r--app-crypt/mhash/files/digest-mhash-0.9.3-r11
-rw-r--r--app-crypt/mhash/files/mhash-0.9.3-mhash_free.patch18
-rw-r--r--app-crypt/mhash/mhash-0.9.3-r1.ebuild40
5 files changed, 71 insertions, 2 deletions
diff --git a/app-crypt/mhash/ChangeLog b/app-crypt/mhash/ChangeLog
index ac4d216a17c5..cfaa2cf85ae6 100644
--- a/app-crypt/mhash/ChangeLog
+++ b/app-crypt/mhash/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-crypt/mhash
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/mhash/ChangeLog,v 1.30 2005/12/26 06:31:36 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mhash/ChangeLog,v 1.31 2005/12/27 03:05:00 robbat2 Exp $
+
+*mhash-0.9.3-r1 (27 Dec 2005)
+
+ 27 Dec 2005; Robin H. Johnson <robbat2@gentoo.org>
+ +files/mhash-0.9.3-mhash_free.patch, +mhash-0.9.3-r1.ebuild:
+ Bug #116769 - upstream accidently dropped a symbol. Note that 0.9.3* is
+ package.masked for the moment due to another bug as well.
*mhash-0.9.3 (26 Dec 2005)
diff --git a/app-crypt/mhash/Manifest b/app-crypt/mhash/Manifest
index 8d0ebbb6960d..4e3e51fec2aa 100644
--- a/app-crypt/mhash/Manifest
+++ b/app-crypt/mhash/Manifest
@@ -1,8 +1,11 @@
-MD5 04782560647b743f2c92f61e45293e00 ChangeLog 3431
+MD5 ca17950ae72a0b7bb72acacde99d7f31 ChangeLog 3713
MD5 b82524ff78b486ef79cccd400ad79348 files/digest-mhash-0.9.1 63
MD5 fb060fa52ccd63f4970aa3099a43c235 files/digest-mhash-0.9.2 63
MD5 517095254033047a16a801e352a2cf9e files/digest-mhash-0.9.3 64
+MD5 517095254033047a16a801e352a2cf9e files/digest-mhash-0.9.3-r1 64
+MD5 d27bb1251e5f7314b085056b0c28a600 files/mhash-0.9.3-mhash_free.patch 488
MD5 b0d485ea1a51fb83c70daedef2599272 metadata.xml 279
MD5 c2898e702ba9d02702277c8be7512abf mhash-0.9.1.ebuild 989
MD5 8567eb305f9641f5257de243688b5efc mhash-0.9.2.ebuild 893
+MD5 821041d7e1bb7b7815dd977d00dc4c72 mhash-0.9.3-r1.ebuild 1060
MD5 3971c9afee469a5a8c3bd0654a2e226a mhash-0.9.3.ebuild 907
diff --git a/app-crypt/mhash/files/digest-mhash-0.9.3-r1 b/app-crypt/mhash/files/digest-mhash-0.9.3-r1
new file mode 100644
index 000000000000..abde19828d5f
--- /dev/null
+++ b/app-crypt/mhash/files/digest-mhash-0.9.3-r1
@@ -0,0 +1 @@
+MD5 8c2dc7b2bfe84bccf8d25d338bf75760 mhash-0.9.3.tar.gz 1021016
diff --git a/app-crypt/mhash/files/mhash-0.9.3-mhash_free.patch b/app-crypt/mhash/files/mhash-0.9.3-mhash_free.patch
new file mode 100644
index 000000000000..1500790c2732
--- /dev/null
+++ b/app-crypt/mhash/files/mhash-0.9.3-mhash_free.patch
@@ -0,0 +1,18 @@
+Don't get rid of old symbols, that are exported. Other stuff depends on them
+(eg PHP).
+diff -u -r mhash-0.9.3.new/lib/mhash.c mhash-0.9.3/lib/mhash.c
+--- lib/mhash.c 2005-12-07 03:55:30.000000000 +0000
++++ lib/mhash.c 2005-12-26 11:16:10.000000000 +0000
+@@ -623,6 +623,12 @@
+ return(ret);
+ }
+
++WIN32DLL_DEFINE void mhash_free(void *ptr)
++{
++ mutils_free(ptr);
++}
++
++
+ /*
+ Saves the state of a hashing algorithm such that it can be
+ restored at some later point in time using
diff --git a/app-crypt/mhash/mhash-0.9.3-r1.ebuild b/app-crypt/mhash/mhash-0.9.3-r1.ebuild
new file mode 100644
index 000000000000..34b23de1f907
--- /dev/null
+++ b/app-crypt/mhash/mhash-0.9.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mhash/mhash-0.9.3-r1.ebuild,v 1.1 2005/12/27 03:05:00 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="library providing a uniform interface to a large number of hash algorithms"
+HOMEPAGE="http://mhash.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mhash/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A} && cd "${S}"
+ # for 0.9.3 only, please send patch upstream
+ epatch "${FILESDIR}/${P}-mhash_free.patch"
+}
+
+src_compile() {
+ econf \
+ --enable-static \
+ --enable-shared || die
+ emake || die "make failure"
+}
+
+src_install() {
+ dodir /usr/{bin,include,lib}
+ make install DESTDIR="${D}" || die "install failure"
+
+ dodoc AUTHORS INSTALL NEWS README TODO THANKS ChangeLog
+ dodoc doc/*.txt doc/skid*
+ prepalldocs
+ cd doc && dohtml mhash.html || die "dohtml failed"
+}