summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2004-05-01 20:46:21 +0000
committerBryan Østergaard <kloeri@gentoo.org>2004-05-01 20:46:21 +0000
commit104ef78238e02c0f9e847ffc4b0e38adc365a40f (patch)
tree915d1069e33fc37c2760273abe892a65f972738d /app-crypt
parentchanged new wolk flags to wolk-dev-sources (diff)
downloadhistorical-104ef78238e02c0f9e847ffc4b0e38adc365a40f.tar.gz
historical-104ef78238e02c0f9e847ffc4b0e38adc365a40f.tar.bz2
historical-104ef78238e02c0f9e847ffc4b0e38adc365a40f.zip
Bump version, bug #48917.
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/pinentry/ChangeLog7
-rw-r--r--app-crypt/pinentry/Manifest6
-rw-r--r--app-crypt/pinentry/files/digest-pinentry-0.7.11
-rw-r--r--app-crypt/pinentry/pinentry-0.7.1.ebuild48
4 files changed, 59 insertions, 3 deletions
diff --git a/app-crypt/pinentry/ChangeLog b/app-crypt/pinentry/ChangeLog
index 7ed7311d8390..1215b13fce66 100644
--- a/app-crypt/pinentry/ChangeLog
+++ b/app-crypt/pinentry/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/pinentry
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.8 2004/04/26 15:51:58 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/ChangeLog,v 1.9 2004/05/01 20:46:21 kloeri Exp $
+
+*pinentry-0.7.1 (01 May 2004)
+
+ 01 May 2004; Bryan Østergaard <kloeri@gentoo.org> +pinentry-0.7.1.ebuild:
+ Bump version, bug #48917.
26 Apr 2004; Aron Griffis <agriffis@gentoo.org> pinentry-0.6.9.ebuild:
Add die following econf for bug 48950
diff --git a/app-crypt/pinentry/Manifest b/app-crypt/pinentry/Manifest
index dc84f253b704..1ec467336f99 100644
--- a/app-crypt/pinentry/Manifest
+++ b/app-crypt/pinentry/Manifest
@@ -1,5 +1,7 @@
-MD5 29489b49320b4c9c744d3d1da7aeb061 pinentry-0.7.0.ebuild 1550
+MD5 1fe336aa60c84218e7e23fc14af9545a pinentry-0.7.1.ebuild 1547
MD5 ec856b2921f0a90483389b95de21d256 pinentry-0.6.9.ebuild 1515
-MD5 2d73d9abfea6def7bb219fb77cd8c717 ChangeLog 1481
+MD5 29489b49320b4c9c744d3d1da7aeb061 pinentry-0.7.0.ebuild 1550
+MD5 af803a041a28d2f4c9bfd547b2e164f2 ChangeLog 1615
MD5 e04ffe05e9f30669f590346558387f72 files/digest-pinentry-0.6.9 66
MD5 7b470fdc8e2b8af70c2ca683de02b9d2 files/digest-pinentry-0.7.0 66
+MD5 85ba6415300c935a1234df2cb3199fce files/digest-pinentry-0.7.1 66
diff --git a/app-crypt/pinentry/files/digest-pinentry-0.7.1 b/app-crypt/pinentry/files/digest-pinentry-0.7.1
new file mode 100644
index 000000000000..f04ba84923c4
--- /dev/null
+++ b/app-crypt/pinentry/files/digest-pinentry-0.7.1
@@ -0,0 +1 @@
+MD5 7861d63dea6434a5a05da84e83f209e6 pinentry-0.7.1.tar.gz 347047
diff --git a/app-crypt/pinentry/pinentry-0.7.1.ebuild b/app-crypt/pinentry/pinentry-0.7.1.ebuild
new file mode 100644
index 000000000000..c86b84a50375
--- /dev/null
+++ b/app-crypt/pinentry/pinentry-0.7.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/pinentry/pinentry-0.7.1.ebuild,v 1.1 2004/05/01 20:46:21 kloeri Exp $
+
+DESCRIPTION="collection of simple PIN or passphrase entry dialogs which utilize the Assuan protocol"
+HOMEPAGE="http://www.gnupg.org/aegypten/"
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/pinentry/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="qt gtk ncurses"
+
+DEPEND="gtk? ( x11-libs/gtk+ )
+ ncurses? ( sys-libs/ncurses )
+ qt? ( x11-libs/qt )
+ !gtk? ( !qt? ( !ncurses? ( sys-libs/ncurses ) ) )"
+
+src_compile() {
+ local myconf=""
+ if ! use qt && ! use gtk && ! use ncurses ; then
+ myconf="--enable-pinentry-curses --enable-fallback-curses"
+ fi
+ econf \
+ `use_enable qt pinentry-qt` \
+ `use_enable gtk pinentry-gtk` \
+ `use_enable ncurses pinentry-curses` \
+ `use_enable ncurses fallback-curses` \
+ --disable-dependency-tracking \
+ ${myconf} \
+ || die
+ make || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+
+ # The other two pinentries don't spit out an insecure memory warning when
+ # not suid root, and gtk refuses to start if pinentry-gtk is suid root.
+ fperms +s /usr/bin/pinentry-qt
+}
+
+pkg_postinst() {
+ einfo "pinentry-qt is installed SUID root to make use of protected memory space"
+ einfo "This is needed in order to have a secure place to store your passphrases,"
+ einfo "etc. at runtime but may make some sysadmins nervous"
+}