summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnant Narayanan <anant@gentoo.org>2007-08-04 21:47:22 +0000
committerAnant Narayanan <anant@gentoo.org>2007-08-04 21:47:22 +0000
commit7d3a01a212006f81006f9a1ff4275113522210cf (patch)
treee0c2fc9881307609c713c5d6e0831655dd1c4cb4 /app-doc/doc++/doc++-3.4.10-r3.ebuild
parentVersion bump for bug 183127. (diff)
downloadhistorical-7d3a01a212006f81006f9a1ff4275113522210cf.tar.gz
historical-7d3a01a212006f81006f9a1ff4275113522210cf.tar.bz2
historical-7d3a01a212006f81006f9a1ff4275113522210cf.zip
Install latex style files too. (Bug #187743)
Package-Manager: portage-2.1.3_rc9
Diffstat (limited to 'app-doc/doc++/doc++-3.4.10-r3.ebuild')
-rw-r--r--app-doc/doc++/doc++-3.4.10-r3.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-doc/doc++/doc++-3.4.10-r3.ebuild b/app-doc/doc++/doc++-3.4.10-r3.ebuild
new file mode 100644
index 000000000000..d16d044b3255
--- /dev/null
+++ b/app-doc/doc++/doc++-3.4.10-r3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doc++/doc++-3.4.10-r3.ebuild,v 1.1 2007/08/04 21:47:21 anant Exp $
+
+inherit eutils
+
+DESCRIPTION="Documentation system for C, C++, IDL and Java"
+HOMEPAGE="http://docpp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/docpp/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/flex.patch
+ sed -i -e "s/locale.alias//g" ${S}/intl/Makefile.in
+}
+
+src_compile() {
+ econf || die
+ emake all || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc CREDITS INSTALL NEWS PLATFORMS REPORTING-BUGS
+
+ #Install Latex style file
+ insinto /usr/share/${PN}
+ doins doc/*.sty
+}
+
+pkg_postinst() {
+ einfo " "
+ einfo "The latex style files for doc++ may be found in "
+ einfo "/usr/share/doc++ "
+ einfo " "
+}