summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2006-01-18 13:02:21 +0000
committerHanno Boeck <hanno@gentoo.org>2006-01-18 13:02:21 +0000
commit41f97d30bb8fda2b662fcaf8904f4188d06e5e9a (patch)
tree47f267005b2ec1f9e769ef7f7d57ffa8afe79111 /app-editors/fte/fte-20050108-r3.ebuild
parentAdded =dev-libs/glib-1* to DEPEND, bug #107486 by Scott Dial (diff)
downloadhistorical-41f97d30bb8fda2b662fcaf8904f4188d06e5e9a.tar.gz
historical-41f97d30bb8fda2b662fcaf8904f4188d06e5e9a.tar.bz2
historical-41f97d30bb8fda2b662fcaf8904f4188d06e5e9a.zip
fte modular x deps
Package-Manager: portage-2.1_pre3-r1
Diffstat (limited to 'app-editors/fte/fte-20050108-r3.ebuild')
-rw-r--r--app-editors/fte/fte-20050108-r3.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/app-editors/fte/fte-20050108-r3.ebuild b/app-editors/fte/fte-20050108-r3.ebuild
index 7709f97ce9c4..fd4f7656b246 100644
--- a/app-editors/fte/fte-20050108-r3.ebuild
+++ b/app-editors/fte/fte-20050108-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/fte-20050108-r3.ebuild,v 1.3 2005/06/23 17:59:29 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/fte/fte-20050108-r3.ebuild,v 1.4 2006/01/18 13:02:21 hanno Exp $
inherit eutils
@@ -15,12 +15,16 @@ KEYWORDS="amd64 ppc ~sparc x86"
IUSE="gpm slang X"
S=${WORKDIR}/${PN}
-RDEPEND=">=sys-libs/ncurses-5.2
+RDEPEND="|| ( (
+ x11-libs/libXdmcp
+ x11-libs/libXau
+ x11-libs/libX11
+ ) virtual/x11 )
+ >=sys-libs/ncurses-5.2
gpm? ( >=sys-libs/gpm-1.20 )"
DEPEND="${RDEPEND}
slang? ( sys-libs/slang )
- app-arch/unzip
- X? ( virtual/x11 )"
+ app-arch/unzip"
set_targets() {
export TARGETS=""