summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-03-01 20:43:53 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-03-01 20:43:53 +0000
commitdf44bd4e2a398e63bffd99b3cfeda32602e22e31 (patch)
tree2a18cc9dbedabef0b3beb89d83db53c990451477 /app-editors/mp/mp-3.2.11.ebuild
parentChangeLog fixes (diff)
downloadhistorical-df44bd4e2a398e63bffd99b3cfeda32602e22e31.tar.gz
historical-df44bd4e2a398e63bffd99b3cfeda32602e22e31.tar.bz2
historical-df44bd4e2a398e63bffd99b3cfeda32602e22e31.zip
Version bumped. Closes 43388
Diffstat (limited to 'app-editors/mp/mp-3.2.11.ebuild')
-rw-r--r--app-editors/mp/mp-3.2.11.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-editors/mp/mp-3.2.11.ebuild b/app-editors/mp/mp-3.2.11.ebuild
new file mode 100644
index 000000000000..89b8d0936ba7
--- /dev/null
+++ b/app-editors/mp/mp-3.2.11.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.2.11.ebuild,v 1.1 2004/03/01 20:43:53 mholzer Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="mp, the definitive text editor"
+SRC_URI="http://www.triptico.com/download/${P}.tar.gz"
+
+HOMEPAGE="http://www.triptico.com/software/mp.html"
+
+DEPEND="virtual/glibc
+ ncurses? ( sys-libs/ncurses )
+ gtk? ( =x11-libs/gtk+-1.2* )"
+
+RDEPEND="${DEPEND}
+ dev-lang/perl"
+IUSE="ncurses gtk"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc"
+
+src_compile() {
+ epatch ${FILESDIR}/gentoo-synh-mp.patch-3.2.11
+ if [ -n "`use ncurses`" ] && [ -n "`use gtk`" ]; then emake || die;
+ elif [ -n "`use ncurses`" ]; then emake mp || die;
+ elif [ -n "`use gtk`" ]; then emake gmp || die;
+ else die "You need ncurses and/or gtk in your USE variables";
+ fi
+}
+
+src_install () {
+ dodir /usr/bin
+ make install PREFIX=${D}/usr || die "install failed"
+ dodoc AUTHORS Changelog COPYING README
+ dohtml README.html doc/mp_api.html
+ insinto /usr/share/pixmaps/
+ doins mp.xpm
+}