summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2005-02-19 12:20:02 +0000
committerHeinrich Wendel <lanius@gentoo.org>2005-02-19 12:20:02 +0000
commit13706c7715e2906289d7a73d602a80f5aa06a76c (patch)
tree2f96a6c896ceddfc3d10de1ea4906fb75f9bbf24 /app-editors/nedit/nedit-5.5.ebuild
parentQuoted NTOP_OPTS in /etc/conf.d/ntop to fix bug #80663 (diff)
downloadhistorical-13706c7715e2906289d7a73d602a80f5aa06a76c.tar.gz
historical-13706c7715e2906289d7a73d602a80f5aa06a76c.tar.bz2
historical-13706c7715e2906289d7a73d602a80f5aa06a76c.zip
fix to compile with all motif versions, mark stable
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'app-editors/nedit/nedit-5.5.ebuild')
-rw-r--r--app-editors/nedit/nedit-5.5.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/app-editors/nedit/nedit-5.5.ebuild b/app-editors/nedit/nedit-5.5.ebuild
index fa56912fecf2..c64f0eceb3b2 100644
--- a/app-editors/nedit/nedit-5.5.ebuild
+++ b/app-editors/nedit/nedit-5.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/nedit-5.5.ebuild,v 1.2 2005/01/01 13:32:15 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/nedit-5.5.ebuild,v 1.3 2005/02/19 12:20:02 lanius Exp $
inherit gcc
@@ -10,16 +10,19 @@ SRC_URI="mirror://sourceforge/nedit/${P}-src.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~mips ~amd64 ~alpha"
+KEYWORDS="x86 ~ppc ~sparc ~mips amd64 ~alpha"
IUSE="spell"
RDEPEND="spell? ( virtual/aspell-dict )
- virtual/x11"
+ x11-libs/openmotif"
DEPEND="${RDEPEND}
dev-util/yacc
x11-libs/openmotif"
src_compile() {
+ sed -i -e "s:-Wl,-Bstatic::" makefiles/Makefile.linux
+ sed -i -e "s:0.93.0:0.94.0:" util/check_lin_tif.c
+ sed -i -e "s:CFLAGS=-O:CFLAGS=${CFLAGS}:" makefiles/Makefile.linux
sed -i -e 's:"/bin/csh":"/bin/sh":' source/preferences.c
make CC=$(gcc-getCC) linux || die
}