summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2004-12-09 19:26:00 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2004-12-09 19:26:00 +0000
commit0a4fc4b845da5916f67c6d9429a986bfadd73bf7 (patch)
treebdde68de1196690214adac2c661f4504aff16233 /app-editors
parentUpdate to 6.3.045 from vim.org, bug #73715 (diff)
downloadhistorical-0a4fc4b845da5916f67c6d9429a986bfadd73bf7.tar.gz
historical-0a4fc4b845da5916f67c6d9429a986bfadd73bf7.tar.bz2
historical-0a4fc4b845da5916f67c6d9429a986bfadd73bf7.zip
Update to 6.3.045 from vim.org and updated the runtime snapshot
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vim-core/ChangeLog8
-rw-r--r--app-editors/vim-core/files/digest-vim-core-6.3-r35
-rw-r--r--app-editors/vim-core/files/vimrc12
-rw-r--r--app-editors/vim-core/vim-core-6.3-r3.ebuild23
4 files changed, 38 insertions, 10 deletions
diff --git a/app-editors/vim-core/ChangeLog b/app-editors/vim-core/ChangeLog
index a8f73a773d5f..eed59646759c 100644
--- a/app-editors/vim-core/ChangeLog
+++ b/app-editors/vim-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/vim-core
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/ChangeLog,v 1.110 2004/12/07 21:07:09 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/ChangeLog,v 1.111 2004/12/09 19:26:00 ciaranm Exp $
+
+*vim-core-6.3-r3 (09 Dec 2004)
+
+ 09 Dec 2004; Ciaran McCreesh <ciaranm@gentoo.org> files/vimrc,
+ +vim-core-6.3-r3.ebuild:
+ Update to 6.3.045 from vim.org and updated the runtime snapshot
07 Dec 2004; Ciaran McCreesh <ciaranm@gentoo.org> files/vimrc:
Update the vimrc comments regarding modelines. If you need more information
diff --git a/app-editors/vim-core/files/digest-vim-core-6.3-r3 b/app-editors/vim-core/files/digest-vim-core-6.3-r3
new file mode 100644
index 000000000000..87d8ca0e626e
--- /dev/null
+++ b/app-editors/vim-core/files/digest-vim-core-6.3-r3
@@ -0,0 +1,5 @@
+MD5 821fda8f14d674346b87e3ef9cb96389 vim-6.3.tar.bz2 3699397
+MD5 5395c4dacbf1c5008b22c4b86794e8a7 vim-6.3-lang.tar.gz 1057792
+MD5 39de45308558b65d2ffb3f78feb93fa5 vim-6.3.025-gentoo-patches.tar.bz2 5183
+MD5 3ad67c40a5f998eb4c0c0faee58f93a0 vim-runtime-20041209.tar.bz2 2202046
+MD5 b04900244202ea8d108178b0639d9c58 vim-6.3.045-patches.tar.bz2 63214
diff --git a/app-editors/vim-core/files/vimrc b/app-editors/vim-core/files/vimrc
index 19d6d32da33a..fbad4b37e9b4 100644
--- a/app-editors/vim-core/files/vimrc
+++ b/app-editors/vim-core/files/vimrc
@@ -15,15 +15,9 @@ set viminfo='20,\"500 " read/write a .viminfo file -- limit regs to 500 lines
set history=50 " keep 50 lines of command history
set ruler " Show the cursor position all the time
-" Added to default to high security within Gentoo. Fixes bug #14088.
-" Modified 07 Oct 2003 by agriffis from "modelines=0" to "nomodeline"
-" according to conversation on vim devel ML:
-" http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=212696
-" http://article.gmane.org/gmane.editors.vim.devel/4410
-"
-" There are other currently unpublished issues with vim modelines, so it is
-" recommended that this settings is left alone until we can get a working
-" patch. -- ciaranm, 7 December 2004.
+" We don't allow modelines by default. See bug #14088 and bug #73715.
+" If you're not concerned about these, you can enable them on a per-user
+" basis by adding "set modeline" to your ~/.vimrc file.
set nomodeline
if v:lang =~ "^ko"
diff --git a/app-editors/vim-core/vim-core-6.3-r3.ebuild b/app-editors/vim-core/vim-core-6.3-r3.ebuild
new file mode 100644
index 000000000000..61c26d113ff7
--- /dev/null
+++ b/app-editors/vim-core/vim-core-6.3-r3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/vim-core-6.3-r3.ebuild,v 1.1 2004/12/09 19:26:00 ciaranm Exp $
+
+inherit vim
+
+VIM_VERSION="6.3"
+VIM_ORG_PATCHES="vim-6.3.045-patches.tar.bz2"
+VIM_RUNTIME_SNAP="vim-runtime-20041209.tar.bz2"
+VIM_GENTOO_PATCHES="vim-6.3.025-gentoo-patches.tar.bz2"
+
+SRC_URI="${SRC_URI}
+ ftp://ftp.vim.org/pub/vim/unix/vim-${VIM_VERSION}.tar.bz2
+ nls? ( ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-lang.tar.gz )
+ mirror://gentoo/${VIM_GENTOO_PATCHES}
+ mirror://gentoo/${VIM_RUNTIME_SNAP}
+ mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S=${WORKDIR}/vim${VIM_VERSION/.}
+DESCRIPTION="vim and gvim shared files"
+KEYWORDS="~x86 ~sparc ~mips ~ppc ~alpha ~amd64 ~ia64 ~arm ~hppa ~ppc64 ~s390"
+IUSE="${IUSE} nls"
+DEPEND="${DEPEND}" # all the deps for vim-core are in vim.eclass