summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-07 01:45:52 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-07 01:45:52 +0000
commit8e6d0bc642d86ab75955328333ca12558a9c63b2 (patch)
tree73b4948b3d11293f9a88a42199799a709731926e /app-editors
parentFixed missing digest. (diff)
downloadhistorical-8e6d0bc642d86ab75955328333ca12558a9c63b2.tar.gz
historical-8e6d0bc642d86ab75955328333ca12558a9c63b2.tar.bz2
historical-8e6d0bc642d86ab75955328333ca12558a9c63b2.zip
*** empty log message ***
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/ktexmaker2/ktexmaker2-1.4.ebuild16
-rw-r--r--app-editors/quanta/quanta-2.0-r1.ebuild12
2 files changed, 22 insertions, 6 deletions
diff --git a/app-editors/ktexmaker2/ktexmaker2-1.4.ebuild b/app-editors/ktexmaker2/ktexmaker2-1.4.ebuild
index f15fefb89620..71ae2b10e6cc 100644
--- a/app-editors/ktexmaker2/ktexmaker2-1.4.ebuild
+++ b/app-editors/ktexmaker2/ktexmaker2-1.4.ebuild
@@ -8,13 +8,21 @@ DESCRIPTION="A Latex Editor and TeX shell for kde2"
SRC_URI="http://xm1.net.free.fr/linux/${A}"
HOMEPAGE="http://xm1.net.free.fr/linux/"
-DEPEND=">=kde-base/kdelibs-2.1.1"
+DEPEND=">=kde-base/kdelibs-2.1.1 sys-devel/perl"
+RDEPEND=">=kde-base/kdelibs-2.1.1"
-RDEPEND=$DEPEND
src_compile() {
-
- try ./configure --prefix=${KDEDIR} --host=${CHOST}
+ local myconf
+ if [ "`use qtmt`" ]
+ then
+ myconf="--enable-mt"
+ fi
+ if [ "`use mitshm`" ]
+ then
+ myconf="$myconf --enable-mitshm"
+ fi
+ try ./configure --prefix=${KDEDIR} --host=${CHOST} $myconf
try make
}
diff --git a/app-editors/quanta/quanta-2.0-r1.ebuild b/app-editors/quanta/quanta-2.0-r1.ebuild
index b3471d7ea649..3777b71d0bca 100644
--- a/app-editors/quanta/quanta-2.0-r1.ebuild
+++ b/app-editors/quanta/quanta-2.0-r1.ebuild
@@ -13,8 +13,16 @@ DEPEND=">=kde-base/kdelibs-2.1.1"
RDEPEND=$DEPEND
src_compile() {
-
- try ./configure --prefix=${KDEDIR} --host=${CHOST}
+ local myconf
+ if [ "`use qtmt`" ]
+ then
+ myconf="--enable-mt"
+ fi
+ if [ "`use mitshm`" ]
+ then
+ myconf="$myconf --enable-mitshm"
+ fi
+ try ./configure --prefix=${KDEDIR} --host=${CHOST} $myconf
try make
}