summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-06-24 07:55:07 +0000
committerMike Frysinger <vapier@gentoo.org>2006-06-24 07:55:07 +0000
commite77834a7b0ef56e897611b3a94aa4594357dbf93 (patch)
tree995964e591a56c01eee104af79ee8c11045482a2 /app-emulation/cedega/cedega-5.2.1.ebuild
parentpull in xmessage #137065 by Fabrice Delliaux (diff)
downloadhistorical-e77834a7b0ef56e897611b3a94aa4594357dbf93.tar.gz
historical-e77834a7b0ef56e897611b3a94aa4594357dbf93.tar.bz2
historical-e77834a7b0ef56e897611b3a94aa4594357dbf93.zip
Version bump #136717 by Rich Gannon.
Package-Manager: portage-2.1.1_pre1-r2
Diffstat (limited to 'app-emulation/cedega/cedega-5.2.1.ebuild')
-rw-r--r--app-emulation/cedega/cedega-5.2.1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/app-emulation/cedega/cedega-5.2.1.ebuild b/app-emulation/cedega/cedega-5.2.1.ebuild
new file mode 100644
index 000000000000..d9128f0f07d6
--- /dev/null
+++ b/app-emulation/cedega/cedega-5.2.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/cedega-5.2.1.ebuild,v 1.1 2006/06/24 07:55:07 vapier Exp $
+
+MY_P="cedega-small-${PV}"
+DESCRIPTION="Cedega replaces WineX, a distribution of Wine with enhanced DirectX for gaming"
+HOMEPAGE="http://www.transgaming.com/"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="Aladdin"
+SLOT="3"
+KEYWORDS="-* amd64 x86"
+IUSE="cups dbus opengl"
+RESTRICT="fetch strip"
+
+RDEPEND="|| ( ( x11-libs/libX11 ) virtual/x11 )
+ opengl? ( virtual/opengl )
+ dbus? ( sys-apps/dbus )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.4
+ !app-emulation/point2play
+ amd64? ( app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-soundlibs )"
+
+pkg_nofetch() {
+ einfo "Please download the appropriate Cedega archive (${MY_P}.tgz)"
+ einfo "from ${HOMEPAGE} (requires a Transgaming subscription)"
+ einfo
+ einfo "Then put the file in ${DISTDIR}"
+}
+
+src_install() {
+ rm -r "${WORKDIR}"/usr/share/gnome
+ rmdir "${WORKDIR}"/usr/share/* >& /dev/null
+ mv "${WORKDIR}"/usr "${D}"/ || die "mv usr"
+}
+
+pkg_postinst() {
+ einfo "Run /usr/bin/cedega to start cedega as any non-root user."
+ einfo "This is a wrapper-script which will take care of creating"
+ einfo "an initial environment and do everything else."
+ einfo ""
+ einfo "Optionally, if you have binfmt_misc compiled into your kernel,"
+ einfo "you can add the following to /etc/sysctl.conf to allow direct"
+ einfo "excecution of Windows binaries through the cedega wrapper:"
+ einfo ""
+ einfo " fs.binfmt_misc.register = :WINEXE:M::MZ::/usr/bin/cedega:"
+ einfo ""
+ einfo "You will also need to mount the /proc/sys/fs/binfmt_misc"
+ einfo "file system in order for this to work. You can add the following"
+ einfo "line into your /etc/fstab file:"
+ einfo ""
+ einfo " none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0"
+ einfo ""
+ einfo "Note: Binaries will still need excecutable permissions to run."
+ einfo "Note: If binfmt_misc is compiled as a module, make sure you"
+ einfo "have it loaded on startup by adding it to"
+ einfo "/etc/modules.autoload.d/<your kernel version>"
+}