summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-06 23:58:51 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-06 23:58:51 +0000
commite3394d894883f3afbc0055a2c02ce5e01b64c865 (patch)
tree0bbc967597386ddc27250c68604b64334e1844fa /app-emulation/softgun/softgun-0.09.ebuild
parentfilter mtune -> mcpu with gcc2 #88147 (diff)
downloadhistorical-e3394d894883f3afbc0055a2c02ce5e01b64c865.tar.gz
historical-e3394d894883f3afbc0055a2c02ce5e01b64c865.tar.bz2
historical-e3394d894883f3afbc0055a2c02ce5e01b64c865.zip
Version bump, thanks to Mr_Bones.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'app-emulation/softgun/softgun-0.09.ebuild')
-rw-r--r--app-emulation/softgun/softgun-0.09.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/softgun/softgun-0.09.ebuild b/app-emulation/softgun/softgun-0.09.ebuild
new file mode 100644
index 000000000000..c561fe0af9fd
--- /dev/null
+++ b/app-emulation/softgun/softgun-0.09.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/softgun/softgun-0.09.ebuild,v 1.1 2005/04/06 23:58:51 vapier Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="ARM software emulator"
+HOMEPAGE="http://softgun.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e 's:/usr/local:$(DESTDIR)/usr:' \
+ Makefile || die "sed Makefile failed"
+ sed -i \
+ -e "/^CFLAGS/s:-O9.*-fomit-frame-pointer:${CFLAGS}:" \
+ config.mk || die "sed config.mk failed"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "Make feiled"
+}
+
+src_install() {
+ dodir /usr/bin
+ make install DESTDIR="${D}" || die "Install failed"
+ dodoc README defaultconfig
+}
+
+pkg_postinst() {
+ einfo "To create a configuration file, run as user:"
+ einfo " gzcat /usr/share/doc/${PF}/defaultconfig.gz > ~/.emuconfig"
+}