summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-27 23:10:34 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-27 23:10:34 +0000
commit509ff8ffdb33d927dfa9f22084998201d6fb2d33 (patch)
tree1a2f1ccd202c2b3986e11f4d3e52c82fcb712154 /app-emulation/vmware-workstation
parentver bump (diff)
downloadhistorical-509ff8ffdb33d927dfa9f22084998201d6fb2d33.tar.gz
historical-509ff8ffdb33d927dfa9f22084998201d6fb2d33.tar.bz2
historical-509ff8ffdb33d927dfa9f22084998201d6fb2d33.zip
touch the libc
Diffstat (limited to 'app-emulation/vmware-workstation')
-rw-r--r--app-emulation/vmware-workstation/vmware-workstation-3.2.1.2242-r1.ebuild13
-rw-r--r--app-emulation/vmware-workstation/vmware-workstation-4.5.1.7568-r1.ebuild4
-rw-r--r--app-emulation/vmware-workstation/vmware-workstation-4.5.2.8848.ebuild4
3 files changed, 10 insertions, 11 deletions
diff --git a/app-emulation/vmware-workstation/vmware-workstation-3.2.1.2242-r1.ebuild b/app-emulation/vmware-workstation/vmware-workstation-3.2.1.2242-r1.ebuild
index ffaa9b27b837..f6a8b09b9ac7 100644
--- a/app-emulation/vmware-workstation/vmware-workstation-3.2.1.2242-r1.ebuild
+++ b/app-emulation/vmware-workstation/vmware-workstation-3.2.1.2242-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation/vmware-workstation-3.2.1.2242-r1.ebuild,v 1.9 2004/06/24 22:36:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation/vmware-workstation-3.2.1.2242-r1.ebuild,v 1.10 2004/06/27 23:08:53 vapier Exp $
# Unlike many other binary packages the user doesn't need to agree to a licence
# to download VM Ware. The agreeing to a licence is part of the configure step
@@ -29,7 +29,7 @@ KEYWORDS="-* x86"
IUSE=""
RESTRICT="nostrip"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
virtual/x11
virtual/os-headers
>=dev-lang/perl-5
@@ -45,10 +45,9 @@ src_unpack() {
}
src_compile() {
-
-has_version \<sys-libs/glibc-2.3.2 \
- && GLIBC_232=0 \
- || GLIBC_232=1
+ has_version '<sys-libs/glibc-2.3.2' \
+ && GLIBC_232=0 \
+ || GLIBC_232=1
if [ ${GLIBC_232} -eq 1 ] ; then
$(gcc-getCC) -W -Wall -shared -o vmware-glibc-2.3.2-compat.so \
@@ -174,7 +173,7 @@ pkg_preinst() {
done
}
-pkg_postinst () {
+pkg_postinst() {
# This is to fix the problem where the not_configured file doesn't get
# removed when the configuration is run. This doesn't remove the file
# It just tells the vmware-config.pl script it can delete it.
diff --git a/app-emulation/vmware-workstation/vmware-workstation-4.5.1.7568-r1.ebuild b/app-emulation/vmware-workstation/vmware-workstation-4.5.1.7568-r1.ebuild
index ef2b0539ea55..a7c0e3ff9931 100644
--- a/app-emulation/vmware-workstation/vmware-workstation-4.5.1.7568-r1.ebuild
+++ b/app-emulation/vmware-workstation/vmware-workstation-4.5.1.7568-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation/vmware-workstation-4.5.1.7568-r1.ebuild,v 1.6 2004/06/24 22:36:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation/vmware-workstation-4.5.1.7568-r1.ebuild,v 1.7 2004/06/27 23:08:53 vapier Exp $
# Unlike many other binary packages the user doesn't need to agree to a licence
# to download VMWare. The agreeing to a licence is part of the configure step
@@ -35,7 +35,7 @@ KEYWORDS="-* x86 -amd64"
# For more information, see bugs #49203 #49163 #47023
RESTRICT="nostrip"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
virtual/x11
virtual/os-headers
>=dev-lang/perl-5
diff --git a/app-emulation/vmware-workstation/vmware-workstation-4.5.2.8848.ebuild b/app-emulation/vmware-workstation/vmware-workstation-4.5.2.8848.ebuild
index e75a1225f790..6349d44a9ff2 100644
--- a/app-emulation/vmware-workstation/vmware-workstation-4.5.2.8848.ebuild
+++ b/app-emulation/vmware-workstation/vmware-workstation-4.5.2.8848.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation/vmware-workstation-4.5.2.8848.ebuild,v 1.4 2004/06/24 22:36:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation/vmware-workstation-4.5.2.8848.ebuild,v 1.5 2004/06/27 23:08:53 vapier Exp $
# Unlike many other binary packages the user doesn't need to agree to a licence
# to download VMWare. The agreeing to a licence is part of the configure step
@@ -39,7 +39,7 @@ KEYWORDS="-* ~x86 -amd64"
# interested in VMware on amd64, you should add yourself to the CC of that bug.
RESTRICT="nostrip"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
virtual/x11
virtual/os-headers
>=dev-lang/perl-5