summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhil Bordelon <sunflare@gentoo.org>2003-03-19 03:16:23 +0000
committerPhil Bordelon <sunflare@gentoo.org>2003-03-19 03:16:23 +0000
commit662606f1879b712b1c6d3f7ec40bc3c93f805c03 (patch)
tree5a67d0adeab51395ffa13f82da9f619e6655d991 /app-emulation
parentadd new eclass to assist with cross-compiling efforts (diff)
downloadhistorical-662606f1879b712b1c6d3f7ec40bc3c93f805c03.tar.gz
historical-662606f1879b712b1c6d3f7ec40bc3c93f805c03.tar.bz2
historical-662606f1879b712b1c6d3f7ec40bc3c93f805c03.zip
New FCEUltra, one which works with modern GCCs. Also tonnes of bugfixes and the usual emulation love.
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/fceultra/ChangeLog9
-rw-r--r--app-emulation/fceultra/fceultra-093.ebuild55
-rw-r--r--app-emulation/fceultra/files/digest-fceultra-0931
3 files changed, 64 insertions, 1 deletions
diff --git a/app-emulation/fceultra/ChangeLog b/app-emulation/fceultra/ChangeLog
index 0710831e2724..20e9fcc975b9 100644
--- a/app-emulation/fceultra/ChangeLog
+++ b/app-emulation/fceultra/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/fceultra
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/fceultra/ChangeLog,v 1.9 2003/02/12 04:00:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/fceultra/ChangeLog,v 1.10 2003/03/19 03:16:23 sunflare Exp $
+
+*fceultra-093 (18 Mar 2003)
+
+ 18 Mar 2003; Phil Bordelon <sunflare@gentoo.org> fceultra-093.ebuild:
+ Updated to the latest version of fceultra. This requires GCC 3.2.2, so
+ it's got that as a requirement now. Marked as testing for obvious
+ reasons.
*fceultra-081-r1 (22 Nov 2002)
diff --git a/app-emulation/fceultra/fceultra-093.ebuild b/app-emulation/fceultra/fceultra-093.ebuild
new file mode 100644
index 000000000000..dcc3e1217649
--- /dev/null
+++ b/app-emulation/fceultra/fceultra-093.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/fceultra/fceultra-093.ebuild,v 1.1 2003/03/19 03:16:23 sunflare Exp $
+
+inherit gcc
+
+MY_P=fceu
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A portable NES/Famicom emulator"
+SRC_URI="http://fceultra.sourceforge.net/dev/${MY_P}${PV}src.tar.gz"
+HOMEPAGE="http://fceultra.sourceforge.net/"
+
+SLOT="0"
+KEYWORDS="~x86 -ppc"
+LICENSE="GPL-2"
+
+# Because of code generation bugs, FCEUltra now depends on a version
+# of gcc greater than or equal to GCC 3.2.2.
+
+DEPEND="svga? ( media-libs/svgalib )
+ sdl? ( media-libs/libsdl )
+ >=sys-devel/gcc-3.2.2"
+
+RDEPEND=${DEPEND}
+
+pkg_setup() {
+
+ use sdl && return 0
+ use svga && return 0
+
+ eerror "You must have 'sdl' or 'svga' in your USE variable"
+ die "unable to build SVGA or SDL versions"
+}
+
+src_compile() {
+ mv Makefile.base Makefile.orig
+ sed -e "s:\${TFLAGS}:\${TFLAGS} ${CFLAGS}:" \
+ Makefile.orig > Makefile.base
+
+ if [ `use sdl` ] ; then
+ make -f Makefile.unixsdl || die "sdl make failed"
+ mv fceu fceu-sdl
+ make -f Makefile.unixsdl clean
+ fi
+ if [ `use svga` ] ; then
+ make -f Makefile.linuxvga || die "svga make failed"
+ mv fceu fceu-svga
+ fi
+}
+
+src_install() {
+ use sdl && dobin fceu-sdl
+ use svga && dobin fceu-svga
+ dodoc Documentation/{*,rel/readme-linux.txt}
+}
diff --git a/app-emulation/fceultra/files/digest-fceultra-093 b/app-emulation/fceultra/files/digest-fceultra-093
new file mode 100644
index 000000000000..5f20e5cb2ae7
--- /dev/null
+++ b/app-emulation/fceultra/files/digest-fceultra-093
@@ -0,0 +1 @@
+MD5 c2fea068f1db62ec51f6fc77f1c5da82 fceu093src.tar.gz 450883