summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-04-11 21:58:55 +0000
committerMike Frysinger <vapier@gentoo.org>2006-04-11 21:58:55 +0000
commit929e7fa6cb2f485e11a86f5b3e3e6efa42b5aa34 (patch)
tree3836020856d3a7de01ff8c9c75e6402c4209a464 /app-emulation
parentStable on sparc (diff)
downloadhistorical-929e7fa6cb2f485e11a86f5b3e3e6efa42b5aa34.tar.gz
historical-929e7fa6cb2f485e11a86f5b3e3e6efa42b5aa34.tar.bz2
historical-929e7fa6cb2f485e11a86f5b3e3e6efa42b5aa34.zip
need to fix the winegcc code rather than hacking individual sections of code #129557
Package-Manager: portage-2.1_pre7-r5
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/Manifest12
-rw-r--r--app-emulation/wine/wine-0.9.11.ebuild12
2 files changed, 8 insertions, 16 deletions
diff --git a/app-emulation/wine/Manifest b/app-emulation/wine/Manifest
index b719768d1ca0..3cb499b27c3c 100644
--- a/app-emulation/wine/Manifest
+++ b/app-emulation/wine/Manifest
@@ -133,9 +133,9 @@ SHA256 1e938dc1fa681a24126e5aa334dc73e3a02a5410781bbea641d5fbf0ca61401e wine-0.9
MD5 1ecfc5fed64aebe42b95c70761331a6d wine-0.9.10.ebuild 3489
RMD160 dc1a22106793861ad2036385fa021ca9dd684366 wine-0.9.10.ebuild 3489
SHA256 b9cd6ccaaed8d78f57894cf675a43a33e3eb9c64c31a4c38622bbda05137b5b9 wine-0.9.10.ebuild 3489
-MD5 39decb2dea313a0adf4721a57405bd25 wine-0.9.11.ebuild 3788
-RMD160 0ae964c25aa86ad42fe48894621ee1a0b89e270a wine-0.9.11.ebuild 3788
-SHA256 211b5b277fd93d70e059d4f1d0cb0d40f22528a5a0eb656f7715db2f6d2d6171 wine-0.9.11.ebuild 3788
+MD5 077640101d794f54377217482e820b07 wine-0.9.11.ebuild 3504
+RMD160 c97c9016e872bfba22cdb98320c5cacc07982117 wine-0.9.11.ebuild 3504
+SHA256 d35ea54f4817daccbd93508e82b29037bc192e4da13c166cc61f1fd15182d7af wine-0.9.11.ebuild 3504
MD5 0e8a939a0799b82181ee17f084caf7eb wine-0.9.2.ebuild 4161
RMD160 32af02785815020bd693318786246cd46ea8107b wine-0.9.2.ebuild 4161
SHA256 aa516a61dd7eaa622a5b0e8cd74646371371f13a2118cf6989f88eb7a75e2268 wine-0.9.2.ebuild 4161
@@ -199,7 +199,7 @@ SHA256 e08dfbc889806d6eb63eda6d255f29afb2921123703cd04682533e817f60e182 wine-999
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)
-iD8DBQFEOuUk2+ySkm8kpY0RAryPAKCGYVo/3j/g9hDGTOJeFpkx0UXwxgCff27t
-NGyd8UuAWlY+zl6WMLqJtz8=
-=wYXr
+iD8DBQFEPCa02+ySkm8kpY0RAqriAJ94Jx93/BNg9LnqM76aNK8M8vCcWQCeORoZ
+F5hmHC8XFLEignLp+opQWr0=
+=82es
-----END PGP SIGNATURE-----
diff --git a/app-emulation/wine/wine-0.9.11.ebuild b/app-emulation/wine/wine-0.9.11.ebuild
index 24be12070bfe..1947e3a85a33 100644
--- a/app-emulation/wine/wine-0.9.11.ebuild
+++ b/app-emulation/wine/wine-0.9.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.11.ebuild,v 1.4 2006/04/10 23:07:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-0.9.11.ebuild,v 1.5 2006/04/11 21:58:55 vapier Exp $
inherit eutils flag-o-matic multilib
@@ -10,7 +10,7 @@ SRC_URI="mirror://sourceforge/${PN}/wine-${PV}.tar.bz2"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="-* ~amd64 ~x86"
+KEYWORDS="-* -amd64 ~x86"
IUSE="alsa arts cups debug esd gif glut jack jpeg lcms ldap nas ncurses opengl oss scanner truetype xml X"
RESTRICT="test" #72375
@@ -70,14 +70,6 @@ src_unpack() {
sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in
epatch "${FILESDIR}"/wine-gentoo-no-ssp.patch #66002
sed -i '/^MimeType/d' tools/wine.desktop || die #117785
-
- # disable X include / lib searching as we setup our toolchain
- # to properly locate the files ... otherwise, it'll use the host
- # `xmkmf` binary which reports 'lib64' on amd64. boo!
- sed -i \
- -e '/^x_includes=/s:=NONE:=:' \
- -e '/^x_libraries=/s:=NONE:=:' \
- configure || die
}
config_cache() {