summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-06-21 08:05:33 +0000
committerMike Frysinger <vapier@gentoo.org>2003-06-21 08:05:33 +0000
commite0dadb46b9d27190ee8445ea0bf03bdeb55731fc (patch)
tree37d76c1fce84ef0708a18c61a673b2871dc5e787 /app-emulation
parentVersion bump. (diff)
downloadhistorical-e0dadb46b9d27190ee8445ea0bf03bdeb55731fc.tar.gz
historical-e0dadb46b9d27190ee8445ea0bf03bdeb55731fc.tar.bz2
historical-e0dadb46b9d27190ee8445ea0bf03bdeb55731fc.zip
part of fixing #13542
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/game-launcher/ChangeLog13
-rw-r--r--app-emulation/game-launcher/Manifest6
-rw-r--r--app-emulation/game-launcher/files/0.9.8-digi-oss.patch7
-rw-r--r--app-emulation/game-launcher/files/0.9.8-gcc3.patch11
-rw-r--r--app-emulation/game-launcher/game-launcher-0.9.8.ebuild75
5 files changed, 58 insertions, 54 deletions
diff --git a/app-emulation/game-launcher/ChangeLog b/app-emulation/game-launcher/ChangeLog
index cdd3ac096e63..c322acd2b129 100644
--- a/app-emulation/game-launcher/ChangeLog
+++ b/app-emulation/game-launcher/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for app-emulation/game-launcher
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/game-launcher/ChangeLog,v 1.4 2003/02/12 04:00:59 vapier Exp $
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/game-launcher/ChangeLog,v 1.5 2003/06/21 08:05:27 vapier Exp $
-* game-launcher-0.9.8 (27 Oct 2002)
+*game-launcher-0.9.8 (27 Oct 2002)
+
+ 21 Jun 2003; Mike Frysinger <vapier@gentoo.org> :
+ Added games.eclass support and a gcc-3.x patch.
+
27 Oct 2002; Thomas Raschbacher <lordvan@gentoo.org>: added ebuild
WARNING: is a security-hole cuz parts of it are(and have to be) world-writeable!!!!
+
04 Jan 2003; Thomas Raschbacher <lordvan@gentoo.org>:
- fixed ChangeLog \ No newline at end of file
+ fixed ChangeLog
diff --git a/app-emulation/game-launcher/Manifest b/app-emulation/game-launcher/Manifest
index 3b25191f4e46..94a7b1ef99a3 100644
--- a/app-emulation/game-launcher/Manifest
+++ b/app-emulation/game-launcher/Manifest
@@ -1,3 +1,5 @@
-MD5 bb4d7fa4b3051fda8b475bee939c2a4e ChangeLog 501
-MD5 f8b274403c5e1bbdd7cb8a5a61b810c7 game-launcher-0.9.8.ebuild 2225
+MD5 0ce1a828196b8d4e3e0302ed4d95c4d3 files/0.9.8-gcc3.patch 299
MD5 79514d6adf8fd7f9d6fc78210cc91aee files/digest-game-launcher-0.9.8 55
+MD5 671b1311f9989ac4e746ae60042ec36c files/0.9.8-digi-oss.patch 229
+MD5 6a4fa3f8e4480394f5d61c80d45a408d game-launcher-0.9.8.ebuild 1240
+MD5 5d0398b6fc3cc5cd8560a9fc3363ffca ChangeLog 598
diff --git a/app-emulation/game-launcher/files/0.9.8-digi-oss.patch b/app-emulation/game-launcher/files/0.9.8-digi-oss.patch
new file mode 100644
index 000000000000..d96c89f758ec
--- /dev/null
+++ b/app-emulation/game-launcher/files/0.9.8-digi-oss.patch
@@ -0,0 +1,7 @@
+--- engine/engine.cc.orig 2003-06-21 03:11:03.000000000 -0400
++++ engine/engine.cc 2003-06-21 03:10:28.000000000 -0400
+@@ -1,3 +1,4 @@
++#define ALLEGRO_WITH_OSSDIGI
+ #include <iostream>
+ #include <strstream>
+ #include <stdlib.h>
diff --git a/app-emulation/game-launcher/files/0.9.8-gcc3.patch b/app-emulation/game-launcher/files/0.9.8-gcc3.patch
new file mode 100644
index 000000000000..141ac66a822d
--- /dev/null
+++ b/app-emulation/game-launcher/files/0.9.8-gcc3.patch
@@ -0,0 +1,11 @@
+--- ./startup/unix/glaunch.cc.old 2003-01-08 15:38:38.000000000 -0800
++++ ./startup/unix/glaunch.cc 2003-01-08 15:41:38.000000000 -0800
+@@ -5,6 +5,8 @@
+ #include "exit.h"
+ #include <stdio.h>
+
++using namespace std;
++
+ static int runProgram(const char * program);
+
+ int main(int argc, char *argv[])
diff --git a/app-emulation/game-launcher/game-launcher-0.9.8.ebuild b/app-emulation/game-launcher/game-launcher-0.9.8.ebuild
index 3b5eb84f142e..97449a4c83dc 100644
--- a/app-emulation/game-launcher/game-launcher-0.9.8.ebuild
+++ b/app-emulation/game-launcher/game-launcher-0.9.8.ebuild
@@ -1,63 +1,42 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/game-launcher/game-launcher-0.9.8.ebuild,v 1.3 2003/03/11 20:50:08 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/game-launcher/game-launcher-0.9.8.ebuild,v 1.4 2003/06/21 08:05:27 vapier Exp $
-DESCRIPTION="Game Launcher is a cross platform, universal front end for emulators.It has been known to work with MAME, Nesticle, RockNES, zSNES, snes9x, Callus, Stella, z26 and Genecyst."
+inherit games eutils
+
+DESCRIPTION="universal front end for emulators ... works with MAME, Nesticle, RockNES, zSNES, snes9x, Callus, Stella, z26, and Genecyst"
HOMEPAGE="http://www.dribin.org/dave/game_launcher/"
-SRC_URI="mirror://sourceforge/glaunch/gl098s.zip"
+SRC_URI="mirror://sourceforge/glaunch/gl${PV//./}s.zip"
+
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-DEPEND=">=media-libs/allegro-4.0.0
- >=media-libs/loadpng-0.11
- >=media-libs/allegromp3-2.0.2
- >=media-libs/allegttf-2.0
- >=media-libs/libpng-1.2.4
- >=sys-libs/zlib-1.1.4
- >=app-arch/unzip-5.50
- >=app-text/recode-3.6"
+KEYWORDS="x86"
RDEPEND=">=media-libs/allegro-4.0.0
- >=media-libs/loadpng-0.11
- >=media-libs/allegromp3-2.0.2
- >=media-libs/allegttf-2.0
+ >=media-libs/loadpng-0.11
+ >=media-libs/allegromp3-2.0.2
+ >=media-libs/allegttf-2.0
>=media-libs/libpng-1.2.4
- >=sys-libs/zlib-1.1.4"
+ >=media-libs/jpgalleg-1.1
+ >=sys-libs/zlib-1.1.4"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
-# Source directory; the dir where the sources can be found (automatically
-# unpacked) inside ${WORKDIR}. S will get a default setting of ${WORKDIR}/${P}
-# if you omit this line.
-S="${WORKDIR}/glaunch"
+S=${WORKDIR}/glaunch
src_compile() {
- cd ${S}
- # got to recode this cuz gcc complains about CF+LF after a '\'
- recode /CR mamescan/main.cc \
- mamescan/scanner.cc \
- mamescan/gamelist.cc \
- model/emumgr.cc \
- control/emumenu.cc \
- control/launcher.cc \
- control/bgctrl.cc
- # set TARGET (maybe set compile options here later too)
- mv common.mk common.mk_orig
- sed s/'TARGET\(.*\)= MINGW'/'#TARGET\1= MINGW'/ common.mk_orig | sed s/'#TARGET\(.*\)= UNIX'/'TARGET\1= UNIX'/ > common.mk
- emake || die
-
-}
+ edos2unix `find -regex '.*\.[ch]' -or -name '*.cc'`
-src_install() {
- dodir /opt/${P}
-# cp glaunch _gl32 glaunch.dat glaunch.cfg slicker.ttf mamescan.exe ${D}/opt/${P}
- cp -r ${S}/* ${D}/opt/${P} # doinst can't do recursive
+ epatch ${FILESDIR}/${PV}-gcc3.patch
+ epatch ${FILESDIR}/${PV}-digi-oss.patch
+
+ mv common.mk common.mk_orig
+ sed s/'TARGET\(.*\)= MINGW'/'#TARGET\1= MINGW'/ common.mk_orig | sed s/'#TARGET\(.*\)= UNIX'/'TARGET\1= UNIX'/ > common.mk
+ emake || die
}
-pkg_postinst() {
- echo
- einfo "WARNING: Some files in /opt/${P} are world writeable!!!"
- einfo "Because of the design that can't be changed easily."
- einfo "You can add a new group and then change the permissions."
- einfo "Members of that group then can run it."
- echo
+src_install() {
+ dodir /opt/${P}
+ cp -r ${S}/* ${D}/opt/${P} # doinst can't do recursive
+ prepgamesdirs
}