summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-11-09 00:06:08 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-11-09 00:06:08 +0000
commit289d2fd4b2f476c5180341c7794f85910f32ddfa (patch)
tree23cfb27aead14d1705e84b30f359d13559b4bad5 /app-i18n/ibus-skk/ibus-skk-1.3.3.ebuild
parentVersion bumped. Added gost USE flag. (diff)
downloadhistorical-289d2fd4b2f476c5180341c7794f85910f32ddfa.tar.gz
historical-289d2fd4b2f476c5180341c7794f85910f32ddfa.tar.bz2
historical-289d2fd4b2f476c5180341c7794f85910f32ddfa.zip
Version bumped.
Package-Manager: portage-2.1.9.22/cvs/Linux x86_64
Diffstat (limited to 'app-i18n/ibus-skk/ibus-skk-1.3.3.ebuild')
-rw-r--r--app-i18n/ibus-skk/ibus-skk-1.3.3.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-i18n/ibus-skk/ibus-skk-1.3.3.ebuild b/app-i18n/ibus-skk/ibus-skk-1.3.3.ebuild
new file mode 100644
index 000000000000..f32d3ce74cd5
--- /dev/null
+++ b/app-i18n/ibus-skk/ibus-skk-1.3.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-skk/ibus-skk-1.3.3.ebuild,v 1.1 2010/11/09 00:06:08 matsuu Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2:2.5"
+inherit python
+
+DESCRIPTION="Japanese input method Anthy IMEngine for IBus Framework"
+HOMEPAGE="http://github.com/ueno/ibus-skk"
+SRC_URI="http://cloud.github.com/downloads/ueno/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=app-i18n/ibus-1.3
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+RDEPEND="${RDEPEND}
+ app-i18n/skk-jisyo"
+
+pkg_setup() {
+ python_set_active_version 2
+
+}
+
+src_prepare() {
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_configure() {
+ econf $(use_enable nls) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}