summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2014-12-05 19:09:11 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2014-12-05 19:09:11 +0000
commita9fe921a9f96205e41d96c8ce2dd99132c5ab0c5 (patch)
tree21b088c3f84238ff5ac5c166768b640d437a661f /app-misc/hivex/hivex-1.3.11.ebuild
parentClean old, thanks to slepnoga (diff)
downloadhistorical-a9fe921a9f96205e41d96c8ce2dd99132c5ab0c5.tar.gz
historical-a9fe921a9f96205e41d96c8ce2dd99132c5ab0c5.tar.bz2
historical-a9fe921a9f96205e41d96c8ce2dd99132c5ab0c5.zip
Bump to 1.3.11, fixes security bug #490990. Thanks to slepnoga.
Package-Manager: portage-2.2.15/cvs/Linux x86_64 Manifest-Sign-Key: 0xF8DBDADE
Diffstat (limited to 'app-misc/hivex/hivex-1.3.11.ebuild')
-rw-r--r--app-misc/hivex/hivex-1.3.11.ebuild115
1 files changed, 115 insertions, 0 deletions
diff --git a/app-misc/hivex/hivex-1.3.11.ebuild b/app-misc/hivex/hivex-1.3.11.ebuild
new file mode 100644
index 000000000000..751af497ac0e
--- /dev/null
+++ b/app-misc/hivex/hivex-1.3.11.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hivex/hivex-1.3.11.ebuild,v 1.1 2014/12/05 19:09:03 maksbotan Exp $
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+USE_RUBY="ruby20"
+RUBY_OPTIONAL=yes
+
+PYTHON_COMPAT=(python2_7 python3_{3,4})
+
+inherit base autotools autotools-utils eutils perl-app ruby-ng python-single-r1
+
+DESCRIPTION="Library for reading and writing Windows Registry 'hive' binary files"
+HOMEPAGE="http://libguestfs.org"
+SRC_URI="http://libguestfs.org/download/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ocaml readline +perl python test static-libs ruby"
+
+RDEPEND="
+ virtual/libiconv
+ virtual/libintl
+ dev-libs/libxml2:2
+ ocaml? ( dev-lang/ocaml[ocamlopt]
+ dev-ml/findlib[ocamlopt]
+ )
+ readline? ( sys-libs/readline )
+ perl? ( dev-perl/IO-stringy )
+ ruby? ( $(ruby_implementations_depend) )
+ python? ( ${PYTHON_DEPS} )
+ "
+
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ perl? (
+ test? ( dev-perl/Pod-Coverage
+ dev-perl/Test-Pod-Coverage )
+ )
+ "
+
+ruby_add_bdepend "ruby? ( dev-ruby/rake )"
+ruby_add_bdepend "ruby? ( virtual/ruby-rdoc )"
+
+REQUIRED_USE="python? ( ${PYTHON_REQ_USE} )"
+
+DOCS=( README )
+S="${WORKDIR}/${P}"
+
+#We are aware of rather poor quality of this ebuild, but the bump is required to fix security bug. We will fix other matters later.
+
+pkg_setup() {
+ if use python; then
+ python-single-r1_pkg_setup
+ fi
+ if use perl; then
+ perl-module_pkg_setup
+ fi
+}
+
+src_unpack() {
+ default
+}
+
+src_prepare() {
+ base_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with readline)
+ $(use_enable ocaml)
+ $(use_enable perl)
+ --enable-nls
+ $(use_enable python)
+ $(use_enable ruby)
+ --disable-rpath )
+
+ autotools-utils_src_configure
+
+ if use perl; then
+ pushd perl
+ perl-app_src_configure
+ popd
+ fi
+}
+
+src_compile() {
+ autotools-utils_src_compile
+}
+
+# Test binding's dont't wok properly in gentoo layout
+#src_test() {
+# if use perl;then
+# pushd perl
+# perl-app_src_install
+# popd
+# fi
+#
+# autotools-utils_src_compile check
+#}
+
+src_install() {
+ strip-linguas -i po
+
+ autotools-utils_src_install "LINGUAS=""${LINGUAS}"""
+
+ if use perl; then
+ perl_delete_localpod
+ fi
+}