summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2003-12-22 19:08:27 +0000
committerTom William Payne <twp@gentoo.org>2003-12-22 19:08:27 +0000
commit850b8a27113cfd03e6931f6b47c12a8cc763d21a (patch)
tree3ce06c34ef5258cf3b4d3c598f1bc0814b25baf6 /app-misc/run-mailcap/run-mailcap-3.23_p1-r1.ebuild
parentSee ChangeLog (diff)
downloadhistorical-850b8a27113cfd03e6931f6b47c12a8cc763d21a.tar.gz
historical-850b8a27113cfd03e6931f6b47c12a8cc763d21a.tar.bz2
historical-850b8a27113cfd03e6931f6b47c12a8cc763d21a.zip
See ChangeLog
Diffstat (limited to 'app-misc/run-mailcap/run-mailcap-3.23_p1-r1.ebuild')
-rw-r--r--app-misc/run-mailcap/run-mailcap-3.23_p1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/run-mailcap/run-mailcap-3.23_p1-r1.ebuild b/app-misc/run-mailcap/run-mailcap-3.23_p1-r1.ebuild
new file mode 100644
index 000000000000..7ebf40ef9b38
--- /dev/null
+++ b/app-misc/run-mailcap/run-mailcap-3.23_p1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/run-mailcap/run-mailcap-3.23_p1-r1.ebuild,v 1.1 2003/12/22 19:08:18 twp Exp $
+
+MY_PV="${PV/_p/-}"
+DESCRIPTION="Execute programs via entries in the mailcap file"
+HOMEPAGE="http://packages.debian.org/unstable/net/mime-support.html"
+SRC_URI="mirror://debian/pool/main/m/mime-support/mime-support_${MY_PV}.tar.gz"
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~alpha ~arm ~hppa ~mips ~sparc ~ppc x86"
+IUSE=""
+DEPEND=""
+RDEPEND=">=dev-lang/perl-5.6*"
+
+S=${WORKDIR}/mime-support
+
+src_compile() {
+ sed -i run-mailcap -e 's:^\(\$xtermprgrm=\)"/usr/bin/x-terminal-emulator":\1$ENV{XTERMCMD} || "xterm":'
+ cp run-mailcap.man run-mailcap.1
+ cp mailcap.man mailcap.5
+}
+
+src_install() {
+ dobin run-mailcap
+ doman run-mailcap.1 mailcap.5
+ insinto /etc
+ doins mime.types
+ for i in compose edit see print; do
+ ( cd ${D}/usr/bin && ln -s run-mailcap $i )
+ ( cd ${D}/usr/share/man/man1 && ln -s run-mailcap.1 $i.1 )
+ done
+}