summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 21:35:06 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 21:35:06 +0000
commitf973ebc0058cc6331b221ce787310fe2522d724c (patch)
treea4c0720a759b8892c8fcb2fc2eff773b504249bc /app-misc/twin
parentChanged src_install () to src_install() (diff)
downloadhistorical-f973ebc0058cc6331b221ce787310fe2522d724c.tar.gz
historical-f973ebc0058cc6331b221ce787310fe2522d724c.tar.bz2
historical-f973ebc0058cc6331b221ce787310fe2522d724c.zip
Changed einstall||die to einstall
Diffstat (limited to 'app-misc/twin')
-rw-r--r--app-misc/twin/twin-0.4.4.ebuild24
-rw-r--r--app-misc/twin/twin-0.4.5.ebuild26
2 files changed, 21 insertions, 29 deletions
diff --git a/app-misc/twin/twin-0.4.4.ebuild b/app-misc/twin/twin-0.4.4.ebuild
index ae7f5689b047..9ba9c9591f84 100644
--- a/app-misc/twin/twin-0.4.4.ebuild
+++ b/app-misc/twin/twin-0.4.4.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/twin/twin-0.4.4.ebuild,v 1.3 2002/10/05 05:39:09 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/twin/twin-0.4.4.ebuild,v 1.4 2002/11/30 21:33:14 vapier Exp $
-IUSE="X gtk ggi"
-
-S=${WORKDIR}/${P}
DESCRIPTION="A text-mode window environment"
SRC_URI="mirror://sourceforge/twin/${P}.tar.gz"
HOMEPAGE="http://twin.sourceforge.net/"
@@ -12,6 +9,7 @@ HOMEPAGE="http://twin.sourceforge.net/"
SLOT="0"
LICENSE="GPL-2 LGPL-2"
KEYWORDS="x86 ppc"
+IUSE="X gtk ggi"
DEPEND="X? ( virtual/x11 )
ggi? ( >=media-libs/libggi-1.9 )
@@ -43,37 +41,35 @@ src_compile() {
--enable-socket-alien=yes \
--enable-h2-tty-termcap=yes \
--enable-term=yes \
- ${myconf} || die
+ ${myconf}
make || die
}
src_install() {
-
- einstall || die
+ einstall
- use X && ( \
+ if [ `use X` ] ; then
insinto /usr/X11R6/lib/X11/fonts/misc
doins fonts/vga.pcf.gz
- )
+ fi
rm -rf ${D}/usr/share/twin/{BUGS,docs,COP*,READ*,Change*,INSTALL*}
dodoc BUGS COPYING* Change* README* TODO*
dodoc docs/*
-
}
pkg_postinst() {
- use X && ( \
+ if [ `use X` ] ; then
/usr/X11R6/bin/mkfontdir /usr/X11R6/lib/X11/fonts/misc
/usr/X11R6/bin/xset fp rehash
- )
+ fi
}
pkg_postrm() {
- use X && ( \
+ if [ `use X` ] ; then
/usr/X11R6/bin/mkfontdir /usr/X11R6/lib/X11/fonts/misc
/usr/X11R6/bin/xset fp rehash
- )
+ fi
}
diff --git a/app-misc/twin/twin-0.4.5.ebuild b/app-misc/twin/twin-0.4.5.ebuild
index e5129cc93eb2..a61f2ed67735 100644
--- a/app-misc/twin/twin-0.4.5.ebuild
+++ b/app-misc/twin/twin-0.4.5.ebuild
@@ -1,10 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/twin/twin-0.4.5.ebuild,v 1.1 2002/10/27 09:55:27 bcowan Exp $
-
-IUSE="X gtk ggi"
-
-S=${WORKDIR}/${P}
+# $Header: /var/cvsroot/gentoo-x86/app-misc/twin/twin-0.4.5.ebuild,v 1.2 2002/11/30 21:35:06 vapier Exp $
DESCRIPTION="A text-mode window environment"
SRC_URI="mirror://sourceforge/twin/${P}.tar.gz"
@@ -13,6 +9,7 @@ HOMEPAGE="http://twin.sourceforge.net/"
SLOT="0"
LICENSE="GPL-2 LGPL-2"
KEYWORDS="~x86"
+IUSE="X gtk ggi"
DEPEND="X? ( virtual/x11 )
ggi? ( >=media-libs/libggi-1.9 )
@@ -44,19 +41,18 @@ src_compile() {
--enable-socket-alien=yes \
--enable-h2-tty-termcap=yes \
--enable-term=yes \
- ${myconf} || die
+ ${myconf}
make || die
}
src_install() {
-
- einstall || die
+ einstall
- use X && ( \
+ if [ `use X` ] ; then
insinto /usr/X11R6/lib/X11/fonts/misc
doins fonts/vga.pcf.gz
- )
+ fi
rm -rf ${D}/usr/share/twin/{BUGS,docs,COP*,READ*,Change*,INSTALL*}
@@ -66,16 +62,16 @@ src_install() {
}
-pkg_postinst() {
- use X && ( \
+pkg_postinst() {
+ if [ `use X` ] ; then
/usr/X11R6/bin/mkfontdir /usr/X11R6/lib/X11/fonts/misc
/usr/X11R6/bin/xset fp rehash
- )
+ fi
}
pkg_postrm() {
- use X && ( \
+ if [ `use X` ] ; then
/usr/X11R6/bin/mkfontdir /usr/X11R6/lib/X11/fonts/misc
/usr/X11R6/bin/xset fp rehash
- )
+ fi
}