summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-10-24 19:34:34 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-10-24 19:34:34 +0000
commit5afd7671731a28778fa789d2f6b02efdf83102bd (patch)
tree5d1fc366800fe5df2eb7e8c3f29c37c48e90f0a1 /app-misc
parentinitial import (diff)
downloadhistorical-5afd7671731a28778fa789d2f6b02efdf83102bd.tar.gz
historical-5afd7671731a28778fa789d2f6b02efdf83102bd.tar.bz2
historical-5afd7671731a28778fa789d2f6b02efdf83102bd.zip
initial import
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/color/Manifest4
-rw-r--r--app-misc/color/color-1.1.ebuild46
-rw-r--r--app-misc/color/files/digest-color-1.11
-rw-r--r--app-misc/color/metadata.xml12
4 files changed, 62 insertions, 1 deletions
diff --git a/app-misc/color/Manifest b/app-misc/color/Manifest
index f153fc0d5b15..62fa1d47c5ec 100644
--- a/app-misc/color/Manifest
+++ b/app-misc/color/Manifest
@@ -1,2 +1,4 @@
-MD5 4bfd0bf27299a4d5295a89499299cad3 color-1.1.ebuild 727
+MD5 fef9c4307ed7dd98b493aa71c693ed14 color-1.1.ebuild 1055
+MD5 26c1e136636784297add5bb8b244fee1 ChangeLog 338
+MD5 67539e408e5395ff1d13bda5af94f891 metadata.xml 554
MD5 bf97f2627c156dd28559d652061edd1b files/digest-color-1.1 59
diff --git a/app-misc/color/color-1.1.ebuild b/app-misc/color/color-1.1.ebuild
new file mode 100644
index 000000000000..1f6da0520a55
--- /dev/null
+++ b/app-misc/color/color-1.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/color/color-1.1.ebuild,v 1.1 2003/10/24 19:34:27 taviso Exp $
+
+inherit ccc
+
+DESCRIPTION="Easily add ANSI colouring to shell scripts"
+HOMEPAGE="http://runslinux.net/projects.html#color"
+
+SRC_URI="http://runslinux.net/projects/color/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86 ~alpha"
+IUSE=""
+DEPEND="virtual/glibc"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+
+ # replace hardcoded compiler and CFLAGS.
+ replace-cc-hardcode
+ sed -i "s/-W -Wall -O2 -g/${CFLAGS}/g" ${S}/Makefile
+}
+
+src_compile() {
+ emake || die
+
+ # some feedback everything went ok.
+ echo; ls -l color; size color
+}
+
+src_install() {
+ dobin color
+ dodoc CHANGELOG COPYING README
+
+ # symlink for british users.
+ dosym /usr/bin/color /usr/bin/colour
+
+ einfo "For information on using color in your shell scripts,"
+ einfo "run \`color\` without any arguments."
+ einfo
+ einfo "More examples are available in ${DOCDIR}."
+}
diff --git a/app-misc/color/files/digest-color-1.1 b/app-misc/color/files/digest-color-1.1
new file mode 100644
index 000000000000..e4b339083586
--- /dev/null
+++ b/app-misc/color/files/digest-color-1.1
@@ -0,0 +1 @@
+MD5 9131623568926877389aa0f6b95d939d color-1.1.tar.gz 9468
diff --git a/app-misc/color/metadata.xml b/app-misc/color/metadata.xml
new file mode 100644
index 000000000000..024af98c0adf
--- /dev/null
+++ b/app-misc/color/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>taviso@gentoo.org</email>
+ <name>Tavis Ormandy</name>
+</maintainer>
+<longdescription>
+Color is a nifty little utility that you can call from shell scripts, that will let you easily use ANSI escape codes (for colors, bold, underline, etc) to your shell scripts without having to memorize escape sequences and type it every time you want a little red...
+</longdescription>
+</pkgmetadata>