summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-08-02 11:52:17 +0000
committerAlin Năstac <mrness@gentoo.org>2007-08-02 11:52:17 +0000
commitd2a091d893c14b7761fd16719bfda2617d4c1958 (patch)
treea8b07804e4f4f25c2e402d276fb1ef6d2a9361ed /app-mobilephone/gnokii/gnokii-0.6.12.ebuild
parentRemove obsolete versions. (diff)
downloadhistorical-d2a091d893c14b7761fd16719bfda2617d4c1958.tar.gz
historical-d2a091d893c14b7761fd16719bfda2617d4c1958.tar.bz2
historical-d2a091d893c14b7761fd16719bfda2617d4c1958.zip
Remove obsolete versions (#183440).
Package-Manager: portage-2.1.2.7
Diffstat (limited to 'app-mobilephone/gnokii/gnokii-0.6.12.ebuild')
-rw-r--r--app-mobilephone/gnokii/gnokii-0.6.12.ebuild97
1 files changed, 0 insertions, 97 deletions
diff --git a/app-mobilephone/gnokii/gnokii-0.6.12.ebuild b/app-mobilephone/gnokii/gnokii-0.6.12.ebuild
deleted file mode 100644
index 7376b422afe0..000000000000
--- a/app-mobilephone/gnokii/gnokii-0.6.12.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/gnokii/gnokii-0.6.12.ebuild,v 1.10 2007/07/02 17:32:00 armin76 Exp $
-
-inherit eutils flag-o-matic linux-info
-
-DESCRIPTION="user space driver and tools for use with mobile phones"
-HOMEPAGE="http://www.gnokii.org/"
-SRC_URI="http://www.gnokii.org/download/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ppc ppc64 sparc x86"
-IUSE="nls X bluetooth irda sms postgres mysql"
-
-RESTRICT="test" #test fails; maybe it will work in the future, but till then...
-
-RDEPEND="X? ( =x11-libs/gtk+-1.2* )
- bluetooth? ( net-wireless/bluez-libs )
- sms? ( >=dev-libs/glib-2
- postgres? ( dev-db/postgresql )
- mysql? ( virtual/mysql )
- )
- dev-libs/libical"
-DEPEND="${RDEPEND}
- irda? ( virtual/os-headers )
- nls? ( sys-devel/gettext )
- sys-devel/autoconf"
-
-CONFIG_CHECK="UNIX98_PTYS"
-
-src_compile() {
- append-ldflags $(bindnow-flags) #avoid QA notices
-
- autoconf && econf \
- $(use_enable nls) \
- $(use_with X x) \
- --disable-debug \
- --disable-xdebug \
- --disable-rlpdebug \
- --enable-security \
- --disable-unix98test \
- || die "configure failed"
-
- if use sms ; then
- cd "${S}/smsd"
-
- if use postgres; then
- emake libpq.la || die "smsd make failed"
- elif use mysql; then
- emake libmysql.la || die "smsd make failed"
- else
- emake libfile.la || die "smsd make failed"
- fi
-
- cd "${S}"
- fi
-
- emake -j1 || die "make failed"
-}
-
-src_install() {
- einstall || die "make install failed"
-
- insinto /etc
- doins Docs/sample/gnokiirc
- sed -i -e 's:/usr/local:/usr:' "${D}/etc/gnokiirc"
-
- doman Docs/man/*
- dodir "/usr/share/doc/${PF}"
- cp -r Docs/sample "${D}/usr/share/doc/${PF}/sample"
- cp -r Docs/protocol "${D}/usr/share/doc/${PF}/protocol"
- rm -rf Docs/man Docs/sample Docs/protocol
- dodoc Docs/*
-
- # only one file needs suid root to make a pseudo device
- fperms 4755 /usr/sbin/mgnokiidev
-
- if use sms; then
- cd "${S}/smsd"
-
- einstall || die "smsd make install failed"
-
- cd "${S}"
- fi
-
- if use X; then
- insinto /usr/share/applications
- doins xgnokii/xgnokii.desktop
- fi
-}
-
-pkg_postinst() {
- elog "gnokii does not need it's own group anymore."
- elog "Make sure the user that runs gnokii has read/write access to the device"
- elog "which your phone is connected to. eg. chown <user> /dev/ttyS0"
-}