summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Proschofsky <suka@gentoo.org>2004-08-25 15:00:35 +0000
committerAndreas Proschofsky <suka@gentoo.org>2004-08-25 15:00:35 +0000
commit7a7480feb810fdf99c31439722b4ac77e9269bd4 (patch)
tree1d40ff8fc05400e93ec29a9eb7aca5f279c048c1 /app-office/oooqs
parentNew version (diff)
downloadhistorical-7a7480feb810fdf99c31439722b4ac77e9269bd4.tar.gz
historical-7a7480feb810fdf99c31439722b4ac77e9269bd4.tar.bz2
historical-7a7480feb810fdf99c31439722b4ac77e9269bd4.zip
new version, also works for openoffice-ximian now
Diffstat (limited to 'app-office/oooqs')
-rw-r--r--app-office/oooqs/ChangeLog10
-rw-r--r--app-office/oooqs/Manifest5
-rw-r--r--app-office/oooqs/files/digest-oooqs-2.0.3-r11
-rw-r--r--app-office/oooqs/files/fixxooo.patch29
-rw-r--r--app-office/oooqs/oooqs-2.0.3-r1.ebuild32
5 files changed, 75 insertions, 2 deletions
diff --git a/app-office/oooqs/ChangeLog b/app-office/oooqs/ChangeLog
index 36140949e026..e822d283923c 100644
--- a/app-office/oooqs/ChangeLog
+++ b/app-office/oooqs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-office/oooqs
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/oooqs/ChangeLog,v 1.11 2004/08/25 11:14:15 suka Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/oooqs/ChangeLog,v 1.12 2004/08/25 15:00:35 suka Exp $
+
+*oooqs-2.0.3-r1 (25 Aug 2004)
+
+ 25 Aug 2004; suka@gentoo.org +files/fixxooo.patch, +oooqs-2.0.3-r1.ebuild:
+ New version: oooqs now also works with openoffice-ximian, thanks to jstubbs
+ for helping me out with the patch!
+
+ This also closes bug #54403
25 Aug 2004; suka@gentoo.org oooqs-2.0.3.ebuild:
marking 2.0.3 stable on x86, add metadata.xml
diff --git a/app-office/oooqs/Manifest b/app-office/oooqs/Manifest
index 84cea7b4dfd7..2bb9918a15f6 100644
--- a/app-office/oooqs/Manifest
+++ b/app-office/oooqs/Manifest
@@ -1,6 +1,9 @@
MD5 2c260e8bcc2b205ad3cdfe98b7bd2326 oooqs-2.0.2.ebuild 649
MD5 824a55711a4f20ecf8551de3ab719869 oooqs-2.0.3.ebuild 664
-MD5 9ba120e3b4c3f96d8d728470d7c9cb79 ChangeLog 1277
+MD5 2bf5b664699e3374f3396b4f02ac82e6 oooqs-2.0.3-r1.ebuild 965
+MD5 167405c3b09c907ee05aa16a728025ef ChangeLog 1534
MD5 d89f6d524fdd9cce162c5959fa9fed1b metadata.xml 269
MD5 0dfa431673ed5292d63d41d5ca44bebc files/digest-oooqs-2.0.2 63
MD5 b96223d4f6f3f644e5a345c12982ab72 files/digest-oooqs-2.0.3 63
+MD5 b96223d4f6f3f644e5a345c12982ab72 files/digest-oooqs-2.0.3-r1 63
+MD5 21f765f87dd345ef6ff0b2dfa632dd7a files/fixxooo.patch 890
diff --git a/app-office/oooqs/files/digest-oooqs-2.0.3-r1 b/app-office/oooqs/files/digest-oooqs-2.0.3-r1
new file mode 100644
index 000000000000..5d78f6742d54
--- /dev/null
+++ b/app-office/oooqs/files/digest-oooqs-2.0.3-r1
@@ -0,0 +1 @@
+MD5 5d401aa7250f80734d785d4c286f635b oooqs-2.0.3.tar.gz 584849
diff --git a/app-office/oooqs/files/fixxooo.patch b/app-office/oooqs/files/fixxooo.patch
new file mode 100644
index 000000000000..c3afe7a9d528
--- /dev/null
+++ b/app-office/oooqs/files/fixxooo.patch
@@ -0,0 +1,29 @@
+--- src/oooqs.cpp 2004-08-25 13:57:33.801575240 +0200
++++ src/oooqs.cpp 2004-08-25 13:57:33.802575088 +0200
+@@ -3,6 +3,7 @@
+ */
+
+ #include <qdir.h>
++#include <qfile.h>
+ #include <qmap.h>
+
+ #include <kaboutdata.h>
+@@ -92,9 +93,15 @@
+ Try to autodetect settings if they aren't found in our own config.
+ */
+ if ( _exec.length() < 2 ) {
+- oooConfig = new KSimpleConfig(
+- QDir::homeDirPath() + QDir::separator()
+- + ".sversionrc", true );
++ if ( QFile::exists( QDir::homeDirPath() + QDir::separator() + ".xversionrc" ) ) {
++ oooConfig = new KSimpleConfig(
++ QDir::homeDirPath() + QDir::separator()
++ + ".xversionrc", true );
++ } else {
++ oooConfig = new KSimpleConfig(
++ QDir::homeDirPath() + QDir::separator()
++ + ".sversionrc", true );
++}
+ oooConfig->setGroup( "Versions" );
+ versions = oooConfig->entryMap( "Versions" );
+ /**
diff --git a/app-office/oooqs/oooqs-2.0.3-r1.ebuild b/app-office/oooqs/oooqs-2.0.3-r1.ebuild
new file mode 100644
index 000000000000..10e3c6dabc33
--- /dev/null
+++ b/app-office/oooqs/oooqs-2.0.3-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/oooqs/oooqs-2.0.3-r1.ebuild,v 1.1 2004/08/25 15:00:35 suka Exp $
+
+inherit kde eutils
+
+need-kde 3
+
+DESCRIPTION="OpenOffice.org Quickstarter, runs in the KDE SystemTray"
+HOMEPAGE="http://segfaultskde.berlios.de/index.php"
+SRC_URI="http://download.berlios.de/segfaultskde/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/fixxooo.patch
+}
+
+pkg_postinst()
+{
+ einfo "If upgrading from version 2.0, please remove the oooqs.desktop file from"
+ einfo "your "Autostart" directory (linked in the "Goto" menu in Konqueror)."
+ einfo
+ einfo "If you want to use this for openoffice-ximian and already had it installed"
+ einfo "for vanilla openoffice.org before, make sure to delete the old config file in"
+ einfo "~/.kde/share/config/oooqsrc"
+
+}