summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-06-26 23:01:57 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-06-26 23:01:57 +0000
commita454d69452cfa27a55da1be5875b84abf2e492fa (patch)
treeb48891c5aedc9ca2bdaf90c136ebc23888a124cd /app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild
parentRevision bump, includes yahoo authentication patch from bitlbee.org. (diff)
downloadhistorical-a454d69452cfa27a55da1be5875b84abf2e492fa.tar.gz
historical-a454d69452cfa27a55da1be5875b84abf2e492fa.tar.bz2
historical-a454d69452cfa27a55da1be5875b84abf2e492fa.zip
added patch to prevent segv on missing /proc/bus/usb/devices (#42378)
Diffstat (limited to 'app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild')
-rw-r--r--app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild b/app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild
index 782c42f6fe85..2e2963999dbc 100644
--- a/app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild
+++ b/app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild,v 1.7 2004/06/24 21:42:11 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/gnome-pilot/gnome-pilot-2.0.10-r1.ebuild,v 1.8 2004/06/26 23:01:57 liquidx Exp $
inherit gnome2 eutils
@@ -39,4 +39,7 @@ src_unpack() {
# add treo600 support
# http://bugzilla.gnome.org/show_bug.cgi?id=124254
epatch ${FILESDIR}/${P}-treo600.patch
+ # prevent segv if /proc/bus/usb/devices is missing
+ # http://mail.gnome.org/archives/gnome-pilot-list/2004-February/msg00013.html
+ cd ${S}; epatch ${FILESDIR}/${P}-missing_proc.patch
}