summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-02-22 01:23:26 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-02-22 01:23:26 +0000
commitb10ddb6c7118342cdc60c31d04b6c221c3184fdd (patch)
tree3d3ecf055f98cc4593c766918c15fad982962b5d /app-pda/gnome-pilot/gnome-pilot-2.0.15.ebuild
parentRedigest for Manifest2 (diff)
downloadhistorical-b10ddb6c7118342cdc60c31d04b6c221c3184fdd.tar.gz
historical-b10ddb6c7118342cdc60c31d04b6c221c3184fdd.tar.bz2
historical-b10ddb6c7118342cdc60c31d04b6c221c3184fdd.zip
Bump to 2.0.15
This is primarily a bugfix release, to patch issues that cropped up with the new features introduced in version 2.0.14. - #357602. Fix memory leak in the usbfs scanning code (with thanks to Brian Warner) - #362565. Add a 400ms pause between HAL detection of a USB device and the first attempt to sync. Several devices were reported to reset themselves if communication was attempted too soon after the first appearance of the USB device. - #365181. Fix a long-standing bug that probably turned up now because of the multiple attempts to add a new pilot due to #362565. Avoid accessing freed memory when the 'add pilot' dialog is opened multiple times. Other changes: - Maintainership has passed from JP Rosevear to Matt Davey. Many thanks to JP for stepping in when gnome-pilot could otherwise have died a nasty death by abandonment. - #364589. With thanks to Glynn Foster. Tweaks to window placement to support multihead displays. Also, added missing description to .server file for panel applet. - Fix another long-standing bug, that could cause garbage to be shown when a configured conduit was unavailable (e.g. if the .conduit files were in the wrong place after an upgrade). - Fix distcheck target Package-Manager: portage-2.1.2-r10
Diffstat (limited to 'app-pda/gnome-pilot/gnome-pilot-2.0.15.ebuild')
-rw-r--r--app-pda/gnome-pilot/gnome-pilot-2.0.15.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-pda/gnome-pilot/gnome-pilot-2.0.15.ebuild b/app-pda/gnome-pilot/gnome-pilot-2.0.15.ebuild
new file mode 100644
index 000000000000..e5396dac47a2
--- /dev/null
+++ b/app-pda/gnome-pilot/gnome-pilot-2.0.15.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/gnome-pilot/gnome-pilot-2.0.15.ebuild,v 1.1 2007/02/22 01:23:26 dang Exp $
+
+inherit gnome2 eutils autotools
+
+DESCRIPTION="Gnome Palm Pilot and Palm OS Device Syncing Library"
+HOMEPAGE="http://live.gnome.org/GnomePilot"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="hal"
+
+RDEPEND=">=gnome-base/libgnome-2.0.0
+ >=gnome-base/libgnomeui-2.0.0
+ >=gnome-base/libglade-2.0.0
+ >=gnome-base/orbit-2.6.0
+ >=gnome-base/libbonobo-2.0.0
+ >=gnome-base/gnome-panel-2.0
+ >=gnome-base/gconf-2.0
+ >=dev-util/gob-2.0.5
+ dev-libs/libxml2
+ >=app-pda/pilot-link-0.11.7
+ hal? (
+ dev-libs/dbus-glib
+ >=sys-apps/hal-0.5.4
+ )"
+
+DEPEND="sys-devel/gettext
+ >=dev-lang/perl-5.6.0
+ ${RDEPEND}"
+
+DOCS="AUTHORS COPYING* ChangeLog README NEWS"
+SCROLLKEEPER_UPDATE="0"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --enable-usb --enable-network --enable-pilotlinktest \
+ $(use_with hal)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+
+ eautoreconf
+}