summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Diener <sediener@gentoo.org>2003-10-25 02:19:58 +0000
committerStephen Diener <sediener@gentoo.org>2003-10-25 02:19:58 +0000
commit70cef6f6adab5a8f429a0bdc92ccb5eb5bbe1453 (patch)
tree5b56f32b92a5b0a2cd02cc5eaa028741be45bfcb /app-sci/bioperl
parentnew ebuild and associated files for 1.2.3 (diff)
downloadhistorical-70cef6f6adab5a8f429a0bdc92ccb5eb5bbe1453.tar.gz
historical-70cef6f6adab5a8f429a0bdc92ccb5eb5bbe1453.tar.bz2
historical-70cef6f6adab5a8f429a0bdc92ccb5eb5bbe1453.zip
new ebuild and associated files for 1.2.3
Diffstat (limited to 'app-sci/bioperl')
-rw-r--r--app-sci/bioperl/Manifest5
-rw-r--r--app-sci/bioperl/bioperl-1.2.3.ebuild76
-rw-r--r--app-sci/bioperl/files/biodbgff-enable-1.2.3.patch98
-rw-r--r--app-sci/bioperl/files/digest-bioperl-1.2.31
4 files changed, 177 insertions, 3 deletions
diff --git a/app-sci/bioperl/Manifest b/app-sci/bioperl/Manifest
index 67e6a66e70eb..4ce856a295fe 100644
--- a/app-sci/bioperl/Manifest
+++ b/app-sci/bioperl/Manifest
@@ -1,10 +1,9 @@
-MD5 d6c0f860388ca0e549be025fae20e759 ChangeLog 1109
+MD5 695c557a2d99a16f01020e407d49ee67 ChangeLog 1109
MD5 20616984167d7ac1a9db33713d70e93f bioperl-1.0.2.ebuild 1496
MD5 ce01843f37edf576d07e2423ee6d486e bioperl-1.2.ebuild 1524
MD5 683bbc29b2f9f4f309efbecfea7184a1 bioperl-1.2.2.ebuild 2198
MD5 e8b4df3df76800c376905734d8043cfa metadata.xml 216
-MD5 f568ff8b7d8eb751c6ba2087cfdd4b1e bioperl-1.2.3.ebuild 2082
-MD5 97abac8473042e6aaaad6ac8a9f66fb8 .bioperl-1.2.3.ebuild.swp 12288
+MD5 07780e6c7f94982c8a22e55fea7383fb bioperl-1.2.3.ebuild 2082
MD5 1828ff2ba6225e17a98d27bfbad5c7c9 files/bioperl-1.2-manpage.diff 712
MD5 dfdb9921cbef92f60e9746a9531d8de7 files/digest-bioperl-1.0.2 66
MD5 14b9e16331895fe40e231065f7dda942 files/digest-bioperl-1.2 64
diff --git a/app-sci/bioperl/bioperl-1.2.3.ebuild b/app-sci/bioperl/bioperl-1.2.3.ebuild
new file mode 100644
index 000000000000..27ffc8201d59
--- /dev/null
+++ b/app-sci/bioperl/bioperl-1.2.3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/bioperl/bioperl-1.2.3.ebuild,v 1.1 2003/10/25 02:19:54 sediener Exp $
+
+inherit perl-module eutils
+CATEGORY="app-sci"
+
+DESCRIPTION="collection of tools for bioinformatics, genomics and life science research"
+HOMEPAGE="http://www.bioperl.org/"
+#SRC_URI="http://www.cpan.org/modules/by-module/Bio/${P}.tar.gz"
+SRC_URI="http://www.bioperl.org/ftp/DIST/${P}.tar.bz2"
+
+LICENSE="Artistic GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="mysql gd"
+
+DEPEND="${DEPEND}
+ dev-perl/File-Temp
+ dev-perl/HTML-Parser
+ dev-perl/IO-String
+ dev-perl/IO-stringy
+ dev-perl/SOAP-Lite
+ dev-perl/Storable
+ dev-perl/XML-DOM
+ dev-perl/XML-Parser
+ dev-perl/XML-Writer
+ dev-perl/XML-Twig
+ dev-perl/libxml-perl
+ dev-perl/libwww-perl
+ dev-perl/Graph
+ dev-perl/Text-Shellwords
+ gd? ( >=dev-perl/GD-1.32-r1 )
+ mysql? ( >=dev-perl/DBD-mysql-2.1004-r3 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # remove interactiveness
+ [ -n "`use mysql`" ] && epatch ${FILESDIR}/biodbgff-enable-${PV}.patch
+ # want man pages in addition to perldoc documentation??
+ #epatch ${FILESDIR}/domanpages-${PV}.patch
+}
+
+src_compile() {
+ # there's a test to run for BioGFFDB if using mysql
+ perl-module_src_compile || die "compile failed"
+ # make test
+## perl-module_src_test || die "src test failed"
+}
+
+src_install() {
+ mydoc="AUTHORS BUGS FAQ"
+ perl-module_src_install
+
+ # bioperl scripts and examples
+ einfo 'Adding bioperl examples and scripts to /usr/share/...'
+ dodir /usr/share/${PF}/scripts
+ cd ${S}/scripts/
+ tar cf - ./ | ( cd ${D}/usr/share/${PF}/scripts; tar xf -)
+ dodir /usr/share/${PF}/examples
+ cd ${S}/examples/
+ tar cf - ./ | ( cd ${D}/usr/share/${PF}/examples; tar xf -)
+ dodir /usr/share/doc/${P}
+ cd ${S}
+ tar cf - ./ | ( cd ${D}/usr/share/doc/${P}; tar xf -)
+
+ # some pods in maindir
+ eval `perl '-V:installvendorlib'`
+ MY_SITE_LIB=${installvendorlib}/Bio
+ insinto ${MY_SITE_LIB}
+ doins biodatabases.pod biodesign.pod bioperl.pod bioscripts.pod
+
+ dobin bptutorial.pl
+
+}
diff --git a/app-sci/bioperl/files/biodbgff-enable-1.2.3.patch b/app-sci/bioperl/files/biodbgff-enable-1.2.3.patch
new file mode 100644
index 000000000000..7bd66206a0b4
--- /dev/null
+++ b/app-sci/bioperl/files/biodbgff-enable-1.2.3.patch
@@ -0,0 +1,98 @@
+--- Makefile.PL.orig 2003-07-14 16:09:49.000000000 +0100
++++ Makefile.PL 2003-07-14 16:15:56.000000000 +0100
+@@ -83,9 +83,6 @@
+ # Prompt user for BioDBGFF stuff
+ #
+
+-if( eval { require DBI } && grep {/mysql/} DBI->available_drivers) {
+- my $proceed = prompt("Do you want to run the BioDBGFF tests (requires a mysql database) y/n",'n');
+- if( $proceed =~ /^[yY]/) {
+ my $cfg = {dbd_driver => 'mysql'};
+ GFFQueryDb($cfg,{'prompt'=>1,'verbose'=>1});
+ if (open T,">t/do_biodbgff.tests") {
+@@ -94,13 +91,6 @@
+ }
+ close T;
+ }
+- } else {
+- if( -e "t/do_biodbgff.tests" ) {
+- unlink "t/do_biodbgff.tests";
+- }
+- }
+-}
+-
+
+ ############################################################################
+ #
+@@ -124,55 +114,27 @@
+ my $d = lc $driver;
+ my $prompt = $options->{'prompt'};
+
+- my $test_db = exists($options->{"$d-test-db"}) ?
+- $options->{"$d-test-db"} : ($cfg->{'test_db'} || 'test');
+- $test_db = prompt
+- ("Which database should I use for testing the $db drivers?",
+- $test_db) if $prompt;
+-
+- my $test_host = exists($options->{"$d-test-host"}) ?
+- $options->{"$d-test-host"} : ($cfg->{'test_host'} || 'localhost');
+- $test_host = prompt
+- ("On which host is database $test_db running (hostname, ip address or host:port)", $test_host) if $prompt;
+-
+- my($test_user, $test_pass);
+-
+- $test_user = exists($options->{"$d-test-user"}) ?
+- $options->{"$d-test-user"} : ($cfg->{'test_user'} || "undef");
+- $test_user = prompt
+- ("User name for connecting to database $test_db?", $test_user)
+- if $prompt;
+- $test_user = undef if $test_user eq 'undef';
+-
+- $test_pass = exists($options->{"$d-test-pass"}) ?
+- $options->{"$d-test-pass"} : ($cfg->{'test_pass'} || "undef");
+- $test_pass = prompt
+- ("Password for connecting to database $test_db?", $test_pass)
+- if $prompt;
+- $test_pass = undef if $test_pass eq 'undef';
+-
+- $cfg->{'test_db'} = $test_db;
+- $cfg->{'test_host'} = $test_host;
+- $cfg->{'test_user'} = $test_user;
+- $cfg->{'test_pass'} = $test_pass;
+- if ($test_host eq 'undef' || $test_host eq 'localhost') {
+- $test_host = '';
+- }
+- my $test_dsn = "DBI:$driver:database=$test_db";
+- $cfg->{test_dsn} = $test_dsn;
+- if ($test_host) {
+- $cfg->{'test_dsn'} .= ";host=$test_host";
+- }
++ $options->{"$d-test-db"} = 'test';
++ $options->{"$d-test-host"} = 'localhost';
++ $options->{"$d-test-user"} = n0b0dy;
++ $options->{"$d-test-pass"} = undef;
++
++ $cfg->{'test_db'} = $options->{"$d-test-db"};
++ $cfg->{'test_host'} = $options->{"$d-test-host"};
++ $cfg->{'test_user'} = $options->{"$d-test-user"};
++ $cfg->{'test_pass'} = $options->{"$d-test-pass"};
+
++ my $test_dsn = "DBI:$driver:database=" . $cfg->{test_db};
++ $cfg->{'test_dsn'} = $test_dsn;
+
+ if ($options->{'verbose'}) {
+ local $^W=0; # some uninitialized variable warning coming through
+ print("Driver $driver is using the following settings for tests:\n",
+- " Database $test_db\n",
+- " Host $test_host\n",
+- " DSN $test_dsn\n",
+- " User $test_user\n",
+- " Password $test_pass\n");
++ " Database ".$cfg->{test_db}. "\n",
++ " Host ".$cfg->{test_host}."\n",
++ " DSN ".$cfg->{test_dsn}. "\n",
++ " User ".$cfg->{test_user}."\n",
++ " Password ".$cfg->{test_pass}."\n");
+ }
+ }
+
diff --git a/app-sci/bioperl/files/digest-bioperl-1.2.3 b/app-sci/bioperl/files/digest-bioperl-1.2.3
new file mode 100644
index 000000000000..05b4fc161597
--- /dev/null
+++ b/app-sci/bioperl/files/digest-bioperl-1.2.3
@@ -0,0 +1 @@
+MD5 c64219b6540a722e781a53aea215ebc8 bioperl-1.2.3.tar.bz2 3086024