summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2004-10-07 22:25:45 +0000
committerGeorge Shapovalov <george@gentoo.org>2004-10-07 22:25:45 +0000
commitacb46fd7c8e775a40a4dd40582186b04523224da (patch)
treee36b28cf038d68b3bf2940e92bc5c25e69fe37ed /app-sci/biopython
parentadded a patch to fix insecure tempfile handling, closes bug 66358 (diff)
downloadhistorical-acb46fd7c8e775a40a4dd40582186b04523224da.tar.gz
historical-acb46fd7c8e775a40a4dd40582186b04523224da.tar.bz2
historical-acb46fd7c8e775a40a4dd40582186b04523224da.zip
new version
Diffstat (limited to 'app-sci/biopython')
-rw-r--r--app-sci/biopython/ChangeLog8
-rw-r--r--app-sci/biopython/Manifest18
-rw-r--r--app-sci/biopython/biopython-1.30.ebuild32
-rw-r--r--app-sci/biopython/files/digest-biopython-1.301
4 files changed, 45 insertions, 14 deletions
diff --git a/app-sci/biopython/ChangeLog b/app-sci/biopython/ChangeLog
index de1ebf51898a..523b295a8c9f 100644
--- a/app-sci/biopython/ChangeLog
+++ b/app-sci/biopython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-sci/biopython
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/biopython/ChangeLog,v 1.11 2004/10/02 15:15:18 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/biopython/ChangeLog,v 1.12 2004/10/07 22:25:45 george Exp $
+
+*biopython-1.30 (07 Oct 2004)
+
+ 07 Oct 2004; George Shapovalvo <george@gentoo.org> biopython-1.30.ebuild :
+ new version (#51833)
+ amd64 has problems with KDTree, will try to look into this more later
05 May 2004; Bryan Østergaard <kloeri@gentoo.org> biopython-1.24.ebuild:
Stable on alpha.
diff --git a/app-sci/biopython/Manifest b/app-sci/biopython/Manifest
index 77349995077d..6919602ec7d4 100644
--- a/app-sci/biopython/Manifest
+++ b/app-sci/biopython/Manifest
@@ -1,20 +1,12 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 a6c82b23ad9c2ab494d24e8dd2427520 ChangeLog 1612
-MD5 821788707f864dffce2a6cbd086ec19a biopython-1.10.ebuild 808
-MD5 64f5e7ece791b5004bf111d8ea6b1e66 biopython-1.21.ebuild 900
MD5 ebd9935ad492f703e31fccbc90cc7133 biopython-1.23.ebuild 795
MD5 74e8621e64f4bcb2915ebbdd58398bbe biopython-1.24.ebuild 794
+MD5 821788707f864dffce2a6cbd086ec19a biopython-1.10.ebuild 808
+MD5 96248c038a70552987a4ab40f4e4a43c ChangeLog 1814
+MD5 4eac662e68aa34df443d7e4742d32dc8 biopython-1.30.ebuild 794
MD5 e52ec7d225835cda2c95c5317cdccfb4 metadata.xml 217
+MD5 64f5e7ece791b5004bf111d8ea6b1e66 biopython-1.21.ebuild 900
MD5 8e719491da5d9664fddedbffc6af8f06 files/digest-biopython-1.10 67
MD5 c54d7ea5347210ae92b5e01a346e2a21 files/digest-biopython-1.21 67
MD5 3a482a8872b4342414ac1d59b7fee4ed files/digest-biopython-1.23 67
MD5 aab085d47ad39d35d85a70db1e1aa89b files/digest-biopython-1.24 67
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.10 (GNU/Linux)
-
-iD8DBQFBXsYMI1lqEGTUzyQRAp5fAJ455D8f8L9o+dMC4Sqh1qYJQDvtOACfejCI
-D3xaavoTs3SNMG3CsNp7AKA=
-=bMTk
------END PGP SIGNATURE-----
+MD5 a8b300aed93e9dbec0b14e657121d00e files/digest-biopython-1.30 67
diff --git a/app-sci/biopython/biopython-1.30.ebuild b/app-sci/biopython/biopython-1.30.ebuild
new file mode 100644
index 000000000000..66b71ac87671
--- /dev/null
+++ b/app-sci/biopython/biopython-1.30.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/biopython/biopython-1.30.ebuild,v 1.1 2004/10/07 22:25:45 george Exp $
+
+inherit distutils
+
+IUSE=""
+
+DESCRIPTION="Biopython - python modules for computational molecular biology"
+SRC_URI="http://www.biopython.org/files/${P}.tar.gz"
+HOMEPAGE="http://www.biopython.org"
+
+DEPEND=">=dev-lang/python-2.2
+ >=dev-python/egenix-mx-base-2.0.3
+ >=dev-python/numeric-19.0
+ >=dev-python/reportlab-1.11"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ DOCS="Doc/* Doc/install/*.txt"
+ distutils_src_install
+
+ dohtml Doc/install/*.html
+ cp -r Doc/examples/ ${D}/usr/share/doc/${PF}/
+}
diff --git a/app-sci/biopython/files/digest-biopython-1.30 b/app-sci/biopython/files/digest-biopython-1.30
new file mode 100644
index 000000000000..53251dcebf82
--- /dev/null
+++ b/app-sci/biopython/files/digest-biopython-1.30
@@ -0,0 +1 @@
+MD5 d8df866a40be20962b8ef52baa5376c1 biopython-1.30.tar.gz 3186467