summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-10-03 17:32:46 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-10-03 17:32:46 +0000
commit46b45ba8a5c9dc00c8f54b66941d825740b1471a (patch)
treecd59f4b35b7b71e0e2a92785ec51f073b0701f34 /app-sci/vbs
parentRemove old versions (diff)
downloadhistorical-46b45ba8a5c9dc00c8f54b66941d825740b1471a.tar.gz
historical-46b45ba8a5c9dc00c8f54b66941d825740b1471a.tar.bz2
historical-46b45ba8a5c9dc00c8f54b66941d825740b1471a.zip
Patching VBS for gcc-3.4; bug #65613.
Diffstat (limited to 'app-sci/vbs')
-rw-r--r--app-sci/vbs/ChangeLog6
-rw-r--r--app-sci/vbs/Manifest5
-rw-r--r--app-sci/vbs/files/vbs-gcc-3.4.patch44
-rw-r--r--app-sci/vbs/vbs-1.4.0.ebuild15
4 files changed, 62 insertions, 8 deletions
diff --git a/app-sci/vbs/ChangeLog b/app-sci/vbs/ChangeLog
index db2c487e1c58..4e17fb5ce5f5 100644
--- a/app-sci/vbs/ChangeLog
+++ b/app-sci/vbs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-sci/vbs
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/vbs/ChangeLog,v 1.4 2004/06/24 22:20:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/vbs/ChangeLog,v 1.5 2004/10/03 17:32:46 plasmaroo Exp $
+
+ 03 Oct 2004; <plasmaroo@gentoo.org> vbs-1.4.0.ebuild,
+ +files/vbs-gcc-3.4.patch:
+ Patching VBS for gcc-3.4; bug #65613.
05 Jun 2004; David Holm <dholm@gentoo.org> vbs-1.4.0.ebuild:
Added to ~ppc.
diff --git a/app-sci/vbs/Manifest b/app-sci/vbs/Manifest
index d32c5a29a70c..ce814f0ba270 100644
--- a/app-sci/vbs/Manifest
+++ b/app-sci/vbs/Manifest
@@ -1,4 +1,5 @@
-MD5 ccfdf737c00e9ad8ff1b6220607dae80 ChangeLog 467
-MD5 f6fc0be353fea4ff210ae7ac4218dac5 vbs-1.4.0.ebuild 763
+MD5 aeae87ff0bc19aec76cc86824de06b0b ChangeLog 593
+MD5 dfc3be85f642ba592f2c4f5b05a5d998 vbs-1.4.0.ebuild 858
MD5 e49bb02132d2cd74ad4e6ee291e102d9 metadata.xml 220
+MD5 0afd4a3b8f7839b7a339d2a1f1353bc4 files/vbs-gcc-3.4.patch 1658
MD5 22a114171374699f394635225aecca7e files/digest-vbs-1.4.0 61
diff --git a/app-sci/vbs/files/vbs-gcc-3.4.patch b/app-sci/vbs/files/vbs-gcc-3.4.patch
new file mode 100644
index 000000000000..9ee5b1af06fd
--- /dev/null
+++ b/app-sci/vbs/files/vbs-gcc-3.4.patch
@@ -0,0 +1,44 @@
+--- src/common/bvector.h 2003-01-12 04:40:59.000000000 +0000
++++ src/common/bvector.h 2004-10-03 18:19:38.364060736 +0100
+@@ -88,10 +88,6 @@
+ position_type _begin; // Starting position.
+ position_type _end; // Stopping position.
+ size_type _size; // Size of this sub-bit vector.
+-
+- // Only bit_vector can create a sub_bit_vector object.
+- sub_bit_vector(bit_vector &, const position_type, const position_type);
+- sub_bit_vector(const sub_bit_vector &);
+ public:
+ sub_bit_vector &operator=(const sub_bit_vector &);
+ sub_bit_vector &operator=(const const_sub_bit_vector &);
+@@ -100,6 +96,10 @@
+ { return _size; }
+ ostream_type &info(ostream_type &) const;
+
++ // Only bit_vector can create a sub_bit_vector object.
++ sub_bit_vector(bit_vector &, const position_type, const position_type);
++ sub_bit_vector(const sub_bit_vector &);
++
+ // We don't need any other method, yet!
+ };
+ class const_sub_bit_vector
+@@ -113,15 +113,15 @@
+ position_type _begin; // Starting position.
+ position_type _end; // Stopping position.
+ size_type _size; // Size of this sub-bit vector.
+-
+- // Only bit_vector can create a sub_bit_vector object.
+- const_sub_bit_vector(const bit_vector &, const position_type, const position_type);
+- const_sub_bit_vector(const const_sub_bit_vector &);
+ public:
+ size_type size() const
+ { return _size; }
+ ostream_type &info(ostream_type &) const;
+
++ // Only bit_vector can create a sub_bit_vector object.
++ const_sub_bit_vector(const bit_vector &, const position_type, const position_type);
++ const_sub_bit_vector(const const_sub_bit_vector &);
++
+ // We don't need any other method, yet!
+ };
+
diff --git a/app-sci/vbs/vbs-1.4.0.ebuild b/app-sci/vbs/vbs-1.4.0.ebuild
index cea0c6072d34..e6cbc99f1bc1 100644
--- a/app-sci/vbs/vbs-1.4.0.ebuild
+++ b/app-sci/vbs/vbs-1.4.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation and Tim Yamin <plasmaroo@gentoo.org> <plasmaroo@squirrelsoft.org.uk>
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/vbs/vbs-1.4.0.ebuild,v 1.4 2004/06/24 22:20:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/vbs/vbs-1.4.0.ebuild,v 1.5 2004/10/03 17:32:46 plasmaroo Exp $
+
+inherit eutils
HOMEPAGE="http://www.geda.seul.org/tools/vbs/index.html"
DESCRIPTION="vbs - the Verilog Behavioral Simulator"
@@ -14,16 +16,20 @@ KEYWORDS="~x86 ~ppc"
DEPEND=">=sys-devel/flex-2.3
>=sys-devel/bison-1.22"
-src_compile () {
+src_unpack () {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-gcc-3.4.patch
+}
+src_compile () {
cd src
econf || die
emake vbs || die
-
}
src_install () {
-
dodoc BUGS CONTRIBUTORS COPYRIGHT FAQ README vbs.txt
docinto examples
@@ -31,5 +37,4 @@ src_install () {
exeinto /usr/bin
doexe src/vbs
-
}