summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2004-04-10 21:22:03 +0000
committerTavis Ormandy <taviso@gentoo.org>2004-04-10 21:22:03 +0000
commit58dbf25a32a5fc75beeb3ade66bfa19207f2aafe (patch)
treebf6904489a38dbf53cd810947e25b42459602807 /app-shells
parentFixed sparc64 virtuals with multiple entries as per bug #47391. (diff)
downloadhistorical-58dbf25a32a5fc75beeb3ade66bfa19207f2aafe.tar.gz
historical-58dbf25a32a5fc75beeb3ade66bfa19207f2aafe.tar.bz2
historical-58dbf25a32a5fc75beeb3ade66bfa19207f2aafe.zip
new release
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/ksh/ChangeLog9
-rw-r--r--app-shells/ksh/Manifest6
-rw-r--r--app-shells/ksh/files/digest-ksh-93.200402293
-rw-r--r--app-shells/ksh/ksh-93.20040229.ebuild81
4 files changed, 95 insertions, 4 deletions
diff --git a/app-shells/ksh/ChangeLog b/app-shells/ksh/ChangeLog
index cf6deb256132..98491fcae099 100644
--- a/app-shells/ksh/ChangeLog
+++ b/app-shells/ksh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/ksh
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ChangeLog,v 1.9 2003/12/06 15:26:10 weeve Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ChangeLog,v 1.10 2004/04/10 21:22:03 taviso Exp $
+
+*ksh-93.20040229 (10 Apr 2004)
+
+ 10 Apr 2004; Tavis Ormandy <taviso@gentoo.org> ksh-93.20040229.ebuild:
+ new release
06 Dec 2003; Jason Wever <weeve@gentoo.org> ksh-93.20030724.ebuild:
Marked stable on sparc, closes #25668
diff --git a/app-shells/ksh/Manifest b/app-shells/ksh/Manifest
index 28029db0036b..3bace9a78eba 100644
--- a/app-shells/ksh/Manifest
+++ b/app-shells/ksh/Manifest
@@ -1,5 +1,7 @@
-MD5 48f6ddcaa54489e9f47b5161e39d928c ChangeLog 1340
+MD5 0ba2a00748abc0d4d6c41d6ae78bd314 ksh-93.20040229.ebuild 2307
MD5 8bc77bfcbeb6b48d224c325da0b6dceb ksh-93.20030724.ebuild 2373
+MD5 b59f449e6f2d28fe0cbdc7fb7daca552 ChangeLog 1462
MD5 e283b9362f2885bedf238e7c08f51e26 metadata.xml 1272
-MD5 75a91bdad38d09a163894fd8ebc8adff files/digest-ksh-93.20030724 206
MD5 fc05a830ab720e8d3462bb10f0474258 files/ksh-93.20030724-libs.diff 12867
+MD5 75a91bdad38d09a163894fd8ebc8adff files/digest-ksh-93.20030724 206
+MD5 9d9dc80da41b462852a6632153563619 files/digest-ksh-93.20040229 206
diff --git a/app-shells/ksh/files/digest-ksh-93.20040229 b/app-shells/ksh/files/digest-ksh-93.20040229
new file mode 100644
index 000000000000..33fab941af49
--- /dev/null
+++ b/app-shells/ksh/files/digest-ksh-93.20040229
@@ -0,0 +1,3 @@
+MD5 cd4cc8fe24b040685451bea07f9bd163 INIT.2004-02-29.tgz 268141
+MD5 fa91217bc99ccf9cc32b3250a2431185 ast-ksh.2004-02-29.tgz 2501552
+MD5 a8288401b0a6984cac48864fc9a835b5 ast-ksh-locale.2003-04-22.tgz 516623
diff --git a/app-shells/ksh/ksh-93.20040229.ebuild b/app-shells/ksh/ksh-93.20040229.ebuild
new file mode 100644
index 000000000000..07d38e1255dc
--- /dev/null
+++ b/app-shells/ksh/ksh-93.20040229.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ksh/ksh-93.20040229.ebuild,v 1.1 2004/04/10 21:22:03 taviso Exp $
+
+inherit ccc eutils
+
+RELEASE="2004-02-29"
+DESCRIPTION="The Original Korn Shell, 1993 revision (ksh93)"
+HOMEPAGE="http://www.kornshell.com/"
+SRC_URI="http://www.research.att.com/~gsf/download/tgz/INIT.${RELEASE}.tgz
+ http://www.research.att.com/~gsf/download/tgz/ast-ksh.${RELEASE}.tgz
+ nls? ( http://www.research.att.com/~gsf/download/tgz/ast-ksh-locale.2003-04-22.tgz )"
+
+LICENSE="ATT"
+SLOT="0"
+KEYWORDS="~x86 ~alpha ~sparc"
+IUSE="static nls"
+
+DEPEND="virtual/glibc !app-shells/pdksh"
+
+S=${WORKDIR}
+
+src_unpack() {
+ # the AT&T build tools look in here for packages.
+ mkdir -p ${S}/lib/package/tgz
+
+ # move the packages into place.
+ cp ${DISTDIR}/ast-ksh.${RELEASE}.tgz ${S}/lib/package/tgz/ || die
+
+ if use nls; then
+ cp ${DISTDIR}/ast-ksh-locale.2003-04-22.tgz ${S}/lib/package/tgz/ || die
+ fi
+
+ # INIT provides the basic tools to start building.
+ unpack INIT.${RELEASE}.tgz
+
+ # `package read` will unpack any tarballs put in place.
+ ${S}/bin/package read || die
+}
+
+src_compile() {
+ # users who prefer ksh as there regular shell
+ # may want to make it static, so it can be used
+ # in the event of fs failure, for example
+ # where shared libraries are not available
+ use static && append-ldflags -static
+
+ # set the optimisations for the build process
+ export CCFLAGS="${CFLAGS}"
+ cd ${S}; ./bin/package only make ast-ksh CC=${CC:-gcc} || die
+
+ # install the optional locale data.
+ # heh, check out locale fudd, or piglatin :)
+ #
+ # "Too many symbowic winks in paf name twavewsal"
+
+ # david korn is a funny guy! :)
+ if use nls; then
+ cd ${S}; ./bin/package only make ast-ksh-locale CC=${CC:-gcc}
+ fi
+}
+
+src_install() {
+ # check where the build scripts put them
+ local my_arch="${S}/arch/$(${S}/bin/package)"
+
+ exeinto /bin
+ doexe ${my_arch}/bin/ok/ksh
+
+ # FIXME: talk to pdksh maintainer about making this nicer,
+ # how can we co-exist nicely without blocking?
+ dosym /bin/ksh /bin/ksh93
+
+ newman ${my_arch}/man/man1/sh.1 ksh.1
+ dodoc lib/package/LICENSES/ast lib/package/gen/ast-ksh.txt
+
+ if use nls; then
+ dodir /usr/share
+ mv ${S}/share/lib/locale ${D}/usr/share
+ fi
+}