summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-08-02 19:23:44 +0000
committerAron Griffis <agriffis@gentoo.org>2004-08-02 19:23:44 +0000
commitdbeb4dc9845e0dd082e370975a8c6eb5ebd30dc8 (patch)
tree187ba61252654f273afae56f913fa4a69c0370d0 /app-shells
parentNew portage (diff)
downloadhistorical-dbeb4dc9845e0dd082e370975a8c6eb5ebd30dc8.tar.gz
historical-dbeb4dc9845e0dd082e370975a8c6eb5ebd30dc8.tar.bz2
historical-dbeb4dc9845e0dd082e370975a8c6eb5ebd30dc8.zip
Fix bug 58961 with patch from Chet Ramey to prevent segfault
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog8
-rw-r--r--app-shells/bash/Manifest7
-rw-r--r--app-shells/bash/bash-3.0-r4.ebuild (renamed from app-shells/bash/bash-3.0-r3.ebuild)7
-rw-r--r--app-shells/bash/files/bash-3.0-local-array.patch15
-rw-r--r--app-shells/bash/files/digest-bash-3.0-r4 (renamed from app-shells/bash/files/digest-bash-3.0-r3)0
5 files changed, 32 insertions, 5 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 54e50361b99f..8c83c1b00c16 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/bash
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.44 2004/08/02 18:17:59 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.45 2004/08/02 19:23:44 agriffis Exp $
+
+*bash-3.0-r4 (02 Aug 2004)
+
+ 02 Aug 2004; Aron Griffis <agriffis@gentoo.org>
+ +files/bash-3.0-local-array.patch, -bash-3.0-r3.ebuild, +bash-3.0-r4.ebuild:
+ Fix bug 58961 with patch from Chet Ramey to prevent segfault
*bash-3.0-r3 (02 Aug 2004)
diff --git a/app-shells/bash/Manifest b/app-shells/bash/Manifest
index b4a7539eb4c9..51ca22375f9a 100644
--- a/app-shells/bash/Manifest
+++ b/app-shells/bash/Manifest
@@ -1,5 +1,5 @@
-MD5 777d4d3233bd8685305fbbb65b5cca23 bash-3.0-r3.ebuild 3904
-MD5 d5e93e2cdb862776b175667e7fc5a218 ChangeLog 9614
+MD5 c448f3d06446b93f6c02b01a4d9f2733 ChangeLog 9835
+MD5 a3a5f5e1cfbb02d35f055dae074bf237 bash-3.0-r4.ebuild 4119
MD5 9b26b6899167a29ee4e9c1ad0d39b5a1 bash-2.05b-r9.ebuild 2909
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 6a2f5ace1a2dd30b1bee55eba1509027 bash-2.05b-r10.ebuild 3041
@@ -9,9 +9,10 @@ MD5 4383b25cd54b24b9f459e338f06d096c files/bash-2.05b-parallel-build.patch 459
MD5 3b905c7c9341c9009bd68f14c047815e files/bash-2.05b-rbash.patch 804
MD5 582fb9ed0ca44627978ce6836a5000dc files/config-top.h.diff 487
MD5 694b8b1e47e4743e78ee5f7515f76542 files/bash-3.0-posixtrap.patch 789
-MD5 30a9ff1b688e79f59376a47d882f3419 files/digest-bash-3.0-r3 128
MD5 1894aaae72806c410d851d046d13dd32 files/digest-bash-2.05b-r9 461
MD5 92f8f2d44177d92edd757366dbd261dc files/bashrc 761
MD5 1894aaae72806c410d851d046d13dd32 files/digest-bash-2.05b-r10 461
MD5 280727f35468e5deaadec039679ee5e8 files/bash-3.0-invisible.patch 601
+MD5 30a9ff1b688e79f59376a47d882f3419 files/digest-bash-3.0-r4 128
MD5 4a3ebcb995491c2730d156b314cbab0b files/bash-3.0-etc-inputrc.patch 1223
+MD5 0392b634a7a02302d24ccc4a4b349423 files/bash-3.0-local-array.patch 275
diff --git a/app-shells/bash/bash-3.0-r3.ebuild b/app-shells/bash/bash-3.0-r4.ebuild
index dbd7b0c3b25f..9cbff2de90d9 100644
--- a/app-shells/bash/bash-3.0-r3.ebuild
+++ b/app-shells/bash/bash-3.0-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r3.ebuild,v 1.1 2004/08/02 18:17:59 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r4.ebuild,v 1.1 2004/08/02 19:23:44 agriffis Exp $
inherit eutils flag-o-matic gnuconfig
@@ -63,6 +63,11 @@ src_unpack() {
# user creates a ~/.inputrc
epatch ${FILESDIR}/${P}-etc-inputrc.patch
+ # Chet Ramey (upstream maintainer) provided this patch in
+ # http://news.gmane.org/gmane.comp.shells.bash.bugs/cutoff=4115
+ # to fix bug 58961 (segfault on local arrays)
+ epatch ${FILESDIR}/${P}-local-array.patch
+
# Enable SSH_SOURCE_BASHRC (#24762)
echo '#define SSH_SOURCE_BASHRC' >> config-top.h
diff --git a/app-shells/bash/files/bash-3.0-local-array.patch b/app-shells/bash/files/bash-3.0-local-array.patch
new file mode 100644
index 000000000000..2aea13c9f24f
--- /dev/null
+++ b/app-shells/bash/files/bash-3.0-local-array.patch
@@ -0,0 +1,15 @@
+*** ../bash-3.0/arrayfunc.c Fri Dec 19 00:03:09 2003
+--- arrayfunc.c Sun Aug 1 20:43:00 2004
+***************
+*** 612,616 ****
+
+ free (t);
+! return var;
+ }
+
+--- 612,616 ----
+
+ free (t);
+! return (var == 0 || invisible_p (var)) ? (SHELL_VAR *)0 : var;
+ }
+
diff --git a/app-shells/bash/files/digest-bash-3.0-r3 b/app-shells/bash/files/digest-bash-3.0-r4
index b3fb57628169..b3fb57628169 100644
--- a/app-shells/bash/files/digest-bash-3.0-r3
+++ b/app-shells/bash/files/digest-bash-3.0-r4