summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-03-16 18:38:47 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-03-16 18:38:47 +0000
commit5a73a178efff071e7d4ecb76383911befa399089 (patch)
tree866b3041b084ccd0ea18b8f83e3790c4d1cdea00 /app-text/antiword
parentNew version (diff)
downloadhistorical-5a73a178efff071e7d4ecb76383911befa399089.tar.gz
historical-5a73a178efff071e7d4ecb76383911befa399089.tar.bz2
historical-5a73a178efff071e7d4ecb76383911befa399089.zip
sed fix
Diffstat (limited to 'app-text/antiword')
-rw-r--r--app-text/antiword/ChangeLog6
-rw-r--r--app-text/antiword/antiword-0.32.ebuild21
2 files changed, 18 insertions, 9 deletions
diff --git a/app-text/antiword/ChangeLog b/app-text/antiword/ChangeLog
index 3bc46adec592..cb516a51530e 100644
--- a/app-text/antiword/ChangeLog
+++ b/app-text/antiword/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for app-text/antiword
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/antiword/ChangeLog,v 1.7 2003/03/09 14:54:43 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/antiword/ChangeLog,v 1.8 2003/03/16 18:38:47 seemant Exp $
08 Mar 2003; Seemant Kulleen <seemant@gentoo.org> antiword-0.33.ebuild :
@@ -11,6 +11,10 @@
*antiword-0.32 (1 Feb 2002)
+ 16 Mar 2003; Seemant Kulleen <seemant@gentoo.org> antiword-0.32.ebuild:
+ same fix for antiword-0.32, thanks to: Jean Jordaan
+ <jean@upfrontsystems.co.za> in bug #17606
+
17 Oct 2002; Daniel Ahlberg <aliz@gentoo.org> antiword-0.32.ebuild, antiword-0.33.ebuild :
Added IUSE.
diff --git a/app-text/antiword/antiword-0.32.ebuild b/app-text/antiword/antiword-0.32.ebuild
index 19f1a006568a..6ac4b2e2e8a4 100644
--- a/app-text/antiword/antiword-0.32.ebuild
+++ b/app-text/antiword/antiword-0.32.ebuild
@@ -1,28 +1,33 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/antiword/antiword-0.32.ebuild,v 1.11 2003/03/01 04:12:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/antiword/antiword-0.32.ebuild,v 1.12 2003/03/16 18:38:47 seemant Exp $
+inherit eutils
+
+IUSE="kde"
+
+S=${WORKDIR}/${PN}.${PV}
DESCRIPTION="free MS Word reader for Linux and RISC OS"
SRC_URI="http://www.winfield.demon.nl/linux/${P}.tar.gz"
HOMEPAGE="http://www.winfield.demon.nl"
-IUSE="kde"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc sparc"
-DEPEND="app-text/ghostscript"
-
-S=${WORKDIR}/${PN}.${PV}
+DEPEND=">=sys-apps/sed-4.0.5
+ app-text/ghostscript"
src_unpack() {
unpack ${A}
cd ${S}
- patch -p0 < ${FILESDIR}/gentoo-antiword.diff
+ epatch ${FILESDIR}/gentoo-antiword.diff
- sed -e '/pedantic/d' -e 's/$(CFLAGS)/$(CFLAGS) -D$(DB)/' \
- Makefile.Linux > Makefile
+ sed -i \
+ -e '/pedantic/d' \
+ -e 's/$(CFLAGS)/$(CFLAGS) -D$(DB)/' \
+ Makefile.Linux
}
src_compile() {