summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-28 03:59:30 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-28 03:59:30 +0000
commit21917ca4bf0ba5a62865a75fd3c3113a5aa03a64 (patch)
tree1bf9fa56ae77a674e1cc217886a64b3237a3d019 /app-text/passivetex
parentversion bump, and cleanup of old ebuilds (diff)
downloadhistorical-21917ca4bf0ba5a62865a75fd3c3113a5aa03a64.tar.gz
historical-21917ca4bf0ba5a62865a75fd3c3113a5aa03a64.tar.bz2
historical-21917ca4bf0ba5a62865a75fd3c3113a5aa03a64.zip
cleanup
Diffstat (limited to 'app-text/passivetex')
-rw-r--r--app-text/passivetex/passivetex-1.4.ebuild24
1 files changed, 12 insertions, 12 deletions
diff --git a/app-text/passivetex/passivetex-1.4.ebuild b/app-text/passivetex/passivetex-1.4.ebuild
index f014eea3869b..a0387608db2f 100644
--- a/app-text/passivetex/passivetex-1.4.ebuild
+++ b/app-text/passivetex/passivetex-1.4.ebuild
@@ -1,38 +1,38 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Your Name <your email>
-# $Header: /var/cvsroot/gentoo-x86/app-text/passivetex/passivetex-1.4.ebuild,v 1.2 2001/06/03 09:54:22 achim Exp $
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/passivetex/passivetex-1.4.ebuild,v 1.3 2002/04/28 03:59:29 seemant Exp $
-A=passivetex.zip
S=${WORKDIR}/passivetex
DESCRIPTION="A namespace-aware XML parser written in Tex"
-SRC_URI="http://users.ox.ac.uk/~rahtz/passivetex/${A}"
+SRC_URI="http://users.ox.ac.uk/~rahtz/passivetex/${PN}.zip"
HOMEPAGE="http://users.ox.ac.uk/~rahtz/passivetex/"
DEPEND="app-text/tetex app-arch/unzip
app-text/xmltex"
RDEPEND="app-text/tetex
app-text/xmltex"
+
src_unpack() {
- mkdir ${S}
- cd ${S}
- unpack ${A}
- cp ${FILESDIR}/${P}-Makefile Makefile
+ mkdir ${S}
+ cd ${S}
+ unpack ${A}
+ cp ${FILESDIR}/${P}-Makefile Makefile
}
src_compile() {
- try make
+ make || die
}
src_install () {
- try make DESTDIR=${D} install
+ make DESTDIR=${D} install || die
}
pkg_postinst() {
if [ -e /usr/bin/mktexlsr ]
then
- /usr/bin/mktexlsr
+ /usr/bin/mktexlsr
fi
}