summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2004-10-18 23:25:42 +0000
committerAndrej Kacian <ticho@gentoo.org>2004-10-18 23:25:42 +0000
commitadb711f79c3a836ad39ac3c2b54e4164e2d21033 (patch)
tree83ea69ab17b7767bf30b9a4df9fc9018b74b22d7 /app-text
parentemergancy glibc fix for ppc64, fixed as to not affect any other architecture (diff)
downloadhistorical-adb711f79c3a836ad39ac3c2b54e4164e2d21033.tar.gz
historical-adb711f79c3a836ad39ac3c2b54e4164e2d21033.tar.bz2
historical-adb711f79c3a836ad39ac3c2b54e4164e2d21033.zip
Initial version. Closes #21874.
Diffstat (limited to 'app-text')
-rw-r--r--app-text/tuxcards/ChangeLog11
-rw-r--r--app-text/tuxcards/Manifest14
-rw-r--r--app-text/tuxcards/files/digest-tuxcards-1.11
-rw-r--r--app-text/tuxcards/metadata.xml9
-rw-r--r--app-text/tuxcards/tuxcards-1.1.ebuild32
5 files changed, 67 insertions, 0 deletions
diff --git a/app-text/tuxcards/ChangeLog b/app-text/tuxcards/ChangeLog
new file mode 100644
index 000000000000..2ea2ffe3dae6
--- /dev/null
+++ b/app-text/tuxcards/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-text/tuxcards
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/tuxcards/ChangeLog,v 1.1 2004/10/18 23:25:42 ticho Exp $
+
+*tuxcards-1.1 (19 Oct 2004)
+
+ 19 Oct 2004; Andrej Kacian <ticho@gentoo.org> +metadata.xml,
+ +tuxcards-1.1.ebuild:
+ Initial version. Ebuild submitted by Daniele Foci <sunscan@sunscan.org> and
+ Bruce Chiarelli <meno15@juno.com>. Closes #21874.
+
diff --git a/app-text/tuxcards/Manifest b/app-text/tuxcards/Manifest
new file mode 100644
index 000000000000..05c89a849026
--- /dev/null
+++ b/app-text/tuxcards/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 024b00f2a3977a49f12ef66a3665348c ChangeLog 453
+MD5 7dbb92cd2f9678d8a28634c532431cf4 metadata.xml 254
+MD5 14ffb81f1c7eb275fba7847551e4fca1 tuxcards-1.1.ebuild 824
+MD5 7496f3cc8989aa48c37967ab36dcd0af files/digest-tuxcards-1.1 64
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+
+iD8DBQFBdFD+10xuJSrg3/sRAkIwAKCAJojlnS+/z712XmfZ1hO7iHcz1ACeLnEx
+uQcxAFbCnnU5/utIKC8XcuM=
+=1/Fj
+-----END PGP SIGNATURE-----
diff --git a/app-text/tuxcards/files/digest-tuxcards-1.1 b/app-text/tuxcards/files/digest-tuxcards-1.1
new file mode 100644
index 000000000000..dc02828d7fff
--- /dev/null
+++ b/app-text/tuxcards/files/digest-tuxcards-1.1
@@ -0,0 +1 @@
+MD5 711da6fdabacd4c5f3a2491ca29fef36 tuxcards-1.1.tar.gz 233649
diff --git a/app-text/tuxcards/metadata.xml b/app-text/tuxcards/metadata.xml
new file mode 100644
index 000000000000..a026b68689a7
--- /dev/null
+++ b/app-text/tuxcards/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>ticho@gentoo.org</email>
+ <name>Andrej Kacian></name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-text/tuxcards/tuxcards-1.1.ebuild b/app-text/tuxcards/tuxcards-1.1.ebuild
new file mode 100644
index 000000000000..106bcab5777d
--- /dev/null
+++ b/app-text/tuxcards/tuxcards-1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/tuxcards/tuxcards-1.1.ebuild,v 1.1 2004/10/18 23:25:42 ticho Exp $
+
+DESCRIPTION="A heirarchical text editor"
+HOMEPAGE="http://www.tuxcards.de"
+
+SRC_URI="http://www.tifskom.de/tux/1.1/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=qt-3.1.1"
+
+src_compile() {
+ sed -e 's:/usr/local:/usr:g' \
+ -e 's:/usr/doc/tuxcards:/usr/share/tuxcards:g' tuxcards.pro > tuxpro && \
+ mv tuxpro tuxcards.pro
+ sed -e 's:/usr/local/doc:/usr/share:g' src/tuxcardsconfiguration.cpp > temp && \
+ mv temp src/tuxcardsconfiguration.cpp
+ qmake tuxcards.pro
+
+ emake || die
+}
+
+src_install() {
+ make INSTALL_ROOT=${D} install || die
+
+ dodoc AUTHORS COPYING INSTALL README
+}