summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2004-12-02 16:21:29 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2004-12-02 16:21:29 +0000
commit79ce87cc120bd0e2b89c4619c41d575790123cae (patch)
tree22ab6da3423df541d3e5a93c554668a1cb236099 /app-vim
parentQA: need-kde() after R/DEPEND (diff)
downloadhistorical-79ce87cc120bd0e2b89c4619c41d575790123cae.tar.gz
historical-79ce87cc120bd0e2b89c4619c41d575790123cae.tar.bz2
historical-79ce87cc120bd0e2b89c4619c41d575790123cae.zip
New version. Fixes bugsummary menus (bug #72888) and adds support for intelligent ebuild/eclass creation based upon context.
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/gentoo-syntax/ChangeLog9
-rw-r--r--app-vim/gentoo-syntax/Manifest10
-rw-r--r--app-vim/gentoo-syntax/files/digest-gentoo-syntax-200412021
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20041202.ebuild52
4 files changed, 67 insertions, 5 deletions
diff --git a/app-vim/gentoo-syntax/ChangeLog b/app-vim/gentoo-syntax/ChangeLog
index 641d4f712532..16a2794fb383 100644
--- a/app-vim/gentoo-syntax/ChangeLog
+++ b/app-vim/gentoo-syntax/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-vim/gentoo-syntax
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/ChangeLog,v 1.19 2004/11/27 18:21:11 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/ChangeLog,v 1.20 2004/12/02 16:21:28 ciaranm Exp $
+
+*gentoo-syntax-20041202 (02 Dec 2004)
+
+ 02 Dec 2004; Ciaran McCreesh <ciaranm@gentoo.org>
+ +gentoo-syntax-20041202.ebuild:
+ New version. Fixes bugsummary menus (bug #72888) and adds support for
+ intelligent ebuild/eclass creation based upon context.
*gentoo-syntax-20041127 (27 Nov 2004)
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index 46b535f9ce29..d74ebdcff342 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,20 +1,22 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 400630667dde7fc746283b1dc158183d ChangeLog 3854
+MD5 bafa69f3eaac1bacab8ac169baea32e1 ChangeLog 4109
MD5 e41083dd32639423a4bbb351d67201ce gentoo-syntax-20041113.ebuild 1836
MD5 a8fcba96f97e87e500b968639f33ed99 gentoo-syntax-20041009.ebuild 649
MD5 f979fba52fe7580548880aee923f638b gentoo-syntax-20041127.ebuild 1839
MD5 f5c80e20f22edcfe2e30e08177ccdf02 gentoo-syntax-20041121.ebuild 1839
MD5 9771ca4ff90b56dddc4acfadc6f6a01e metadata.xml 250
+MD5 905f0ccf9beda24f9a8dd6a42ceb1c31 gentoo-syntax-20041202.ebuild 1839
MD5 a8a32028435572bf714cacd280ac4335 files/digest-gentoo-syntax-20041127 74
MD5 8ae17c577573d3654205f007a4ecb6ce files/digest-gentoo-syntax-20041113 73
MD5 aec43637a5435dc556d7e4803becaf0e files/digest-gentoo-syntax-20041121 73
+MD5 b5f329b0b88bc9f4ab39100919448b1f files/digest-gentoo-syntax-20041202 74
MD5 af854ba426622a145f3f786c605ff98c files/digest-gentoo-syntax-20041009 73
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)
-iD8DBQFBqMWQLLFUmVNQ7rkRAv90AJ9nXxupTOgIS4pIR1UmswODr7TOswCgjte/
-GDl2Y6g2bISZqV+xKc87xzU=
-=C9vX
+iD8DBQFBr0ECLLFUmVNQ7rkRAg7dAJ9fflF9M7n/bB9kFZ6kJcndcZuiFgCfSrzK
+ZdIuHLrYrFgZrbA5iQAD0kw=
+=4RGB
-----END PGP SIGNATURE-----
diff --git a/app-vim/gentoo-syntax/files/digest-gentoo-syntax-20041202 b/app-vim/gentoo-syntax/files/digest-gentoo-syntax-20041202
new file mode 100644
index 000000000000..8237f2984769
--- /dev/null
+++ b/app-vim/gentoo-syntax/files/digest-gentoo-syntax-20041202
@@ -0,0 +1 @@
+MD5 7d925311bd8dc6bdd2069cb6783a29aa gentoo-syntax-20041202.tar.bz2 12510
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20041202.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20041202.ebuild
new file mode 100644
index 000000000000..687f820f533f
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20041202.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/gentoo-syntax-20041202.ebuild,v 1.1 2004/12/02 16:21:28 ciaranm Exp $
+
+inherit eutils vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo Ebuild, Eclass, GLEP, ChangeLog and Portage
+Files syntax highlighting, filetype and indent settings"
+HOMEPAGE="http://developer.berlios.de/projects/gentoo-syntax"
+LICENSE="vim"
+KEYWORDS="~x86 ~sparc ~mips ~amd64 ~ppc ~ppc64 ~alpha ~ia64"
+SRC_URI="http://download.berlios.de/gentoo-syntax/${P}.tar.bz2"
+
+# For gathering stats. Evil, I know, but I need to know whether I can
+# reasonably add this package in as a PDEPEND of vim-core. -- ciaranm
+RESTRICT="nomirror"
+
+IUSE="ignore-glep31"
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ else
+ einfo "Note for developers and anyone else who edits ebuilds:"
+ einfo " This release of gentoo-syntax now contains filetype rules to set"
+ einfo " fileencoding for ebuilds and ChangeLogs to utf-8 as per GLEP 31."
+ einfo " If you find this feature breaks things, please submit a bug and"
+ einfo " assign it to vim@gentoo.org. You can use the 'ignore-glep31' USE"
+ einfo " flag to remove these rules."
+ fi
+ echo
+ epause 5
+}
+