summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-09-19 12:19:59 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-09-19 12:19:59 +0000
commit926f5027e957c3706d3399c4991dfea2837d372c (patch)
tree89d0614fab8c845987490a4cc2baacae8b462d8a /dev-cpp/libgnomecanvasmm/libgnomecanvasmm-2.12.0.ebuild
parentcrlf fix thanks to James Rowe in bug #106246 (diff)
downloadhistorical-926f5027e957c3706d3399c4991dfea2837d372c.tar.gz
historical-926f5027e957c3706d3399c4991dfea2837d372c.tar.bz2
historical-926f5027e957c3706d3399c4991dfea2837d372c.zip
Version bump.
Package-Manager: portage-2.0.52-r1
Diffstat (limited to 'dev-cpp/libgnomecanvasmm/libgnomecanvasmm-2.12.0.ebuild')
-rw-r--r--dev-cpp/libgnomecanvasmm/libgnomecanvasmm-2.12.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-cpp/libgnomecanvasmm/libgnomecanvasmm-2.12.0.ebuild b/dev-cpp/libgnomecanvasmm/libgnomecanvasmm-2.12.0.ebuild
new file mode 100644
index 000000000000..55e5f76bc28c
--- /dev/null
+++ b/dev-cpp/libgnomecanvasmm/libgnomecanvasmm-2.12.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libgnomecanvasmm/libgnomecanvasmm-2.12.0.ebuild,v 1.1 2005/09/19 12:15:06 ka0ttic Exp $
+
+inherit gnome2
+
+DESCRIPTION="C++ bindings for libgnomecanvas"
+HOMEPAGE="http://gtkmm.sourceforge.net/"
+
+LICENSE="LGPL-2.1"
+SLOT="2.6"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND=">=gnome-base/libgnomecanvas-2.6
+ >=dev-cpp/gtkmm-2.4"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( app-doc/doxygen )"
+
+DOCS="AUTHORS COPYING ChangeLog NEWS README TODO INSTALL"
+
+src_compile() {
+ if useq amd64; then
+ libtoolize --copy --force
+ aclocal -I scripts
+ autoconf
+ automake -c -f
+ fi
+
+ gnome2_src_compile
+
+ if use doc ; then
+ einfo "Building API documentation"
+ cd docs/reference
+ emake || die "failed to build API docs"
+ fi
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use doc ; then
+ cd docs/reference
+ dohtml -r html/*
+ fi
+}