summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-03-25 03:24:53 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-03-25 03:24:53 +0000
commit006e903ab31e72e43c41d9b575d917a8e808ef9b (patch)
tree3d8b0e96013c05dcd2f74a497339de38bafea3d8 /dev-db/libdbi-drivers
parentMarked stable on sparc. (diff)
downloadhistorical-006e903ab31e72e43c41d9b575d917a8e808ef9b.tar.gz
historical-006e903ab31e72e43c41d9b575d917a8e808ef9b.tar.bz2
historical-006e903ab31e72e43c41d9b575d917a8e808ef9b.zip
Initial commit. Original ebuild submitted by Max <m.e.bruche@lse.ac.uk>. Bug #45153.
Diffstat (limited to 'dev-db/libdbi-drivers')
-rw-r--r--dev-db/libdbi-drivers/ChangeLog11
-rw-r--r--dev-db/libdbi-drivers/Manifest2
-rw-r--r--dev-db/libdbi-drivers/files/digest-libdbi-drivers-0.7.11
-rw-r--r--dev-db/libdbi-drivers/libdbi-drivers-0.7.1.ebuild32
4 files changed, 46 insertions, 0 deletions
diff --git a/dev-db/libdbi-drivers/ChangeLog b/dev-db/libdbi-drivers/ChangeLog
new file mode 100644
index 000000000000..af929319f5f6
--- /dev/null
+++ b/dev-db/libdbi-drivers/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-db/libdbi-drivers
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/libdbi-drivers/ChangeLog,v 1.1 2004/03/25 03:24:53 robbat2 Exp $
+
+*libdbi-drivers-0.7.1 (24 Mar 2004)
+
+ 24 Mar 2004; Robin H. Johnson <robbat2@gentoo.org>
+ libdbi-drivers-0.7.1.ebuild:
+ Initial commit. Original ebuild submitted by Max <m.e.bruche@lse.ac.uk>. Bug
+ #45153.
+
diff --git a/dev-db/libdbi-drivers/Manifest b/dev-db/libdbi-drivers/Manifest
new file mode 100644
index 000000000000..8b2840bde469
--- /dev/null
+++ b/dev-db/libdbi-drivers/Manifest
@@ -0,0 +1,2 @@
+MD5 5f7ec902fdfab6e8ac2ef06998d90020 libdbi-drivers-0.7.1.ebuild 863
+MD5 773b07f27a69df8943d40fea56b1c36e files/digest-libdbi-drivers-0.7.1 72
diff --git a/dev-db/libdbi-drivers/files/digest-libdbi-drivers-0.7.1 b/dev-db/libdbi-drivers/files/digest-libdbi-drivers-0.7.1
new file mode 100644
index 000000000000..836a39fb827e
--- /dev/null
+++ b/dev-db/libdbi-drivers/files/digest-libdbi-drivers-0.7.1
@@ -0,0 +1 @@
+MD5 f11020119ceb7a6dee3969cb0589d4bc libdbi-drivers-0.7.1.tar.gz 488642
diff --git a/dev-db/libdbi-drivers/libdbi-drivers-0.7.1.ebuild b/dev-db/libdbi-drivers/libdbi-drivers-0.7.1.ebuild
new file mode 100644
index 000000000000..41c0199020b8
--- /dev/null
+++ b/dev-db/libdbi-drivers/libdbi-drivers-0.7.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="The libdbi-drivers project maintains drivers for libdbi."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://${PN}.sourceforge.net/"
+LICENSE="LGPL-2.1"
+DEPEND="dev-db/libdbi"
+IUSE="mysql postgres sqlite oci8"
+KEYWORDS="~x86"
+SLOT=0
+
+src_compile() {
+ local myconf=""
+ local drivers=""
+ use mysql && drivers="${drivers} mysql" myconf="${myconf} --with-mysql"
+ use postgres && drivers="${drivers} pgsql" myconf="${myconf} --with-pgsql"
+ use sqlite && drivers="${drivers} sqlite" myconf="${myconf} --with-sqlite"
+ use oci8 && [ -n "${ORACLE_HOME}" ] && myconf="${myconf} --with-oracle --with-oracle-dir=${ORACLE_HOME}" drivers="${drivers} oracle"
+
+ if [ -z "${drivers}" ]; then
+ die "You have not specified any supported databases in your use flags (mysql, pgsql, sqlite, oracle)"
+ fi
+
+ econf ${myconf}
+ emake
+}
+
+src_install () {
+ make install DESTDIR=${D} || die "make install failed"
+ dodoc AUTHORS ChangeLog COPYING NEWS README README.osx TODO
+}