summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-08 11:16:36 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-08 11:16:36 +0000
commitb8cf36593ae76911a9cd8e17cccc617669203182 (patch)
tree854494081b639a378ac7173c381d6c5014c46db5 /dev-db/sqlite
parentVersion bump. (diff)
downloadhistorical-b8cf36593ae76911a9cd8e17cccc617669203182.tar.gz
historical-b8cf36593ae76911a9cd8e17cccc617669203182.tar.bz2
historical-b8cf36593ae76911a9cd8e17cccc617669203182.zip
Delete older ebuilds.
Diffstat (limited to 'dev-db/sqlite')
-rw-r--r--dev-db/sqlite/files/sqlite-3.6.14.2-fix_alignment.patch30
-rw-r--r--dev-db/sqlite/files/sqlite-3.6.16-tkt3922.test.patch25
-rw-r--r--dev-db/sqlite/files/sqlite-3.6.17-fix_installation.patch116
-rw-r--r--dev-db/sqlite/sqlite-3.6.14.2.ebuild88
-rw-r--r--dev-db/sqlite/sqlite-3.6.17.ebuild88
-rw-r--r--dev-db/sqlite/sqlite-3.6.18.ebuild110
6 files changed, 0 insertions, 457 deletions
diff --git a/dev-db/sqlite/files/sqlite-3.6.14.2-fix_alignment.patch b/dev-db/sqlite/files/sqlite-3.6.14.2-fix_alignment.patch
deleted file mode 100644
index fe7ee13bc7a4..000000000000
--- a/dev-db/sqlite/files/sqlite-3.6.14.2-fix_alignment.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- src/rowset.c
-+++ src/rowset.c
-@@ -60,7 +60,7 @@
- ** There is an added cost of O(N) when switching between TEST and
- ** SMALLEST primitives.
- **
--** $Id: rowset.c,v 1.6 2009/04/22 15:32:59 drh Exp $
-+** $Id: rowset.c,v 1.7 2009/05/22 01:00:13 drh Exp $
- */
- #include "sqliteInt.h"
-
-@@ -127,15 +127,15 @@
- */
- RowSet *sqlite3RowSetInit(sqlite3 *db, void *pSpace, unsigned int N){
- RowSet *p;
-- assert( N >= sizeof(*p) );
-+ assert( N >= ROUND8(sizeof(*p)) );
- p = pSpace;
- p->pChunk = 0;
- p->db = db;
- p->pEntry = 0;
- p->pLast = 0;
- p->pTree = 0;
-- p->pFresh = (struct RowSetEntry*)&p[1];
-- p->nFresh = (u16)((N - sizeof(*p))/sizeof(struct RowSetEntry));
-+ p->pFresh = (struct RowSetEntry*)(ROUND8(sizeof(*p)) + (char*)p);
-+ p->nFresh = (u16)((N - ROUND8(sizeof(*p)))/sizeof(struct RowSetEntry));
- p->isSorted = 1;
- p->iBatch = 0;
- return p;
diff --git a/dev-db/sqlite/files/sqlite-3.6.16-tkt3922.test.patch b/dev-db/sqlite/files/sqlite-3.6.16-tkt3922.test.patch
deleted file mode 100644
index a3e0fadf8e08..000000000000
--- a/dev-db/sqlite/files/sqlite-3.6.16-tkt3922.test.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-http://www.sqlite.org/cvstrac/tktview?tn=3951
-
---- test/tkt3922.test
-+++ test/tkt3922.test
-@@ -36,20 +36,6 @@
- }
- } {-1 integer}
- }
--do_test tkt3922.2 {
-- execsql {
-- DELETE FROM t1;
-- INSERT INTO t1 VALUES('-9223372036854775809');
-- SELECT a, typeof(a) FROM t1;
-- }
--} {-9.22337203685478e+18 real}
--do_test tkt3922.3 {
-- execsql {
-- DELETE FROM t1;
-- INSERT INTO t1 VALUES('-9223372036854776832');
-- SELECT a, typeof(a) FROM t1;
-- }
--} {-9.22337203685478e+18 real}
- do_test tkt3922.4 {
- execsql {
- DELETE FROM t1;
diff --git a/dev-db/sqlite/files/sqlite-3.6.17-fix_installation.patch b/dev-db/sqlite/files/sqlite-3.6.17-fix_installation.patch
deleted file mode 100644
index 2b6c2ab405af..000000000000
--- a/dev-db/sqlite/files/sqlite-3.6.17-fix_installation.patch
+++ /dev/null
@@ -1,116 +0,0 @@
-https://www.sqlite.org/cvstrac/tktview?tn=4016
-
---- Makefile.in
-+++ Makefile.in
-@@ -683,8 +683,7 @@
- $(LTCOMPILE) $(TEMP_STORE) -c $(TOP)/src/status.c
-
- sqlite3.h: $(TOP)/src/sqlite.h.in
-- sed -e s/--VERS--/$(RELEASE)/ $(TOP)/src/sqlite.h.in | \
-- sed -e s/--VERSION-NUMBER--/$(VERSION_NUMBER)/ >sqlite3.h
-+ cat $(TOP)/src/sqlite.h.in | tclsh $(TOP)/tool/mksqlite3h.tcl `cat ${TOP}/VERSION` > sqlite3.h
-
- table.lo: $(TOP)/src/table.c $(HDR)
- $(LTCOMPILE) $(TEMP_STORE) -c $(TOP)/src/table.c
---- main.mk
-+++ main.mk
-@@ -389,9 +389,7 @@
- awk -f $(TOP)/addopcodes.awk parse.h.temp >parse.h
-
- sqlite3.h: $(TOP)/src/sqlite.h.in
-- sed -e s/--VERS--/`cat ${TOP}/VERSION`/ \
-- -e s/--VERSION-NUMBER--/`cat ${TOP}/VERSION | sed 's/[^0-9]/ /g' | $(NAWK) '{printf "%d%03d%03d",$$1,$$2,$$3}'`/ \
-- $(TOP)/src/sqlite.h.in >sqlite3.h
-+ cat $(TOP)/src/sqlite.h.in | tclsh $(TOP)/tool/mksqlite3h.tcl `cat ${TOP}/VERSION` > sqlite3.h
-
- keywordhash.h: $(TOP)/tool/mkkeywordhash.c
- $(BCC) -o mkkeywordhash $(OPTS) $(TOP)/tool/mkkeywordhash.c
---- tool/mksqlite3c.tcl
-+++ tool/mksqlite3c.tcl
-@@ -305,36 +305,3 @@
-
- close $out
-
--# This block overwrites the copy of sqlite3.h in the current directory.
--#
--# It copies tsrc/sqlite3.h to ./sqlite3.h, adding SQLITE_API in front of the
--# API functions and global variables as it goes.
--#
--set fd_in [open tsrc/sqlite3.h r]
--set fd_out [open sqlite3.h w]
--while {![eof $fd_in]} {
-- set varpattern {^[a-zA-Z][a-zA-Z_0-9 *]+sqlite3_[_a-zA-Z0-9]+(\[|;| =)}
-- set declpattern {^ *[a-zA-Z][a-zA-Z_0-9 ]+ \**sqlite3_[_a-zA-Z0-9]+\(}
--
-- set line [gets $fd_in]
-- if {[regexp {define SQLITE_EXTERN extern} $line]} {
-- puts $fd_out $line
-- puts $fd_out [gets $fd_in]
-- puts $fd_out ""
-- puts $fd_out "#ifndef SQLITE_API"
-- puts $fd_out "# define SQLITE_API"
-- puts $fd_out "#endif"
-- set line ""
-- }
--
-- if {([regexp $varpattern $line] && ![regexp {^ *typedef} $line])
-- || ([regexp $declpattern $line])
-- } {
-- set line "SQLITE_API $line"
-- }
-- puts $fd_out $line
--}
--close $fd_out
--close $fd_in
--
--
---- tool/mksqlite3h.tcl
-+++ tool/mksqlite3h.tcl
-@@ -0,0 +1,47 @@
-+#!/usr/bin/tclsh
-+#
-+# This script performs processing on src/sqlite.h.in. It:
-+#
-+# 1) Adds SQLITE_EXTERN in front of the declaration of global variables,
-+# 2) Adds SQLITE_API in front of the declaration of API functions,
-+# 3) Replaces the string --VERS-- with the current library version,
-+# formatted as a string (e.g. "3.6.17"), and
-+# 4) Replaces the string --VERSION-NUMBER-- with current library version,
-+# formatted as an integer (e.g. "3006017").
-+#
-+# This script reads from stdin, and outputs to stdout. The current library
-+# version number should be passed as the only argument. Example invocation:
-+#
-+# cat sqlite.h.in | mksqlite3h.tcl 3.6.17 > sqlite3.h
-+#
-+
-+set zVersion [lindex $argv 0]
-+set nVersion [eval format "%d%03d%03d" [split $zVersion .]]
-+
-+while {![eof stdin]} {
-+ set varpattern {^[a-zA-Z][a-zA-Z_0-9 *]+sqlite3_[_a-zA-Z0-9]+(\[|;| =)}
-+ set declpattern {^ *[a-zA-Z][a-zA-Z_0-9 ]+ \**sqlite3_[_a-zA-Z0-9]+\(}
-+
-+ set line [gets stdin]
-+
-+ regsub -- --VERS-- $line $zVersion line
-+ regsub -- --VERSION-NUMBER-- $line $nVersion line
-+
-+ if {[regexp {define SQLITE_EXTERN extern} $line]} {
-+ puts $line
-+ puts [gets stdin]
-+ puts ""
-+ puts "#ifndef SQLITE_API"
-+ puts "# define SQLITE_API"
-+ puts "#endif"
-+ set line ""
-+ }
-+
-+ if {([regexp $varpattern $line] && ![regexp {^ *typedef} $line])
-+ || ([regexp $declpattern $line])
-+ } {
-+ set line "SQLITE_API $line"
-+ }
-+ puts $line
-+}
-+
diff --git a/dev-db/sqlite/sqlite-3.6.14.2.ebuild b/dev-db/sqlite/sqlite-3.6.14.2.ebuild
deleted file mode 100644
index bbe07acf7761..000000000000
--- a/dev-db/sqlite/sqlite-3.6.14.2.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.14.2.ebuild,v 1.11 2009/07/27 17:02:15 nixnut Exp $
-
-EAPI="1"
-
-inherit eutils flag-o-matic multilib versionator
-
-DESCRIPTION="an SQL Database Engine in a C Library"
-HOMEPAGE="http://www.sqlite.org/"
-DOC_BASE="$(get_version_component_range 1-3)"
-DOC_PV="$(replace_all_version_separators _ ${DOC_BASE})"
-SRC_URI="http://www.sqlite.org/${P}.tar.gz
- doc? ( http://www.sqlite.org/${PN}_docs_${DOC_PV}.zip )"
-
-LICENSE="as-is"
-SLOT="3"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="debug doc soundex tcl +threadsafe"
-RESTRICT="!tcl? ( test )"
-
-RDEPEND="tcl? ( dev-lang/tcl )"
-DEPEND="${RDEPEND}
- doc? ( app-arch/unzip )"
-
-pkg_setup() {
- if has test ${FEATURES} ; then
- if ! has userpriv ${FEATURES} ; then
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
- fi
- if ! use tcl ; then
- ewarn "You must enable the tcl use flag if you want to run the testsuite."
- eerror "Testsuite will not be run."
- fi
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # note: this sandbox fix is no longer needed with sandbox-1.3+
- epatch "${FILESDIR}"/sandbox-fix2.patch
-
- epatch "${FILESDIR}/${P}-fix_alignment.patch"
-
- epunt_cxx
-}
-
-src_compile() {
- # Enable column metadata, bug #266651
- append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
-
- # not available via configure and requested in bug #143794
- use soundex && append-cppflags -DSQLITE_SOUNDEX
-
- econf \
- $(use_enable debug) \
- $(use_enable threadsafe) \
- $(use_enable threadsafe cross-thread-connections) \
- $(use_enable tcl)
- emake TCLLIBDIR="/usr/$(get_libdir)/${P}" || die "emake failed"
-}
-
-src_test() {
- if has userpriv ${FEATURES} ; then
- local test=test
- use debug && test=fulltest
- emake ${test} || die "some test(s) failed"
- fi
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- TCLLIBDIR="/usr/$(get_libdir)/${P}" \
- install \
- || die "emake install failed"
-
- doman sqlite3.1 || die
-
- if use doc ; then
- # Naming scheme changes randomly between - and _ in releases
- # http://www.sqlite.org/cvstrac/tktview?tn=3523
- dohtml -r "${WORKDIR}"/${PN}-${DOC_PV}-docs/* || die
- fi
-}
diff --git a/dev-db/sqlite/sqlite-3.6.17.ebuild b/dev-db/sqlite/sqlite-3.6.17.ebuild
deleted file mode 100644
index 019a35e768b1..000000000000
--- a/dev-db/sqlite/sqlite-3.6.17.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.17.ebuild,v 1.10 2009/09/30 17:11:04 klausman Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic multilib versionator
-
-DESCRIPTION="an SQL Database Engine in a C Library"
-HOMEPAGE="http://www.sqlite.org/"
-DOC_BASE="$(get_version_component_range 1-3)"
-DOC_PV="$(replace_all_version_separators _ ${DOC_BASE})"
-SRC_URI="http://www.sqlite.org/${P}.tar.gz
- doc? ( http://www.sqlite.org/${PN}_docs_${DOC_PV}.zip )
- !tcl? ( mirror://gentoo/sqlite3.h-${PV}.bz2 )"
-
-LICENSE="as-is"
-SLOT="3"
-KEYWORDS="alpha amd64 arm hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="debug doc +readline soundex tcl +threadsafe"
-RESTRICT="!tcl? ( test )"
-
-RDEPEND="readline? ( sys-libs/readline )
- tcl? ( dev-lang/tcl )"
-DEPEND="${RDEPEND}
- doc? ( app-arch/unzip )"
-
-src_prepare() {
- # note: this sandbox fix is no longer needed with sandbox-1.3+
- epatch "${FILESDIR}/sandbox-fix2.patch"
-
- epatch "${FILESDIR}/${PN}-3.6.16-tkt3922.test.patch"
- epatch "${FILESDIR}/${P}-fix_installation.patch"
-
- epunt_cxx
-}
-
-src_configure() {
- # Enable column metadata, bug #266651
- append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
-
- # not available via configure and requested in bug #143794
- use soundex && append-cppflags -DSQLITE_SOUNDEX
-
- econf \
- $(use_enable debug) \
- $(use_enable readline) \
- $(use_enable threadsafe) \
- $(use_enable threadsafe cross-thread-connections) \
- $(use_enable tcl)
-}
-
-src_compile() {
- use tcl || cp "${WORKDIR}/sqlite3.h-${PV}" sqlite3.h
- emake TCLLIBDIR="/usr/$(get_libdir)/${P}" || die "emake failed"
-}
-
-src_test() {
- if [[ "${EUID}" -ne "0" ]]; then
- local test=test
- use debug && test=fulltest
- emake ${test} || die "some test(s) failed"
- else
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
- fi
-
- if ! use tcl; then
- ewarn "You must enable the tcl USE flag if you want to run the testsuite."
- eerror "Testsuite will not be run."
- fi
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- TCLLIBDIR="/usr/$(get_libdir)/${P}" \
- install \
- || die "emake install failed"
-
- doman sqlite3.1 || die "doman sqlite3.1 failed"
-
- if use doc; then
- # Naming scheme changes randomly between - and _ in releases
- # http://www.sqlite.org/cvstrac/tktview?tn=3523
- dohtml -r "${WORKDIR}"/${PN}-${DOC_PV}-docs/* || die "dohtml failed"
- fi
-}
diff --git a/dev-db/sqlite/sqlite-3.6.18.ebuild b/dev-db/sqlite/sqlite-3.6.18.ebuild
deleted file mode 100644
index 2a34ac16e8e4..000000000000
--- a/dev-db/sqlite/sqlite-3.6.18.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.18.ebuild,v 1.8 2009/10/31 14:06:09 ranger Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic multilib versionator
-
-DESCRIPTION="an SQL Database Engine in a C Library"
-HOMEPAGE="http://www.sqlite.org/"
-DOC_BASE="$(get_version_component_range 1-3)"
-DOC_PV="$(replace_all_version_separators _ ${DOC_BASE})"
-SRC_URI="http://www.sqlite.org/${P}.tar.gz
- doc? ( http://www.sqlite.org/${PN}_docs_${DOC_PV}.zip )
- !tcl? ( mirror://gentoo/sqlite3.h-${PV}.bz2 )"
-
-LICENSE="as-is"
-SLOT="3"
-KEYWORDS="alpha amd64 ~arm hppa ~ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="debug doc icu +readline soundex tcl +threadsafe"
-RESTRICT="!tcl? ( test )"
-
-RDEPEND="icu? ( dev-libs/icu )
- readline? ( sys-libs/readline )
- tcl? ( dev-lang/tcl )"
-DEPEND="${RDEPEND}
- doc? ( app-arch/unzip )"
-
-pkg_setup() {
- if ! use tcl; then
- ewarn "Installation of SQLite with \"tcl\" USE flag enabled provides more (TCL-unrelated) functionality."
-
- if use icu; then
- ewarn "Support for ICU is enabled only when \"tcl\" USE flag is enabled."
- fi
-
- ebeep 1
- fi
-}
-
-src_prepare() {
- if use icu; then
- rm -f test/like.test
- fi
-
- epunt_cxx
-}
-
-src_configure() {
- # Support column metadata, bug #266651
- append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
-
- # Support R-trees, bug #257646
- # Avoid "./.libs/libsqlite3.so: undefined reference to `sqlite3RtreeInit'" during non-amalgamation building.
- if use tcl; then
- append-cppflags -DSQLITE_ENABLE_RTREE
- fi
-
- if use icu && use tcl; then
- append-cppflags -DSQLITE_ENABLE_ICU
- sed -e "s/TLIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
- fi
-
- # Support soundex, bug #143794
- use soundex && append-cppflags -DSQLITE_SOUNDEX
-
- econf \
- $(use_enable debug) \
- $(use_enable readline) \
- $(use_enable threadsafe) \
- $(use_enable threadsafe cross-thread-connections) \
- $(use_enable tcl)
-}
-
-src_compile() {
- use tcl || cp "${WORKDIR}/sqlite3.h-${PV}" sqlite3.h
- emake TCLLIBDIR="/usr/$(get_libdir)/${P}" || die "emake failed"
-}
-
-src_test() {
- if [[ "${EUID}" -ne "0" ]]; then
- local test=test
- use debug && test=fulltest
- emake ${test} || die "some test(s) failed"
- else
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
- fi
-
- if ! use tcl; then
- ewarn "You must enable the tcl USE flag if you want to run the testsuite."
- eerror "Testsuite will not be run."
- fi
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- TCLLIBDIR="/usr/$(get_libdir)/${P}" \
- install \
- || die "emake install failed"
-
- doman sqlite3.1 || die "doman sqlite3.1 failed"
-
- if use doc; then
- # Naming scheme changes randomly between - and _ in releases
- # http://www.sqlite.org/cvstrac/tktview?tn=3523
- dohtml -r "${WORKDIR}"/${PN}-${DOC_PV}-docs/* || die "dohtml failed"
- fi
-}