summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMasatomo Nakano <nakano@gentoo.org>2004-11-30 21:06:36 +0000
committerMasatomo Nakano <nakano@gentoo.org>2004-11-30 21:06:36 +0000
commit94effd1e730458ccb91b302a97d3102f386ee0b5 (patch)
treeee8b45fb0669f76d254bc62d56b355d78710054a /dev-db
parentrelease autoconf (diff)
downloadhistorical-94effd1e730458ccb91b302a97d3102f386ee0b5.tar.gz
historical-94effd1e730458ccb91b302a97d3102f386ee0b5.tar.bz2
historical-94effd1e730458ccb91b302a97d3102f386ee0b5.zip
Added xml2 support
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/postgresql/ChangeLog6
-rw-r--r--dev-db/postgresql/Manifest4
-rw-r--r--dev-db/postgresql/postgresql-8.0.0_beta5.ebuild13
3 files changed, 18 insertions, 5 deletions
diff --git a/dev-db/postgresql/ChangeLog b/dev-db/postgresql/ChangeLog
index 0021a5a779bc..1944244f712b 100644
--- a/dev-db/postgresql/ChangeLog
+++ b/dev-db/postgresql/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/postgresql
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.154 2004/11/23 10:42:55 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.155 2004/11/30 21:06:36 nakano Exp $
+
+ 30 Nov 2004; Masatomo Nakano <nakano@gentoo.org>
+ postgresql-8.0.0_beta5.ebuild:
+ Added xml2 support. (#72942)
*postgresql-8.0.0_beta5 (23 Nov 2004)
diff --git a/dev-db/postgresql/Manifest b/dev-db/postgresql/Manifest
index f5be29587c92..1a7c479a87f7 100644
--- a/dev-db/postgresql/Manifest
+++ b/dev-db/postgresql/Manifest
@@ -5,10 +5,10 @@ MD5 1d2540a8383fdae873c569307d3014cd postgresql-7.3.8.ebuild 7977
MD5 cb8662f9d01e3ff4dd5de9d375ae31f0 postgresql-7.4.6.ebuild 10142
MD5 43cd40217c38d9cb9b6a2449d50c8095 postgresql-7.3.7-r2.ebuild 7950
MD5 f21ab43b9a00dca552cd35c635241df7 postgresql-7.4.3.ebuild 9760
-MD5 f9d823272eeea631a072e73a94ed26e2 postgresql-8.0.0_beta5.ebuild 7051
+MD5 2db62bb18c2ae29b50c7f04440c59ac2 postgresql-8.0.0_beta5.ebuild 7232
MD5 fa39b30de3679dba54a788f4a4632e92 postgresql-7.4.5-r1.ebuild 10083
MD5 b5bf2b1222e5fa77a17b0163f0f22d25 postgresql-7.4.5.ebuild 10070
-MD5 eb206a5c1c597f2d98e4afe3fc902e3d ChangeLog 27750
+MD5 fd1c4b668a28a46bf78fbbc65a936797 ChangeLog 27866
MD5 f8d3d207746da2a3cd14dcaab8daab76 metadata.xml 163
MD5 cd9e32f5a21def1a4e2d1ac0e042aa47 files/postgresql-7.3.7-gentoo.patch 529
MD5 e9a2e5278a70bebace44f1ecf38129e6 files/postgresql-7.4.6-gentoo.patch 1160
diff --git a/dev-db/postgresql/postgresql-8.0.0_beta5.ebuild b/dev-db/postgresql/postgresql-8.0.0_beta5.ebuild
index 378f779208e8..c4d864bac9a9 100644
--- a/dev-db/postgresql/postgresql-8.0.0_beta5.ebuild
+++ b/dev-db/postgresql/postgresql-8.0.0_beta5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-8.0.0_beta5.ebuild,v 1.1 2004/11/23 10:42:55 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-8.0.0_beta5.ebuild,v 1.2 2004/11/30 21:06:36 nakano Exp $
inherit eutils gnuconfig flag-o-matic
@@ -17,7 +17,7 @@ SRC_URI="mirror://postgresql/source/v8.0.0beta/${PN}-base-${MY_PV}.tar.bz2
LICENSE="POSTGRESQL"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~s390 ~ppc64"
-IUSE="ssl nls python tcltk perl libg++ pam readline zlib doc"
+IUSE="ssl nls python tcltk perl libg++ pam readline xml2 zlib doc"
S=${WORKDIR}/${MY_P}
DEPEND="virtual/libc
@@ -30,6 +30,7 @@ DEPEND="virtual/libc
perl? ( >=dev-lang/perl-5.6.1-r2 )
python? ( >=dev-lang/python-2.2 dev-python/egenix-mx-base )
ssl? ( >=dev-libs/openssl-0.9.6-r1 )
+ xml2? ( dev-libs/libxml2 )
nls? ( sys-devel/gettext )"
RDEPEND="virtual/libc
app-admin/sudo
@@ -98,6 +99,10 @@ src_compile() {
make || die
cd contrib
make || die
+ if use xml2; then
+ cd xml2
+ make || die
+ fi
}
src_install() {
@@ -114,6 +119,10 @@ src_install() {
# make DESTDIR=${D} install-all-headers || die
cd ${S}/contrib
make DESTDIR=${D} LIBDIR=${D}/usr/lib install || die
+ if use xml2; then
+ cd ${S}/contrib/xml2
+ make DESTDIR=${D} LIBDIR=${D}/usr/lib install || die
+ fi
cd ${S}
if use pg-hier; then
dodoc ${WORKDIR}/README-${P_HIERPG}.html || die