summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorBrad House <brad_mssw@gentoo.org>2004-02-07 17:12:43 +0000
committerBrad House <brad_mssw@gentoo.org>2004-02-07 17:12:43 +0000
commite6a78d036aab7b85d71ee54d72fc33e9624ae121 (patch)
tree1585b5e262b5448177e0920fd7f0ff12bd50306f /dev-db
parentAdding entry to ChangeLog regarding me removing this package from the tree sh... (diff)
downloadhistorical-e6a78d036aab7b85d71ee54d72fc33e9624ae121.tar.gz
historical-e6a78d036aab7b85d71ee54d72fc33e9624ae121.tar.bz2
historical-e6a78d036aab7b85d71ee54d72fc33e9624ae121.zip
allow nptl-enabled build of mysql
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql/ChangeLog6
-rw-r--r--dev-db/mysql/files/mysql-gentoo-nptl.diff15
-rw-r--r--dev-db/mysql/mysql-4.0.17.ebuild9
3 files changed, 28 insertions, 2 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index 03294d8bfb49..400a2f87ebfc 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/mysql
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.85 2004/02/04 10:14:27 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.86 2004/02/07 17:12:43 brad_mssw Exp $
+
+ 07 Feb 2004; Brad House <brad_mssw@gentoo.org> mysql-4.0.17.ebuild,
+ files/mysql-gentoo-nptl.diff:
+ make mysql compile with nptl-enabled glibc
04 Feb 2004; Joshua Kinard <kumba@gentoo.org> mysql-4.0.17.ebuild:
Added ~mips to KEYWORDS and added a check for the berkdb USE flag if we're on
diff --git a/dev-db/mysql/files/mysql-gentoo-nptl.diff b/dev-db/mysql/files/mysql-gentoo-nptl.diff
new file mode 100644
index 000000000000..fabeb6cf423d
--- /dev/null
+++ b/dev-db/mysql/files/mysql-gentoo-nptl.diff
@@ -0,0 +1,15 @@
+diff -ruN mysql-4.0.17/configure.in mysql-4.0.17-nptl/configure.in
+--- mysql-4.0.17/configure.in 2003-12-14 16:23:49.000000000 -0500
++++ mysql-4.0.17-nptl/configure.in 2004-02-07 12:00:00.715528784 -0500
+@@ -1191,7 +1191,10 @@
+ then
+ # Look for LinuxThreads.
+ AC_MSG_CHECKING("LinuxThreads")
+- res=`grep Linuxthreads /usr/include/pthread.h 2>/dev/null | wc -l`
++ # res=`grep Linuxthreads /usr/include/pthread.h 2>/dev/null | wc -l`
++ # All gentoo systems support this stuff, and this is an improper detection
++ # for LinuxThreads anyhow, always set the result to 1
++ res=1
+ if test "$res" -gt 0
+ then
+ AC_MSG_RESULT("Found")
diff --git a/dev-db/mysql/mysql-4.0.17.ebuild b/dev-db/mysql/mysql-4.0.17.ebuild
index 4752d2b109ee..d583d34d0674 100644
--- a/dev-db/mysql/mysql-4.0.17.ebuild
+++ b/dev-db/mysql/mysql-4.0.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.17.ebuild,v 1.3 2004/02/04 10:14:27 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.17.ebuild,v 1.4 2004/02/07 17:12:43 brad_mssw Exp $
inherit eutils
#to accomodate -laadeedah releases
@@ -77,6 +77,9 @@ src_unpack() {
#for correct hardcoded sysconf directory
EPATCH_OPTS="-p1 -d ${S}" \
epatch ${FILESDIR}/${PN}-4.0-my-print-defaults.diff
+ #
+ unset EPATCH_OPTS
+ epatch ${FILESDIR}/${PN}-gentoo-nptl.diff
# attempt to get libmysqlclient_r linked against ssl if USE="ssl" enabled
# i would really prefer to fix this at the Makefile.am level, but can't
@@ -89,6 +92,10 @@ src_unpack() {
EPATCH_OPTS="-p1 -d ${S}" \
epatch ${FILESDIR}/${PN}-4.0.14-r1-tcpd-vars-fix.diff
fi
+
+ cd ${S}
+ autoconf
+ automake
}
src_compile() {